Support WCDMA Preferred option won't stick

Discussion in 'Android Devices' started by marcioefj, May 29, 2010.

  1. marcioefj

    marcioefj New Member
    5

    May 29, 2010
    4
    0
    5
    Hey guys!

    I just got my Milestone from Vivo (Brazil), but since Vivo is legally bound to unlock it upon request, I use it on TIM. It already came with android 2.1

    I am used to TIM's coverage in my region and I am noticing that Milestone hardly ever gets 3G signal on areas with good coverage on my old N95, except when I set it to WCDMA only, when it works great with 3g.

    However, since there are areas where 3g coverage is not available, I try to set it to WCDMA Preferred option with no success.
    As soon as I leave the screen settings go back to default (GSM Auto PRL) and 3G picks up for like 5 minutes in a whole day...

    Anyone's got the same issue? Know how to make the option stick? Is this a network restriction?
     

    Advertisement

  2. Blue1k

    Blue1k Well-Known Member
    93

    Oct 1, 2009
    608
    190
    93
    Teacher/Web Design
    Cloverdale, BC
    Did you access the menu typing *#*#4636#*#*
     
  3. marcioefj

    marcioefj New Member
    5

    May 29, 2010
    4
    0
    5
    That's right!
     
  4. marcioefj

    marcioefj New Member
    5

    May 29, 2010
    4
    0
    5
    Guys, I changed firmware to Canada's Telus and Brazil Retail and the WCDMA preferred option won't stick in any of those.

    But on the Brazil Retail firmware, HSDPA is on most of the time, so problem solved... I don't really know what was causing it, maybe APN settings (since these come already set on retail firmware)

    Thanks anyway!
     
  5. juan.ferrari

    juan.ferrari Member
    5

    Jun 13, 2010
    9
    0
    5
    Im in SP and I have the same problem, but Im still with the 2.0 original.
    TIM has no 3G at all for what I ve seen.

    Have you tried Vivo? Is it 3G for real??
     
  6. marcioefj

    marcioefj New Member
    5

    May 29, 2010
    4
    0
    5
    TIM has 3g as well. Vivo firmware was getting in the way. Update your device to retail firmware and enjoy!
     

Share This Page

Loading...