Weather widget not workingSupport


Last Updated:

  1. Neera

    Neera Well-Known Member This Topic's Starter

    Joined:
    Mar 4, 2010
    Messages:
    192
    Likes Received:
    43
    Noticed this morning that my weather widget (using Beautiful Widgets) is not updating even after trying to manually refresh it.

    I removed the widget and when I re-added it to the home screen I got this message (see attachment): "Google ended their API Google Weather".

    Is anyone else experiencing this problem as well?
     

    Attached Files:


    Advertisement
  2. Tim K

    Tim K Well-Known Member Contributor

    Joined:
    Nov 2, 2009
    Messages:
    1,648
    Likes Received:
    471
    Yes/No. Google is no longer providing weather services to apps, so you just have to go into the BW settings and select "accuweather" as the provider of weather services.
     
    Neera likes this.
  3. Neera

    Neera Well-Known Member This Topic's Starter

    Joined:
    Mar 4, 2010
    Messages:
    192
    Likes Received:
    43
    Thanks Tim, but since BW removed the Google option only the Accuweather one remained which had been working fine till today, but for some reason it doesn't anymore now.

    Switched to "One more clock widget" for now and it works beautifully.
     
  4. nj02vette

    nj02vette Well-Known Member

    Joined:
    Jul 9, 2010
    Messages:
    2,346
    Likes Received:
    2,034
    Yeah, BW seems to be broken for me as well.

    I'm sure the developer will update quickly.
     
  5. Tim K

    Tim K Well-Known Member Contributor

    Joined:
    Nov 2, 2009
    Messages:
    1,648
    Likes Received:
    471
    I'm running BW version 4.12 with no problems. Have you tried clearing data/cache on the app or reinstalling it? Maybe its got some old google weather data jamming it up.... or try force stopping it and then re-applying the widget.
     
  6. Neera

    Neera Well-Known Member This Topic's Starter

    Joined:
    Mar 4, 2010
    Messages:
    192
    Likes Received:
    43
    Strange indeed. Today it seems to be working again...

    Gonna stay with "One more clock widget" for a little while longer. Kinda enjoying the "Chrome Rings" widget/theme.
     
  7. kennychaffin

    kennychaffin Well-Known Member

    Joined:
    Aug 28, 2010
    Messages:
    487
    Likes Received:
    49
    My samsung GIII /verizon accuweather widget has been broken since Sunday 10/7 it is not updating either automatically or manually. Anyone else?
     
  8. nj02vette

    nj02vette Well-Known Member

    Joined:
    Jul 9, 2010
    Messages:
    2,346
    Likes Received:
    2,034
    No explanation by my BW is working again as well.
     
  9. kennychaffin

    kennychaffin Well-Known Member

    Joined:
    Aug 28, 2010
    Messages:
    487
    Likes Received:
    49
    Working here again too, I restarted the phone and that may have fixed it, not really sure cause it didn't seem to be working on restart, but then it started working...
     
  10. kippydon

    kippydon New Member

    Joined:
    Jan 2, 2013
    Messages:
    1
    Likes Received:
    0

    hi have had same problem this morning, it just stopped.. how to change on experai T
     
  11. CraigCH

    CraigCH New Member

    Joined:
    Feb 4, 2013
    Messages:
    1
    Likes Received:
    0
    I had the same problem on my S3 and just figured it out. It only refreshes when the GPS is turned on. I prefer not to leave my GPS on all the time, but if you turn the GPS on, and then hit the refresh on the weather widget, it will update immediately, then you can turn the GPS off. I still might look for another weather widget.
     
  12. Saurabh647

    Saurabh647 New Member

    Joined:
    Feb 2, 2015
    Messages:
    1
    Likes Received:
    0
    I have this problem on my Samsung galaxy recently I don't know if your problem has been solved but it was the problem of DNS on my device if you are using a router then change your routers DNS to 8.8.8.8 and in next 8.8.4.4 its google DNS and its safe and you can change it directly from your phone too just go to your selected wifi network touch it and hold and in modify network config.< show advance option< in ip setting change DHCP to static and change your DNS to above said DNS servers in there but don't change anything else
    (NOTE: this solution is for a wifi connection only :))
    peace!!
     
  13. WonderWabbit

    WonderWabbit New Member

    Joined:
    Dec 31, 2015
    Messages:
    1
    Likes Received:
    0
    Im using BW 5.7.2, I have re-selected my widget, i have changed from Accuweather to Weather Underground, but still the centre of the App says N/A instead of weather icon & no Temps Hi Lo) = not updating any weather information. If i tap N/A & go in to the weather page, at the top it gives my correct location, date & time, but says No weather data yet.....
    when i click the Refresh button..... no change.
    People have talked about uninstalling and re-installing BW....
    But i have paid for my App, so that i get all the weather animations.
    Are you really saying the only solution is i have to pay again to get this No Weather Icon & temp information resolved? just to see if a re-install will work?
     
  14. Terrorvision

    Terrorvision New Member

    Joined:
    Aug 11, 2016
    Messages:
    1
    Likes Received:
    0
    I had NA messages in all the weather fields and nothing worked until I went in and re-selected the temp NA field (I use Total Launcher) and told it to do temp again in the settings.
    It said I needed some sort of total key launcher (clicking took me to it automatically)
    Cost 6 dollars but its done now and finally got it working.
    PS,.. and thats using accuweather
     
  15. JohnJNunya

    JohnJNunya New Member

    Joined:
    Aug 17, 2016
    Messages:
    1
    Likes Received:
    0
    For what it's worth, on my Galaxy S7 Edge, after a reboot (about 2 hours or more), ALL widgets stop updating. I use about 4 or 5 widgets from a wide range of providers and not a single one of them update. They all simply stop working. There are a LOT of complaints "out there" about this issue but thus far no reasonable explanation or solution.
     

Share This Page

Loading...