Website ads


Last Updated:

  1. Mr. Boom

    Mr. Boom Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    689
    Likes Received:
    84
    Why is every ad i see, on this site, an anti-Sharron Angle ad? Getting pretty sick of them! I thought "news" sources are supposed to give equal time to both sides?

    Regardless, time for something different!
     

    Advertisement
  2. 1. It's an advertisement, fer cryeye. It doesn't have to give equal time.

    2. It's probably out of the site owners control what gets placed in the ad space.

    3. If you're using Android Forums as a source of political news, you are a sad panda.
     
  3. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Joined:
    Jan 19, 2010
    Messages:
    22,479
    Likes Received:
    9,225
    Hello Mr. Boom.

    Your remarks will get the attention of an admin if put here:

    Suggestion Box & Feedback - Android Forums

    For what it's worth, the ads are agency generated in most cases, and the admins here watch out for popups and annoyances, but cant catch them all, so opinions and input are needed.
     
  4. Mr. Boom

    Mr. Boom Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    689
    Likes Received:
    84
    Out of site owners control? ISn't it the site owner who decides what goes where? Isn't it the site owner who decides who to sell advertisement space to? All this is beside the point. I am merely asking why it is the same ad over and over. Why can't it rotate to something different?
    I do not use Android Forums as a source of political news. Not why i signed up. I use it for Android news.


    @ Frisco, thanks for the advice. I wasn't really trying to make a political comment. Just tired of seeing the same thing over and over!
     
  5. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,759
    Likes Received:
    8,893
    I suspect it's probably that something is stuck on your PC; you shouldn't be seeing the same stuff over and over. I would try clearing your browser's cache/cookies and see if that fixes it.

    Still, I've moved this over to the Suggestion & Feedback section just in case it is something server side :)
     

Share This Page

Loading...