1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Weird problem: samsung galaxy s2


  1. killerclowder

    killerclowder New Member

    I got the the Samsung Galaxy s2 4G Epic from Sprint a few months ago and it's my first smart phone so I'm not very well-versed. It's a great phone, but this weird problem keeps happening and I have googled the issue to see if anyone else was dealing with it, but nothing came up.

    What it does is in all circumstances (fully charged, running out of battery, plugged in and not, while I'm working on it or sitting idly) the phone acts as if I am pressing the settings button over and over. It's completely unpredictable and I've found no pattern with it. It's also really obnoxious.

    I did a factory reset and it did not work.

    I took it to a Sprint store and they tried to help, but it was like a Michigan Jay Frog deal. It didn't do anything while I was there, but started freaking out while I was driving home and is still doing so.

    The man at the store who was assisting me asked if it started happening after the last system update. I don't really remember, but that might have been the case. Other than that, I don't know what to do. I'm going to take it back to the store in hopes that it will sing and dance for them, but I thought I would ask if anyone had experienced a similar problem and was hoping that there may be available solutions.

    Thanks,
    Jen

    Advertisement
  2. Digital Controller

    Digital Controller The Real Bass Creator Guide

    Hey there killerclowder, first off let me welcome you to the site!

    Secondly, i have moved your thread to the Epic 4G forums, hopefully the correct phone as i believe it is known as thus under Sprint, anyhow, hopefully here people with your device will be able to assist you better :)

    If you have an issue with this move please notify me with a PM.

    Lastly, enjoy your time here :D
  3. killerclowder

    killerclowder New Member

    Oh, thank you! Yes I imagine this subforum would be more helpful.
  4. alpha2k

    alpha2k Well-Known Member

    Not sure, just trying to help. It sound similar to like you have a piece or spec of dust close to the settings button on the bottom, or maybe something intrusive in that area.
    I know I had a screen protector I had put on (Zagg screen) and as I was getting ready to leave the store I was messing with the phone and found it randomly did weird stuff as if I was hitting the buttons, and I wasn't. So I took it back over and I suggested it might be something like this happening, or maybe the screen protector was wedged down the side or something. So I took off the screen protector and everything went back fine as it was before. I then put on a new screen protector and this time everything worked fine. Had that one for almost 2 yrs :). So either a dust particle or the screen protector was the cause, not sure which.

    I figured this might be whats happening to yours.
  5. kendermouse

    kendermouse Active Member

    Actually, I'm fairly certain the forum they need is this one. The S2 Epic is an entirely different animal than the one this forum is about. For starters, it has no slide out keyboard, and is an S2 model, not an S. Please move it again, to the proper forum?

Share This Page