Weird USB connection issueSupport

Last Updated:

  1. TimmyB44

    TimmyB44 Well-Known Member

    OK, I've searched the forum but can't find this one, specifically. If I plug my phone into the usb cable on my PC, my PC makes the connection sound, shows the removable disk under "My Computer", etc. However, when I double-click on that new disk that showed up, it says "Please insert a disk into (whatever drive letter was assigned)". The phone is set to "USB Mass Storage", not any of the other settings. I cannot access any of my files. The only way I can get it to work is to completely shut down and restart my phone, which is a real pain to do multiple times in a day.

    I've had this phone since last October. No issues at all. This just began last week for the very first time. Any guesses out there?

  2. malch

    malch Member

    Yes, one or more apps has installed itself on your SD card. This tends to cause mucho problems.

    Goto Settings, Applications, Manage Applications, On SD Card. This will allow you to find and relocate those apps back to the internal storage.

    And, yes, I had the same problem until I took the steps outlined above.
  3. TimmyB44

    TimmyB44 Well-Known Member

    Wow, I've got quite a few of those that I've moved to the card. I never had issues before, but I will move these all back over tonight when I get a chance. I wonder which one is causing the issue?

    Thanks for the reply. I'll let you know when I have a chance to experiment.

    Tim :cool:
  4. TimmyB44

    TimmyB44 Well-Known Member

    OK, now I'm really cracking up. I went to "Manage Apps", selected "SD Card" to see which apps were there. It lists about 20. However, when I click on an app to move it, it shows "Move to SD Card", meaning it is really not on the card. This happens for each and every app in the list. I even tried moving a couple to the Card and back, and they did this task just fine. What's happening here?
  5. malch

    malch Member

    Yeah, the interface is confusing.

    When you select the "SD Card" tab, it lists all of your apps. Apps are installed on the SD card only if the associated checkbox is ticked and green.
  6. TimmyB44

    TimmyB44 Well-Known Member

    OK, then I've got something else causing my problem. I only had one app checked green, and I uninstalled that one, but I still have my connection issue this morning. :(
  7. malch

    malch Member

    Hmmmm, well I still think we might be on the right lines.

    It's my guess that the phone has a problem allowing the SD card to be mounted as shared mass storage device because there are open files on the SD.

    So I'm thinking maybe you have a running application that has an open file there.

    If you can reproduce the problem, terminate one of the running apps and try again.

    If this theory holds up, you should be able to identify a specific app that is preventing the SD card from being released so that the device at the other end of the USB can mount it.

    I had this problem constantly until I moved all of my apps off the SD card. And the problem has not arisen a single time since I did that.
    TimmyB44 likes this.
  8. TimmyB44

    TimmyB44 Well-Known Member

    Well, of course, now that I say it isn't working, it IS. Other than the one blip this afternoon, it has worked flawlessly, with about 8-10 connections with no problems. It must have been that one rogue app that was on the sd card.

    Thanks, again, Malch. Truly appreciate you taking the time to assist.

    tim :cool:

Share This Page