1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support WEP Wifi Connection Problem


  1. squalliram

    squalliram Member

    Hello,

    I am new to this forum and would really want to please help me get this problem solved. I just bought a Sony Ericsson Xperia X10 and tried connecting it to my internet at home (Belkin N1 router - 64-bit WEP encryption) but it does not connect at all. It catches the internet connection and says its in very good range, I put the key but it never connects. I have tried all the different things possible via this forum, googling for answers, etc but haven't found a solution yet.

    Stuff that I have tried:
    1) Tried accessing it via a static i/p technique.
    2) I cannot change the WEP encryption to WPA-PSK because the internet is set up by my landlord and I am not allowed to change it. I can check the settings and it shows access to all b/g/n configurations.
    3) I have another phone i.e. the new Sony Xperia S, even that is not able to connect to my wifi.
    4) I am able to connect both these phones very easily to other wifi's having WPA-PSK connectivity but just not my home network.

    Kindly help as I have been struggling a lot to find for a proper solution over the internet.

    Advertisement
  2. brotherswing

    brotherswing Well-Known Member

    I can think of several things to try, but not most of my ideas are decidedly not elegant. Have you tried using address reservations? Might not work, it's similar to using static ip's... do you have/use any other wifi devices?
  3. squalliram

    squalliram Member

    Yes, I have a laptop that accesses that wifi without any problems. My friend has a nokia N8 and wifi works on his phone as well.
  4. brotherswing

    brotherswing Well-Known Member

    Alright, without being able to tweak settings on the router there's relatively few options. If you connect a USB wifi adapter to the laptop, you can set it up adhoc so that it's basically acting like a repeater. Like I said, not elegant, but it would work. I'm not familiar enough with your handset to be more help other than crude hacks, sorry...:eek:
  5. squalliram

    squalliram Member

    Could you suggest me as to what settings to tweak in order to make it work. I think I have tried some by accessing 192.168.2.1 and changing it from WEP to WPA-PSK, but that does not seem to help as well.
  6. brotherswing

    brotherswing Well-Known Member

    Do you have administration rights to the router?
  7. squalliram

    squalliram Member

    Yes, I can access it via the 192.168.. i/p address and change its properties to test something. Did quite a lot of stuff yesterday but couldn't get it sorted.
  8. brotherswing

    brotherswing Well-Known Member

    Can you power cycle the router?
  9. beau420

    beau420 Well-Known Member

    Reboot the router.

    Turn Wifi on with NO security - does it connect?
    Turn WPA-PSK on - does it connect?
    Turn WEP on - does it connect?

    That is the proper way to troubleshoot it.

    90 percent of the time the problem isn't the phone, but the router. Sometimes a power cycle/reboot fixes it. Could be the channel the router is set to use (I hate when people leave it on Automatic) Find a quiet channel (there are apps for that) and set it to use that. Sometimes it is just the router settings aren't accepting any new connections until you reset the password or change anything to do with the security.
    squalliram and brotherswing like this.
  10. squalliram

    squalliram Member

    I have tried the WPA-PSK approach (AES encryption) and it does somehow make it work on my Xperia S (it did not connect to it instantly). Basically, there is an option of WPS (Wifi-Protection Setup) in my Xperia S which allowed me to do a Push Button Configuration (PBC) i.e. holding the router button for 3 seconds to allow my phone to access it. It assigned me an i/p address and thus made it work but spoiled it for my other housemates, so I had to get the setting back to WEP.I know it is more secure to use WPA, but I cannot change it without asking my landlord. Anyways, the point is that somehow my other phone connects to the router not instantly but via some route as given above. My question again is: Is it really not possible to connect it via WEP?
  11. brotherswing

    brotherswing Well-Known Member

    I'm going to ask some of the other staff members, to see if we can figure this out for you....
    Stay tuned, I'll let you know what I find out.
  12. sdrawkcab25

    sdrawkcab25 Guides Guide

    You are typing in a 10 character hexadecimal key right?(numbers 0-9, letters A-F) Not a pass phrase?

    If you are 100% positive you are typing in the right key, you have to try another WEP secured network, if that works, then you know the problem lies with the router. Copy down then router settings and hard reset the router (usually a pin hole on the back of the router, press it for at least 10 seconds). If it doesn't work with another router, take the phone to a store and have them troubleshoot it.

    However googling your issue, does bring up other users with the same problem when using WEP encryption, it's hard to say whether it is a Sony issue or just that the others are having issues with their router also.
  13. squalliram

    squalliram Member

    Yes, I am 100% sure that I am typing in the correct key because I can see the correct key from the router settings menu so I am certain that I am not going wrong on that part. Its pretty difficult to find out another WEP secured network as everything that I have come across so far has WPA security. I don't think its a sony issue because I had an HTC hero earlier which behaved the same way as these are behaving at the moment. I have had a talk with Belkin support people and they told they can hopefully help me solve this problem. In the meanwhile, please keep your suggestions coming.Thanks everyone.
  14. brotherswing

    brotherswing Well-Known Member

    I did get another opinion.
    Another thing to consider, while Belkin is a well respected accessories company, networking equipment isn't their strong suit. I've never had very good luck with their routers, and if the option is available I suggest sticking with the big three of home networking. Namely: Netgear, D-Link, and Linksys.
  15. squalliram

    squalliram Member

    Dont really have an option there, its my landlord's house and we are just mere tenants. :(
  16. ch1k3n123

    ch1k3n123 Active Member

    squalliram, I think I am in the exact same situation as you. I just want to see if we're somewhat in the same situation.

    Device: LG Thrive
    Version: Android 2.2.1
    WiFi: WEP

    I cannot seem to connect to my WiFi, even with the right password. At least, I'm pretty sure it's the right password, I don't think it has changed. All the computers in my house can connect to it just fine, but my android can't.
    If I don't have the "Use static IP" box checked, it does the "obtaining IP address" loop. If I do check the "Use static IP" thing and enter in the fields, it tells me that it's "connected" but I can't actually connect to any web pages or use any internet connected apps. I entered in the things from my ipconfig on my computer into my phone. Was that what I was supposed to do?
    I can connect to any wifi hotspots like libraries, coffee shops, etc. but not my home WiFi, where I need it the most!
    I'm sort of afraid to press the red "reset" button on the bottom of the router because I don't think I have Admin access to the router page, and pressing that button might screw things over if I can't change the settings back. I'm not quite sure how to "reboot" the router either, as there's no definite power button, but there's a button on the front that I tried pressing a few times that doesn't really seem to do anything.

    Does that sound like the same situation to you?
    squalliram likes this.
  17. ch1k3n123

    ch1k3n123 Active Member

    Quick update,
    I got my problem fixed. It was in the router, not my phone, so maybe working with your landlord you might be able to fix your router to make it work.
    Good luck to you! :)
    squalliram and brotherswing like this.
  18. brotherswing

    brotherswing Well-Known Member

    I've been thinking the same thing.
  19. beau420

    beau420 Well-Known Member

    A lot of the WEP networks I have dealt with also require you manually add the computer or devices MAC address in the router menu (so you would have to copy down the MAC address of the phone's wireless NIC, then add the address to the appropriate router menu), then you must manually type the ridiculous WEP key into your phone.

    It might be easier to convince your landlord that WEP is a nuissance. It's not like WEP is air tight....slightly harder to crack than WPA, but still:

    Why is WEP crackable? How WEP weaknesses affect your wireless network security | Openxtra

    Why WEP Is Not Secure :: Chapter 6. How IEEE 802.11 WEP Works and Why It Doesn't :: Part II: The Design of Wi-Fi Security :: 802.11 security. wi-fi protected access and 802.11i :: Networking :: eTutorials.org
  20. alostpacket

    alostpacket Over Macho Grande? VIP Member

    You might try politely telling your landlord they are using a woefully out of date and insecure method of encryption. WEP is literally dangerously weak. It can be cracked wirelessly in minutes/hours (IIRC).

    I don't know if they would be receptive to the idea, but there almost is no excuse for him to force WEP :) It's probably a tough sell, but always worth a try.

    But as others have stated WPA/WPA2 PSK is the was to go. AES is fine as well.

    If you do get them to allow WPA, be careful not to use any other fancy named "security" auto config stuff either on your phone or router. It should be simply WPA/WPA2 PSK (AES).

    It also might be that the router is old and or has too many open TCP/IP connections.

    Any info you can give about the brand of the router and current settings would help.
  21. squalliram

    squalliram Member

    How were you able to get it fixed? Could you share your solution? Please :)
  22. squalliram

    squalliram Member

  23. ch1k3n123

    ch1k3n123 Active Member

    Restarting the router didn't work, so I had to contact AT&T to get me a new one, but most likely the problem was in the router that I couldn't fix. The old wan was just really old anyways, and it was due in for a replacement, that's probably why it didn't work, because resetting it didn't fix it.
  24. tuskezs

    tuskezs New Member

    I have two different types of D-Link routers and I used WEP until now without any problems (with Windows and Android Froyo). But today I bought a tablet with Android 4 and it could not connect to the the wifi (the same problem as written above). I changed the WEP encryption to WPA-PSK and all my equipment works properly. I know it is not solution for your problem, but experience with D-Link router.
  25. squalliram

    squalliram Member

    I tried it on an iPhone and it works flawlessly... Looks like its a problem with android phones connecting to WEP connections!

Share This Page