What is Gtalkservices?


Last Updated:

  1. BigPapaBang

    BigPapaBang Active Member This Topic's Starter

    Joined:
    Jun 11, 2010
    Messages:
    44
    Likes Received:
    1
    I've disabled Google talk from starting at start up and signed out of it to help my battery life but when u go to running apps it shows Gtalkservices still running. Does anyone know what it is? Can I disable it?
     

    Advertisement
  2. THEFORCE

    THEFORCE Well-Known Member

    Joined:
    Mar 17, 2010
    Messages:
    608
    Likes Received:
    198
    Setting, applications, running services, and click gtalkserive....you will have to do this each start up
     
  3. BigPapaBang

    BigPapaBang Active Member This Topic's Starter

    Joined:
    Jun 11, 2010
    Messages:
    44
    Likes Received:
    1
    So just going into talk to sign out doesn't totally turn it off? I could have sworn that that's the way everyone was saying to do it. I just wanted to make sure before I shut it down.
     
  4. THEFORCE

    THEFORCE Well-Known Member

    Joined:
    Mar 17, 2010
    Messages:
    608
    Likes Received:
    198
    You are logged off but the app is still running..I have seen a great increase in battery performance after doing...if you do it, make sure you do it at each start up.
     
  5. sweteg

    sweteg Well-Known Member

    Joined:
    May 23, 2010
    Messages:
    71
    Likes Received:
    10
    Every time you reboot, it'll start up again. I think it's tied in to some other programs that are needed for the phone to work correctly (the sync process). So when you run something related, it restarts the gtalkservice. That's why they say don't delete it if you are fully rooted.

    To speed up turning it off, just make a shortcut to the running services on the homescreen.
     
  6. BigPapaBang

    BigPapaBang Active Member This Topic's Starter

    Joined:
    Jun 11, 2010
    Messages:
    44
    Likes Received:
    1
    Nice. I thought signing out shut down the program. Thanks for the tip
     
  7. Bat~man

    Bat~man Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    224
    Likes Received:
    29
    U turned off the "sign in automatically" and exit it by signing out but whenever I go to check on the apps that are running...its usually there....says it was started by an app.

    Is this going to kill my battery the same as if I stay signed in?
     
  8. dgaf98

    dgaf98 Well-Known Member

    Joined:
    Jun 1, 2010
    Messages:
    76
    Likes Received:
    10
    i was going to ask the same question. also is there a way to completly remove google talk if i never use it
     
  9. LisaFitz

    LisaFitz Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    167
    Likes Received:
    13
    Use the menu-settings-applications-running services to kill it off

    I noticed this too even after i signed out manually, sometimes its running hidden and sometimes it doesn't run at all - strange - :rolleyes:
     
  10. teky

    teky Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    433
    Likes Received:
    120
    Just bring it up and log out and close it...otherwise, it will keep coming back. You don't need to do anything else.
     
  11. as329

    as329 Well-Known Member

    Joined:
    Jun 19, 2010
    Messages:
    58
    Likes Received:
    6
    There are a couple threads (or at least mentions of this in other threads). I've been playing with it all day. If you kill it and disable it with startup auditor, at least for me, I couldn't get gmail to push. If I killed it in running services, it just came back everytime I turned on the phone (assuming that gmail somehow initiated gtalk). In the last couple hours, I have left it running, and haven't noticed any battery loss while sleeping, however, I do seem to be losing battery at a faster rate when the phone is on...still looking into this.

    This is the one thing that pisses me off, I just had this phone running great. I lost 1% battery overnight and have been getting through the day with plenty to spare before this. Hope it's fixed.
     
  12. as329

    as329 Well-Known Member

    Joined:
    Jun 19, 2010
    Messages:
    58
    Likes Received:
    6
    That was true prior to the update. See my post above, it just keeps coming back (at least in running services)
     
  13. dylan88

    dylan88 Well-Known Member

    Joined:
    Mar 25, 2010
    Messages:
    810
    Likes Received:
    196
    same here. i shouldnt have updated. nothing was wrong. it was perfect. if it aint broke, dont fix it.
     
  14. as329

    as329 Well-Known Member

    Joined:
    Jun 19, 2010
    Messages:
    58
    Likes Received:
    6
    I was the guinea pig for the family's three, soon to be four, EVOs and took one for the team....I should have updated the kid's phone, she would have never noticed the difference the way she treats phones :eek:
     
  15. teky

    teky Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    433
    Likes Received:
    120
    Doesn't matter...if you are logged out, it isn't doing anything with your CPU. It is just resident in memory. The OS will shut it down when it needs the memory for another app.

    That's why these task killers are BS.

    Unless an app is actually running and consuming CPU, it has no impact on the battery.
     
  16. Essex

    Essex Well-Known Member

    Joined:
    Jun 12, 2010
    Messages:
    269
    Likes Received:
    61
    +1 to teky

    RE: Google Talk running

    Go to the Market and search for "SystemPanel App" and install the free version. Trust me though, you will want the full version after using the free version because the paid version allows you to monitor your phone in semi real time and compare app usage with battery life. Very useful!

    When you open up the app, you will be able to see all of the apps that are running along with how much memory those apps are using. You will see that just because an app is "running" it doesn't necessarily mean that it is actively using memory. It might just be running in the background in a cached state.

    I came from the Hero and I still remember when the "messages" app would keep the phone awake and obliterate the battery. Because of the Hero, I embraced apps like "ATK" and "Handcent" so that I could make sure that my phone would sleep. On the Hero, I would watch my running apps like a hawk and kill them when something would run without me telling it to. My point (yes, I have a point) is that before I installed SystemPanel App on my EVO, I was completely clueless about how Android allocates memory and manages applications. I assumed that just because an app was "running" that it was draining my battery. Not true!

    So, I say all of this not to doubt your reports of worsened battery life. I just think that if you were more informed about what your phone is doing, app by app, you might be able to diagnose the REAL culprit for your battery drain (might be Google Talk or it might be something else). So don't give up! You just need more information and control than the stock "Running services" and "Battery use" apps can provide! SystemPanel App. SystemPanel App. SystemPanel App. SystemPanel App ...
     
  17. as329

    as329 Well-Known Member

    Joined:
    Jun 19, 2010
    Messages:
    58
    Likes Received:
    6
    Sometimes you have to feel stupid to learn...

    Last night before the update, I decided that I was getting such good battery life that I would control my own screen brightness. On 100%, the screen is beautiful. Anyway, I installed a brightness widget and in playing around with it, turned off auto adjust (I have since learned I can use both simultaneously). In the last hour or so, which I know isn't long enough to matter, but I am fairly tuned into the battery use on this phone, I reset back to auto adjust and am doing just fine with my battery with gtalk running the whole time, sleeping or on.

    Again, another reason to love these boards, especially while learning a new OS.
     
  18. Sgt. Slaughter

    Sgt. Slaughter Well-Known Member

    Joined:
    Jun 26, 2010
    Messages:
    62
    Likes Received:
    17
    My comment on this is that this behavior is completely different than before the update. It continuing to pop up in running services after signing out of it and killing the app like mentioned before does nothing in the end. Before the update doing the previous would not allow the service to come back up but now after the update it does so something has changed to cause this to happen regardless.

    Also I find it odd that when I uncheck auto sign in and manually sign out, then kill the service via running services; and THEN click on GTalk app to open it up it comes up showing me signed in yet auto sign in is unchecked and all. I've tried checking it and unchecking it again, restarting the phone, and trying again and get the same results every time.
     
  19. tkdawg22

    tkdawg22 Member

    Joined:
    Jun 21, 2010
    Messages:
    5
    Likes Received:
    0
    Before the update yesterday I was able to end the process and it would stay off until I rebooted. Now it starts back up on its own even when the phone is idling. I check every so often to see if its running again.
     
  20. HuDuVuDu

    HuDuVuDu Member

    Joined:
    Jun 1, 2010
    Messages:
    21
    Likes Received:
    2
    I am having the same thing. Before the update it would stay off, now it randomly starts back up.
     
  21. swg

    swg Member

    Joined:
    Jun 12, 2010
    Messages:
    13
    Likes Received:
    2
    Startup Auditor seems to shut it down for good even after the update.
     
  22. mrvirginia

    mrvirginia Well-Known Member

    Joined:
    May 13, 2010
    Messages:
    1,493
    Likes Received:
    228
    yup startup auditor is how you really take care of progs that start up on boot.

    warning: disabling gtalk causes the gmail app to stop syncing in the background.
     
  23. teky

    teky Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    433
    Likes Received:
    120
    I've read that the Android Market app also uses the gtalk service. It won't work without it. I'm not sure why.
     
  24. ryohei47

    ryohei47 Well-Known Member

    Joined:
    May 31, 2010
    Messages:
    159
    Likes Received:
    18
    go to talk, then settings. uncheck automatically log in, then log out
     
  25. swg

    swg Member

    Joined:
    Jun 12, 2010
    Messages:
    13
    Likes Received:
    2
    You would think that would keep it shutdown but it does not, only temporarily. Also no problem with the Market using Startup Auditor for what its worth...
     

Share This Page

Loading...