What the hell happened


Last Updated:

  1. harrisonkk

    harrisonkk Member This Topic's Starter

    Joined:
    Jan 26, 2010
    Messages:
    15
    Likes Received:
    0
    About two hours ago my phone started loosing battery power really fast so i decided to plug it into the charger. Five minutes ago I looked and it was still at %15, the amount it was at when I first plugged it in. So I decided I would turn it off and turn it back on and see if it was just the UI getting messed up or something. Three seconds after I unplug the phone from the charger it turns off and now it wont turn back on. I've tried just waiting a little while, taking out the battery, plugging it back into the charger... nothing works.

    What the **** happened to my phone?
     

    Advertisement
  2. mihalich

    mihalich Well-Known Member

    Joined:
    Nov 23, 2009
    Messages:
    425
    Likes Received:
    44
    sounds like all you were missing was the smoke. I've heard of the battery meter getting out of whack, and needing a restart to fix it...but if it won't come back on, that's problems.

    Joe
     
  3. BucYouUp68

    BucYouUp68 Well-Known Member

    Joined:
    Nov 10, 2009
    Messages:
    373
    Likes Received:
    27
    Make sure it is plugged in to the wall charger, Let it charge for about 30 minutes and see if it turns on.
     
  4. harrisonkk

    harrisonkk Member This Topic's Starter

    Joined:
    Jan 26, 2010
    Messages:
    15
    Likes Received:
    0
    Yeah that's what I'm trying right now. I'm on the phone with a Motorola rep right now and they said they can send me a new battery, so hopefully that will work if this doesn't.
     
  5. BucYouUp68

    BucYouUp68 Well-Known Member

    Joined:
    Nov 10, 2009
    Messages:
    373
    Likes Received:
    27
    You should be good, If it does turn on after 30, let it charge all night.
     
  6. BenDroid

    BenDroid Well-Known Member

    Joined:
    Jan 8, 2010
    Messages:
    200
    Likes Received:
    13
    I had a similar problem a while back. First thing that I did was disconnect the battery for a few. Reconnected the battery and then hooked it up to the charger for about 15 mins. Turned it back on and haven't had a problem since. Something just went screwy with the battery sensor I guess.
     
  7. harrisonkk

    harrisonkk Member This Topic's Starter

    Joined:
    Jan 26, 2010
    Messages:
    15
    Likes Received:
    0

    Latest Update: The phone is back on haha.

    It's turning on again but it dies even if I just unlock the screen because just the screen being on for like 3 seconds kills it. Hopefully letting it charge for a really long time will fix it. If not then I have the new battery coming and now we know it's definitely the battery that's the problem.:eek:
     
  8. BenDroid

    BenDroid Well-Known Member

    Joined:
    Jan 8, 2010
    Messages:
    200
    Likes Received:
    13
    Good luck. I hope that it works out for you.
     
  9. xjestersdeadx

    xjestersdeadx Well-Known Member

    Joined:
    Feb 10, 2010
    Messages:
    166
    Likes Received:
    13
    Someone posted that Taskiller was doing this to their phone. Don't know how true it is.
     
  10. bradjason24

    bradjason24 New Member

    Joined:
    Feb 6, 2010
    Messages:
    4
    Likes Received:
    0
    now, i will say that i rooted, and went back to stock. after i went back to stock, my device wouldnt charge. but, i kept the cable in my device and unplugged it from the wall. when i plugged it back in (to the wall socket), it started charging just fine. no battery pulls or anything. just in case anyone was in my shoes...
     
  11. Apeman

    Apeman Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    172
    Likes Received:
    9
    This happened to me, and a good overnight charge fixed it for me completly. It has to do with the battery sensor, and it needs a good night being charged and off for it to fix itself.

    Make sure it is plugged into the wall, because a lot of computers don't send full power threw the USB ports, so it actually looses power while "charging"
     
  12. jetpirana

    jetpirana New Member

    Joined:
    Mar 3, 2010
    Messages:
    4
    Likes Received:
    0
    anyone know if the Eris is rooted yet?
     
  13. CRPercodani

    CRPercodani OFWGKTA VIP Member

    Joined:
    Oct 24, 2009
    Messages:
    2,940
    Likes Received:
    564
  14. Apeman

    Apeman Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    172
    Likes Received:
    9
  15. mtbhk44

    mtbhk44 Well-Known Member

    Joined:
    Nov 9, 2009
    Messages:
    363
    Likes Received:
    38
  16. BucYouUp68

    BucYouUp68 Well-Known Member

    Joined:
    Nov 10, 2009
    Messages:
    373
    Likes Received:
    27
    It will be when they roll out 2.1 :D, Back On Topic please.
     
  17. droidism

    droidism Well-Known Member

    Joined:
    Nov 10, 2009
    Messages:
    86
    Likes Received:
    0

    There may be more to this than we think because the EXACT SAME THING (verbatim) that you posted happened to me at almost the exact same time! I am use to electronics bugging out from time to time but after reading your post it kinda weird'ed me out a bit. Anyway, my droid is back up and running and glad yours are too.
     

Share This Page

Loading...