What the hell just happened to my EVO?


Last Updated:

  1. Boozeman

    Boozeman Active Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    43
    Likes Received:
    4
    My SD card was unmounted, so I simply went to restart my EVO to mount it back to the phone. I powered off but then could not power back on (this is not the first time I've had this problem).

    Nothing worked..holding down power button, pressing power button repeatedly, trying to hard reset, no matter what I did, it didn't seem to work. Even plugged in my phone to the wall and the orange light didn't pop up, it was basically as if my phone had completely died. This went on for about 10 minutes and FINALLY I was able to get to the hard reset screen and reboot from there, but geeeeezus what an ordeal.

    I'm telling you, trying to restart this phone is a pain in the ass. This has happened three times now, though not this bad, but it's gotten worse each time. Basically, don't ever power off this phone unless you absolutely, unequivocally MUST because getting it back on is a bigger pain in the ass than it has any right to be.
     

    Advertisement
  2. IPvFletch

    IPvFletch Well-Known Member

    Joined:
    Jun 6, 2010
    Messages:
    441
    Likes Received:
    28
    This happened to me twice since I've had the phone. It hasn't happened in a long time though.
     
  3. sikclown

    sikclown Well-Known Member

    Joined:
    Nov 21, 2009
    Messages:
    1,910
    Likes Received:
    965
    I have not had this problem at all. Maybe exchange it? I mean it could be app related but that doesn't explain why turning it back on is so hard. When I reboot I simply wait a few seconds after it turns off and then press the power button for two or three seconds and powers up. You have posted this before either here or in another forum.... Or I am having major DeJa Vu
     

Share This Page

Loading...