What's with GTalk?! Can't Turn it OFF!


Last Updated:

  1. htmlcssguru

    htmlcssguru Well-Known Member This Topic's Starter

    Joined:
    Jun 28, 2010
    Messages:
    107
    Likes Received:
    19
    I've read MANY posts about how turning of GTalk (Talk icon in Apps) is pivotal in getting better battery life. I've gone to Settings menu in Talk and unchecked auto-sign in, rebooted, etc. I downloaded the app Running Services and when I view what's running... yep!.. there's Gtalk!

    From my understanding it's running in the background and continually checking for people on friend's lists, etc. and sucks major battery juice. WHY is it running? Is it part of some other function/feature that needs it? (like the navigation? google voice? translator? ??).

    Or, is what i've done by having it NOT automatically sign in enough to save battery life and the fact it's 'running' in the background is insignificant since i'm not officially 'signed in'? I'm not sure how this program works but understood in previous battery related threads that it was bad and needed to be turned off.

    A little help on this subject would be MUCH appreciated. Thanks!
     

    Advertisement
  2. StrummingLevi

    StrummingLevi Member

    Joined:
    Jul 5, 2010
    Messages:
    8
    Likes Received:
    0
    I'm actually having the same problem. It seems like I'm automatically signed back in and the app keeps restarting itself. Any help would be much appreciated.
     
  3. htmlcssguru

    htmlcssguru Well-Known Member This Topic's Starter

    Joined:
    Jun 28, 2010
    Messages:
    107
    Likes Received:
    19
    Yeah, I don't know what else I can do to it to make it completely go away. Or, if that's even possible. I don't use GTalk, not interested in using it, and certainly don't need it running on my phone. The question is: Is turning off auto-sign in enough? Or, is this something that has to have another switch flipped to keep it from even existing?
     
  4. RedWingsFan

    RedWingsFan Well-Known Member

    Joined:
    May 10, 2010
    Messages:
    365
    Likes Received:
    108
    I used Startup Auditor to keep it from becoming active. But be aware that Gmail push needs Gtalk. Without it running you'll get no emails.

    Just make sure you don't allow Gtalk to automatically sign in and sign out if you aren't using it. It'll just run in the background for Gmail.
     
  5. hawt

    hawt Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    106
    Likes Received:
    30
    Just set GTalk not to automatically sign in. There is GTalk Service which runs in the background which pushes your Gmail notifications and what not. It might show up in whatever task killer you're using but it isn't the messaging app running (which would destroy your battery).
     
  6. wrecklass

    wrecklass Well-Known Member

    Joined:
    Jun 9, 2010
    Messages:
    124
    Likes Received:
    29
    Yes this has caused a lot of confusion, and it doesn't help that Google had the same name for the two things. Google talk app is the one that caused some problems and turning it to not auto login solves the problem. HTC also patched this so it no longer auto logsin by default.

    The Gtalk Service is the one that does need to be running and will restart if you kill it. Some people have used task killers to stop the service only to find their phone becomes unstable. Don't do that!

    Hopefully this helps. It would be nice if Google would change the name of these things to eliminate the confusion they have caused.

    --
    Sent from my EVO 4G with Tapatalk
     
  7. Bruse Wayne

    Bruse Wayne Active Member

    Joined:
    Mar 23, 2010
    Messages:
    32
    Likes Received:
    3
    great thread ! i was about to start searching for some info on this cause my friends kept randomly iming me and I had thought i signed out :D

    disabled auto log in and Im all good now
     
  8. whtge8

    whtge8 Well-Known Member

    Joined:
    Jun 8, 2010
    Messages:
    137
    Likes Received:
    11
    I disabled auto sign in as well but when I go into the manage applications > running applications, in the settings menu and GTalk is always there. Even if I stopped the application, it would show back up about an hour later.
     
  9. PyroSporker

    PyroSporker Well-Known Member

    Joined:
    Apr 3, 2010
    Messages:
    1,727
    Likes Received:
    1,258
    I force stop this app every time I see it. I realize it may be "necessary" to run certain things, but I haven't seen any detrimental effects from stopping it so far. Especially after the most recent OTA update I noticed that it would come back in the running apps list every time I turn on the 3G radio (I keep 3G off unless I need it then flip it back off), so the system must think it is essential to run along with the internet or it tries to sync with gmail every time the internet is turned on despite the gmail settings being set to manual.
     
  10. htmlcssguru

    htmlcssguru Well-Known Member This Topic's Starter

    Joined:
    Jun 28, 2010
    Messages:
    107
    Likes Received:
    19
    I'm convinced it's a necessary app rhat poses no threats and is vital to certain google features to operate. The original concern was the battery use. By disabling the auto login that seems to have taken care of the battery issues despite the fact this is running in the background. I'm getting crazy battery life now so i don't care if it is running in the background
     
  11. wrecklass

    wrecklass Well-Known Member

    Joined:
    Jun 9, 2010
    Messages:
    124
    Likes Received:
    29
    Read my post which is two above your post.
    --
    Swyped on my EVO 4G with Tapatalk
     
  12. jgjackson7

    jgjackson7 New Member

    Joined:
    Jul 17, 2010
    Messages:
    2
    Likes Received:
    0
    Sorry to bump an old thread, but I was having the same problem. Thing is, I am still having the problem. I now understand that there are distinct services and one does not necessarily affect the other. However, despite disabling auto login, I still somehow get IMs from people.

    My thought is that it is because I stay signed in on the Gmail website, but I don't understand how this affects the phone. If I don't have a Gmail web window open, I shouldn't show as available if I am not signed in on the phone, no?

    Thoughts?
     
  13. kiz88

    kiz88 Well-Known Member

    Joined:
    Jun 11, 2010
    Messages:
    176
    Likes Received:
    22

    Exactly as long a Google Talk does not log you on your good to go. This running in the backround while Google talk is signed out does not deplete battery life.

    See my sig for my best battery life so far.
     
  14. meangreengdub

    meangreengdub Well-Known Member

    Joined:
    Oct 18, 2009
    Messages:
    328
    Likes Received:
    5
    I know there are a few threads on this but they all say to sign in and turn off automatic sign in and then click log out BUT later on it turns back on.

    I got to thinking and went to my gmail on my computer and clicked sign off chat in my gmail on my computer and ever since then, I can never find GTalk on Running Services or on the Task Manager and my battery is seeming to be much better.

    So, not sure if this has been mentioned before, but if not, try it out and post back what you think.
     
  15. digitalzombie

    digitalzombie Well-Known Member

    Joined:
    Jun 14, 2010
    Messages:
    63
    Likes Received:
    5
    You know what's crazy is I read this and had a EUREKA moment since I never turn off Google Chat on my Gmail. I remember signing out and turning off GTalk after noticing it was always running. But since reading this I checked my Google Chat window through my PC and I was signed out! I think I did that through my phone, cause I don't remember signing out on the PC. Also checked SystemPanel and sure enough GTalk was nowhere to be found.
     

Share This Page

Loading...