1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

whatsapp disable 'cannot connect to internet' notification when new wifi connection found


  1. pkb1908

    pkb1908 Member

    Hi all - Samsung Nexus Prime user here, on Android 4.4.2 - question is about Whatsapp:

    whenever I am on the move and I catch a new WiFi network (or lose data signal altogether, i.e. on the Tube) - but, crucially, I haven't executed browser sign-in (usually cos I don't want to!), Whatsapp has started sending me a notification:

    Whatsapp cannot connect to the internet (with a triangle showing exclamation mark as the symbol). get a ringtone like I have an email, white light flashes, phone vibrates - v irritating to think I might have a message that's of use, only to see it's this useless notification instead!

    I don't want to disable all whatsapp notifications, as I like to be alerted when I have a message - so how to disable this specific notification?

    thanks!

    Advertisement
    :
  2. BurnCK

    BurnCK Well-Known Member

    I'd like to know too. It's annoying as hell. My workplace has a couple of different access points that have different logins, so when I move round the building I get that notification. Must get it about 10 times a day ! Gonna uninstall the damn thing if there's no way of turning it off !!
  3. gtbarry

    gtbarry Well-Known Member

    What versions of Whatsapp are you two running? When I go to settings I see under "Notifications" only settings regarding messages and not the app. Which may be your issue, that the notification about Internet connection is baked into the app and cannot be turned off.

    I am using version 2.10.750. I turn off wifi and mobile data when I sleep to conserve battery and avoid notifications. That should be similar to what you two are experiencing - and I have not once had that notification from whatsapp
  4. pkb1908

    pkb1908 Member

    @gtbarry - same, 2.10.750! yep only notification setting I have is for all notifications, but this new message only appears recently...

    @BurnCK - exactly the same problem for me @ work, v annoying, but so many of my friends/colleagues use whatsapp I'd rather find a workaround than uninstall - unless it keeps hapenning :)

    cheers, the search continues
  5. gtbarry

    gtbarry Well-Known Member

    This workaround MIGHT work for you, but I doubt it. Also, you will only have 15 minutes for a refund for this paid app - so trying it at the right time might be an issue.

    LightFlow (there is a free version that is full function, but it doesn't work with whatsapp) can take over your app notifications for alerts. Try:

    - turning off all notifications for whatsapp in whatsapp.
    - Then download the paid version of LightFlow from the Play Store
    - Set LightFlow to alert you for whatsapp notifications
    - test to make sure you are getting alerts that you want for whatsapp through LightFlow
    - do your best to lose your Internet connection as you have noted above
    - see if you get the lost signal alert

    As I mentioned above, judging from the settings we both have, the lost connection alert is a function of the app and not the settings. But, MAYBE this will help you.

    (You also may want to keep LightFlow or just try the free version first. It is a fantastic app to customize all your alerts for a wide variety of apps. You can set tones, vibrations, LED color (hardware dependent) and how often they remind you, etc. I'm a big fan of the app.)
  6. gpup

    gpup Active Member

    Yep, I get this same error message whenever I lose my WiFi connection. It seems to be a new feature in the latest Whatsapp update. The app alerts the user when the server connection is lost. Sort of nice to know for some people maybe, but for most of us really annoying. I don't care, just reconnect when I get my internet back. I also cannot find the setting to turn it off, so if anyone knows where it is, that would be great. I never should have installed the update!
  7. athegn

    athegn Well-Known Member

    Same here. Could not see how to turn off this latest annoyance so uninstalled.
  8. gtbarry

    gtbarry Well-Known Member

    Very confusing. I have had whatsapp for over a year now and I am using version 2.10.750 (the latest).

    I turn off mobile data and wifi when I sleep at night.

    Not once have I had this notification.
  9. pkb1908

    pkb1908 Member

    Just to be clear @gtbarry - I don't get the notification when I turn off all data, just when I have WiFi enabled and I catch a signal of say Virgin WiFi on the London Underground and don't execute browser sign-in, or I move to another part of my work building and latch onto a network that I am not authorised to access... so only occurs when you're on a WiFI network without signing in.

    Btw nice tip on lightflow, whilst I doubt it'll help with this problem, it does sound ace!

    ta
  10. Flashgiz

    Flashgiz New Member

    I have the same problem. whatsapp has this very annoying notification every time you change wifi network (which happens all the time!...) when you are walking from place to place. there is NO way of modifying this notification settings or turning it off. Its very confusing because the sound is the same as a new message sound. I dont really need to know its unable to connect to the internet every time there is no wifi connection.
    Every other app that I have doesn't do it I dont see the logic behind it.
    Its a good app, you would think that they would catch up on that problem by now...
    If anyone has a solution for that problem please let me know.
  11. jdta09

    jdta09 Member

    I got an update to Whatsapp yesterday (2.10.768) and it seems like this might have been fixed!
  12. pkb1908

    pkb1908 Member

    @jdta09 have also got that update, let's hope you're right and this is fixed!!
  13. Stuartglossop

    Stuartglossop New Member

    It's still not fixed and its annoying me like hell! I've contacted the developers today so ill see what they say.
    Might even delete the App if it carries on.
  14. Stuartglossop

    Stuartglossop New Member

    Has it been fixed?
  15. gpup

    gpup Active Member

    What did the developers say?
  16. Stuartglossop

    Stuartglossop New Member

    Not a lot really just a standard reply saying reinstall the App and have a look at the Q and A on the website. Hoping it gets fixed in the next update
  17. argolis

    argolis New Member

    Worth registering for a first post! What's App are beginning to buy into their own brand with this self-importance.

    I'm running v2.11.12. They've added a pop-up window to go along with the taskbar and light notification. I have a patchy work WiFi network requiring a sign in so I get this constantly. The only options on the pop-up window are to forget the network or disable Wifi. Seriously? No ignore option there or in the app settings?? :mad:

    What next, every individual app on my phone decides to each tell me when the WiFi or bluetooth aren't available? 50 notifications that my WiFi isn't working, gee thanks. Just let the system notifications do their job and stick to what you're supposed to be doing What's App. :rolleyes:
  18. gtbarry

    gtbarry Well-Known Member

    Settings > Notifications > Popup Notification

    You can turn if off there.
  19. argolis

    argolis New Member

    Hmm seems I was mistaken in that the taskbar and light notifications are gone :eek:

    Thanks gtbarry, but I don't see a pop-up notification setting that affects WiFi notifications though. There's pop-up window setting for incoming messages, group and broadcasts but it doesn't seem like any of these would apply. I do want notifications of incoming messages, but just not the WiFi status. Have you found that one of them works for you?

    Thanks
Loading...

Share This Page