WhatsApp! Messenger supportsSupport


  1. GorenTz

    GorenTz New Member


    Advertisement
    :
  2. Munhoz

    Munhoz Member

    Technically no, because the WhatsApp Messenger requirements are Android 2.1 or above. The Motorola i1 has the 1.5 version.
    Even though, you can give it a try for yourself, but I don't believe it's gonna work.

    http://http://www.whatsapp.com/android/
Loading...

Share This Page