When and where for S-off


  1. scotty85

    scotty85 Guides Guide

    i reflashed the ics leak,and this time it went without the errors i had the first time. the first time,i actually had to flash the leak 3 times :eek:

    this it only took once,and i feel like my phone is smoother and happier. but it could well be the placebo afect of having done something different,lol ;)
    chknhwk likes this.
  2. pwned

    pwned Well-Known Member

    Ihave to say that the timing if the wire trick was tricky. Took me forever to get it right. I finally ended up watching the video and timing it with it. Now though I'm s-off. Already changed my splash screen too
  3. mtbhk44

    mtbhk44 Well-Known Member

    Ok. So. Uh. If I decide to do this, can I use speaker wire?
  4. StillLoading

    StillLoading Active Member

    That's what I did. A paperclip works a little easier though from what I've heard (insulated with electric tape)
  5. WA_Bob

    WA_Bob VIP Member VIP Member

    Well, I used the paperclip after I read about someone else doing it and it worked but the right sized piece of wire would work better IMO. That would allow you to use two hands and it looks much easier that way.
    scotty85 likes this.
  6. scotty85

    scotty85 Guides Guide

    i concur. i used a small piece of wire
    chknhwk likes this.
  7. mtbhk44

    mtbhk44 Well-Known Member

    I knew I shouldn't have done this - LOL - it failed the first time around. Now I'm stuck at the arrow screen and I cannot get into recovery of any sort. When I pull the battery and restart, it just boots to the arrow and sits there. When I pull the battery and attempt to get into recovery it just keeps booting into fastboot and it sits there.

    Any suggestions gang?
  8. pwned

    pwned Well-Known Member

    You need to flashyour boot.IMG again or re run the tool from there. It picks up where it left off
  9. mtbhk44

    mtbhk44 Well-Known Member

    I can rerun the tool from the arrow? I've tried that to no avail

    How do I flash my boot.img again - from the command prompt on my PC?

    Edit - OK - somehow after all of my fiddling I ended up being able to restart the phone and I'm back on the home screen. I don't know how or why this happened, but it did. Yay. Now it's not seeing my SD card but I think I'm going to try and start over.
  10. mtbhk44

    mtbhk44 Well-Known Member

    I must be ******ed (no offense to the mentally ******ed). I wonder if I'm not doing the wire trick right. I cannot get this to take. Do you have to touch the contacts more than once, or just touch both within 1.75 seconds. I'm getting errorcode 66732337. Still sober. GRRRR
  11. imparables

    imparables Member

    Edit: OMG, some powerful, evil, dark force took my body over. It forced me to do it. I didn't want to I swear....I swear. It just took total control of me.

    And ladies and gentlemen it made do it...I achieved s-off.
  12. mtbhk44

    mtbhk44 Well-Known Member

    I have tried seventy five different ways from Tuesday. I cannot, for some reason, get the contacts to receive the wires. I've gone from start to finish and every time I get to the wire trick portion, it fails. I just spent the better part of 10 minutes even getting the phone to accept one wire touch. I think I'm giving up.
  13. WA_Bob

    WA_Bob VIP Member VIP Member

    Sounds like it might be time to take a break for a few. But it does indeed work and I can attest that it took a while for me to get my timing down to do it. You can do it!
    mtbhk44 likes this.
  14. imparables

    imparables Member

    So from one of your previous posts you cannot re-run the program from your PC.....where it left off? It took me a few minutes to get the wire trick to connect correctly. For a minute it semed like my wire wasn't working. You doing exactly what the ytube video does? What type of wires you're using? Don't give up.
    mtbhk44 likes this.
  15. imparables

    imparables Member

    So this means your wire trick is working but you're getting an error message? If so did you extract the zip files from bear, which are 4 files, into the adb file you used to root your phone? Not to be redundant but can you explain from start to finish what you're doing? What firmware and rom you're running?
  16. mtbhk44

    mtbhk44 Well-Known Member

    It was. I took a break, grabbed some very low grade speaker wire and tried again. SUCCESS!
  17. mtbhk44

    mtbhk44 Well-Known Member

    No, apparently I WAS able to start in the middle, from the arrow. For some reason (probably my own stupidity) I thought I wasn't able to. I probably got impatient. Anyway, I reinstalled recovery and the boot image and I was good to go. I think the missing recovery was the wild card in all of this - just guessing though.
  18. imparables

    imparables Member

    OK....keep going. You'll get it.
  19. mtbhk44

    mtbhk44 Well-Known Member

    Yep - I did finally get it. Thanks for the push!!!
  20. WA_Bob

    WA_Bob VIP Member VIP Member

    Groovy man! Welcome to the club! :beer:
  21. imparables

    imparables Member

    Congrats....lol. Glad it finally worked.
  22. scotty85

    scotty85 Guides Guide

    awsome! :party:
    chknhwk likes this.
  23. DroidPhreak

    DroidPhreak Active Member

    So the first time I ran it, it went into fastboot however it stood there, doing nothing. I saw the JuopunutBear boot screen and the computer end was doing nothing. After hours of reapplying my boot/kernel (I needed a working phone) I was done. A few hours later, I decided to give it a shot again so I ran the program but this time, my phone wouldn't even restart at the moment the program said it would. I read a bit more about this and saw that you have to be in the current rom and let the program do it's thing automatically. One thing I didn't want to do was wipe/reinstall my ROM but seeing as nothing else worked, I had to take that route. Despite me wiping the phone, re-installing the ROM (inefabilis 1.4 at the time) the darn thing would still do nothing. Frustration got the best of me and decided I would leave it for tomorrow. I had some time yesterday and decided the last resort would be to RUU back after a few more attempts. While I was RUUin'g I needed a rom of some kind just to get through the program so I went with RezRom 1.6 and had it ready to copy over once the RUU was done. RezRom was installed, I started the program and to my relief, it was finally doing the steps properly. Once I ran that, I was able to get through the whole way through and the wire trick I got working on the first try. I think I had read so much of people's experiences and what to do that I was able to pull it off that quick. Once installed, I wiped the phone and went back to Inefabilis and now I have an S-off rezound :D. This whole time I wanted to preserve the phone without wiping but I guess I should have RUUed from the get go. Just wanted to give my experience with this and would highly recommend just RUU'ing back. All the time spent on figuring out the problem proved somewhat fruitless since it was on my end rather than the program's end.
  24. howardz2

    howardz2 Active Member

    Well, I did get S-OFF. It took me two nights (totalled about 8 hours). Required much time at the jBear mIRC chat room for all sorts of things the jBear website doesn't tell you. I was using the original first version of jBear S-OFF, so it is possible things have changed for the better.

    jBear's website is

    unlimited.io

    (no www. )

    Here are my pointers:

    1. Use a spare SD card. The jBear process will end up wiping it. When you are all done that SD card will need to be totally reformatted. It takes quite some time to format an SD card, so I did it in my PC.


    2. Find the kernel boot.img file for the current GB, ICS Leak, or ROM that you are currently using. You also need to know the adb/fastboot commands to flash that kernel file. The jBear process replaces your kernel and reboots to this jBear kernel. If you are not successful at doing S-OFF and want to stop trying and put your phone into a usable state, you will need to flash your saved kernel file. No kernel file equals you can't use your phone.

    3. Make a nandroid backup of your entire system (check all boxes in Ramon RA recovery). You might need it - as I certainly did.

    4. You download the sBear zip file for your firmware (GB or leaked ICS) and copy the files from the zip file to the directory on your PC where you have the adb/fastboot files stored. (Of course you should have a working adb/fastboot system with the htc drivers installed).

    5. Boot up your phone normally, connect phone to PC as charge-only with usb debugging ON, and then run the jBear exe file on your PC. You don't know how much time I wasted trying to run the jBear exe file and getting errors while the phone was in bootloader/fastboot mode. The video on the jBear website shows starting off in hboot/bootloader - probably to show the before picture, but I thought I was supposed to start at that state. Also, the video just shows the starting state and ending state of the bootloader screen and does not show even a single step that one takes to perform the jbear S-OFF process.

    6. When the jBear exe file tells you to do the wire trick, keep trying to do the wire trick until the software stops asking you to do it. I used a large insulated paper clip with the insulation stripped off a bit on each end. It is important to keep the paper clip straight in the pin#1 hole to make good electrical contact. You need to touch the other end of the paper clip briefly to the ground pin and then do it again after waiting 1.75 seconds. So this takes alot of trying.

    7. I am on GB, and the jBear program installed the ENG hboot. The bootloader screen looks different than other peoples' screen. This is because they were on the ICS leak and received a different hboot program from hBear. My screen said "ENG S-OFF" and did not say Juoblahblahcan'st spell it. So, I naturally got help and repeatedly reflashed the hboot file, but never got the same screen as the other successful S-OFF people - this was another waste of my time due to incomplete directions.

    8. I think we should just call it F**KBear until the wonderful developers change the name to something everyone can easily remember and spell.

    In general the entire HTC user family is gratefull for this capability. It will probably provide us with valuable capabilities. For example, I have read S-OFF should allow us to RUU backwards to previous versions of official HTC/Verizon released operating systems.

    Regards,

    Howard
    chknhwk and Skorpios1027 like this.
  25. Skorpios1027

    Skorpios1027 Frell me dead VIP Member

    Excellent advice, I used an old 2GB sdcard and formatted it prior to starting the process. When it was all said and done though, my sdcard was blank, but did not need reformatting, YMMV.

    Always good advice to CYA
    Note: The file I got was called ControlBear.exe and that you should run the .exe file from the gui (as administrator), not the command line (I was using Windoze). After successfully doing my phone, I went to do another and since I was in a shell already, tried to run it from there and kept getting "Can't find the bar" errors.
    If you get the message still sober, all you should need to do to try again is exit the ControlBear.exe and rerun it, do not reboot your phone.
    Agreed, the directions on the unlimited.io page leaves much to be desired, and wading through pages of posts on the forums can be confusing. The important thing you should see on the bootloader screen is S-off.

    I was fortunate in the fact I was able to achieve S-Off on the first attempt.

Share This Page