1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Where is the mic button on ICS keyboard?


  1. Jeffery

    Jeffery Well-Known Member

    The mic button is missing for me on the keyboard when I use Gmail and Google Voice. Anyone have any suggestions? I like to dictate my texts.

    Advertisement
  2. Thom

    Thom Premium Guide Member Guide

    A little more information is needed ...

    "mix button"?
    "mic button"?
    "ICS keyboard"?

    ... Thom
  3. Jeffery

    Jeffery Well-Known Member

    The keyboard used to have a microphone button next to the "?123" button, now it is a comma button.
  4. Thom

    Thom Premium Guide Member Guide

    If this is the standard Bionic keyboard ... hit the key labeled "ABC".

    ... Thom
  5. fatpomp

    fatpomp Well-Known Member

    It's not the standard keyboard it's the ICS keyboard he's running the ICS rom.

    Jeffery I don't have the mic button either. I'm pretty sure I saw on rootzwiki other people were having the same problem.
    Jeffery likes this.
  6. Jeffery

    Jeffery Well-Known Member

    In Android keyboard settings under Voice Input key I have "On main keyboard" checked. There are also 2 other options: On symbols keyboard (that doesn't work either) and Off.
  7. fatpomp

    fatpomp Well-Known Member


    I saw those too and they didn't work for me either.
  8. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Ummm, I have ICS4BIONIC 2-014 release and it is there.

    Do you have Bluetooth enabled?
  9. Jeffery

    Jeffery Well-Known Member

    I am running 02-14 and I do not have bluetooth enabled.
  10. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Just checked, and even though BT enabled kills audio on phone calls, it's not affecting the mic on the KB.

    Perhaps a bad flash? I have it here without an issue:

    Screenshot_2012-02-16-21-36-49.jpg
  11. Jeffery

    Jeffery Well-Known Member

    What's even more weird is that my keyboard doesn't have the settings between 123! and the voice input button.

    I used pathsaver, then upgraded to .902, installed safestrap then installed the previous alpha. When 02-14 came out I wiped cache, dalvik, and formatted system, then installed 2-14 and the Gapps from my other post.

    Weird...

    I guess I'll make a backup, wipe everything and reinstall.
  12. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Well, I had a really old (Alpha 7? 8?) install in safestrap so I wiped everything and went to the 2-10 release when data was finally confirmed. I just upgraded to 2-14 last night, and all I did was wipe system, cache and dalvik and it's there. I can't say whether it was there under 2-10 or not, but I'd try wiping those three again and installing.

    Did you get the GAPPS 2-14 release also?
    Jeffery likes this.
  13. Jeffery

    Jeffery Well-Known Member

    Yes, I made a thread with the links for GAPPS 2-14 and ICS4BIONIC 2-14 when I found them on twitter.
  14. tehsusenoh

    tehsusenoh Well-Known Member

    Make sure that the voice input is selected in the input settings. If all else fails, just reflash, making sure to wipe system, cache, dalvik, then flash ICS and the GApps.
    johnlgalt and PowerBomb like this.
  15. PowerBomb

    PowerBomb Well-Known Member

    My mic was missing too but this piece of advice is what brought it back. This is a separate option from the "display mic key on keyboard/symbols keyboard" setting that we all said we already knew about and already tried. That option is in the settings for "Android Keyboard", but one screen prior to that, when you are just at the "Language & Input" list screen, where it lists whatever keyboards you have installed (Android Keyboard, Swype, Japanese IME), make sure Google Voice Typing is turned on. Now my mic button is back. I'm running the 2/10 version of the ROM, haven't bothered with flashing 2/14 yet.
  16. Jeffery

    Jeffery Well-Known Member

    For some reason I don't have the option to check Google Voice Typing.
  17. PowerBomb

    PowerBomb Well-Known Member

    Strange. I'm not certain but I think that would be related to the Google apps pack that you flash along with ICS, so maybe try getting the most recent Gapps.zip again and try flashing it.
  18. Jeffery

    Jeffery Well-Known Member

    I wiped everything and reinstalled w/2/14 gapps and had the same problem.

    So I decided to install 2/09 Gapps, that solved my problem.
  19. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Ummm, that is weird. I'm running ICS 2-14 + GAPPS 2-14 and it's all there.

    I started with 2-10 of both, and when I did 2-14 set, I didn't wipe everything, only /system /cache and the dalvik cache. I can't understand why it is not there, and why you cannot enable Google Voice Input.....
  20. Jeffery

    Jeffery Well-Known Member

    Oddly, after reading your post I reflashed the 2-14 Gapps w/out wiping anything and the Google Voice Input is now working. Very odd issue, no idea what could possibly have caused this problem, but it's working now and that's what matters!

    Thank you everyone for your help.
  21. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Ever since the separation of GApps into a separate ZIP file for ROM development (almost 2 years ago, IIRC, that I saw the GApps file), these sorts of issues have always persisted.

    Glad the reflash worked.

Share This Page