Why are all Google Native Apps only for OS 2.0 and up?


Last Updated:

  1. thomasanderson

    thomasanderson Well-Known Member This Topic's Starter

    Joined:
    Nov 6, 2009
    Messages:
    180
    Likes Received:
    14
    Is it just me, or is it weird to anyone else that more than half the apps Google itself releases for Android leaves us 1.5 users high and dry? It would seem that if anyone would empathize with us poor schmucks who got suckered into buying a phone whose OS went obsolete in 3 weeks Google would. Seems like when I view all the apps Google has for Android every other app I search for comes up nill on my Hero.
     

    Advertisement
  2. ScorpDX

    ScorpDX Well-Known Member

    Joined:
    Feb 7, 2010
    Messages:
    1,642
    Likes Received:
    375
    Why would they spend time developing apps for an outdated OS? Then there would be no apps when the new OS went live.

    That's like asking someone to write a program for windows 95, just makes no sense!
     
  3. wodin6

    wodin6 Well-Known Member

    Joined:
    Dec 18, 2009
    Messages:
    118
    Likes Received:
    13
  4. Sorce

    Sorce Member

    Joined:
    Feb 23, 2010
    Messages:
    23
    Likes Received:
    5
    Most likely the apps use APIs opened up in 2.0. If the code could actually work against 1.5 I don't see why it wouldn't be compatible. Basically that means there are certain things the software can ask the os to do. At an older version the os doesn't know what to do with those requests so those calls won't work.
     
  5. cooolone2

    cooolone2 Well-Known Member

    Joined:
    Nov 5, 2009
    Messages:
    737
    Likes Received:
    65
    More buyers remorse? Come on already... 2.x will be available to Hero owners 1st half of 2010. We are barely through 1st quarter and still people seem confused.

    What Google apps to be specific? Goggles? Maps? My Google Maps works fine, but is it you are wanting street access or turn based voice?

    This forum will guide you through tweaking the Hero to function wonderfully, yes, albeit without Google/HTC/Sprint support as they all seem to be looking forward, which we are all eagerly awaiting the release of their hard work. Until then we are left to patiently await those apps.

    Or... just ROOT it, lol...

    :cool:
     
  6. cooden

    cooden Active Member

    Joined:
    Nov 8, 2009
    Messages:
    43
    Likes Received:
    10
    It just amazes me how people do not use the search button or read any of the posts on the same page! You can download the 2.1 version, if you can use the internet, you can upgrade your phone. You literally install it on your computer, hook up your phone and click the next button. That's it!!!!!! About 15 minutes later, BOOM--you have 2.1 on your phone. Google Goggles, Navigator, etc. Just do some reading!
     

Share This Page

Loading...