Why Can't I Select Text Notifications in Google Voice?Support


Last Updated: 2012-05-18 18:22:42
  1. Apota4u

    Apota4u Member

    I want to setup my phone where text message notifications are disabled for my regular telephone text messages but enabled for GV text messages. I get hundreds of text messages per day on my regular telephone number, so it will drive me crazy to constantly get notifications, but only my friends and family send me text messages on GV number so I want to get notifications on that right away, but for some reason it GV won't let me select to get text notifications. Does anyone know how to fix this issue? Thanks for your help and time!

    PS - I just figured it out. It's because of the, "Receive Text Messages" option not being checked. It lets you check, "Only Via the Google Voice app" or "Also Via The Messaging App". I have the 2nd option selected. If I select the 1st option it lets me choose text message notifications, but does that mean that all my GV text messages will only show up in the GV app and no longer on my phone? I don't want to do that. I want them to show up in both places but I want to only have the notifications for GV and not my phone. I was able to do this before.

    Attached Files:

    • 250.jpg
      250.jpg
      File size:
      154.8 KB
      Views:
      14

    Advertisement
  2. trophynuts

    trophynuts Well-Known Member

    have you tried going into your stock text messaging app and turning off vibrate notifications in there?
  3. Apota4u

    Apota4u Member

    Yes, look at my PS in my previous message that I just added. I figured out why it's doing it, but this creates another issue. It seems like the only way I can get notifications is if the text messages only go to the GV app and not my phone anymore. I hate using the GV app for sending text messages because it doesn't tell you when you are going over the 160 character limit like it does when sending text messages on your regular phone or I might consider doing it.
  4. trophynuts

    trophynuts Well-Known Member

    guess this is a bit out of my realm since i've never used GV
  5. binary visions

    binary visions Well-Known Member

    You can't do what you want to do.

    If you receive messages in your Messaging app, it's forwarding messages to your text message database which triggers the notification in the Messaging app. The messaging app can't filter out the texts it got from Google Voice from the texts it got the regular way, and the Google Voice app doesn't want to notify you twice, so it disables its own internal text message notification and leans on the Messaging app's notification.
    trophynuts likes this.
  6. Apota4u

    Apota4u Member

    Well, a while back it used to work that way, so something must have changed for it not to work that way anymore. I used to get double notifications & I could disable the sound on my phone only. So, I have to think of another solution.

    I wouldn't mind having my GV texts go only to my GV app if my GV app would tell me when I'm going over my 160 character limit. How am I supposed to know if my msg is getting cut off with out it? Is there a way to get that enabled? I don't understand why that isn't an option, I've seen it in every other text messaging app, and GV has that feature if you are sending text messages from their website, so why wouldn't they have it in there app?

    Another solution is to have my text messages forwarded to my email account and since I don't use my Gmail account for my emails then the only thing going in there would be my text messages, and enable notifications on my Gmail account.

    Those are the only 2 solutions I can think of unless anybody else has any other ideas? Thanks!



  7. binary visions

    binary visions Well-Known Member

    You know that it'll just send a second SMS if you go over 140 characters, right? It doesn't just drop the last piece.
  8. binary visions

    binary visions Well-Known Member

    (I know that doesn't solve your problem, I just wanted to make sure you knew it didn't just truncate the message)
  9. Apota4u

    Apota4u Member

    No, I didn't know that. Well, if that's the case then maybe I'll just do it that way. I thought it truncates the message and they won't see anything after the 160 characters. It would still be nice to know when you are going over the 160. It's stupid Google doesn't put that option in there.

  10. binary visions

    binary visions Well-Known Member

    I agree that it's silly.

    If you send over the character limit, GV will automatically prepend a number to the beginning of the text messages when sent, so the person receiving will know it's a series. I.e. if you send 200 characters, it'll say:
    "(1/2) <first part of message>"
    "(2/2) <second part of message>"
  11. Optimizm

    Optimizm New Member

    Is there anyway to disable Google Voice from sending me an email and transcipt after every voicemail I receive? Also, how do I turn off the "screen calling" feature? That is cumbersome and a lot of people hang up before I can pull up the virtual dialpad to enter "1".
  12. Tim K

    Tim K Well-Known Member Contributor


    What you want to do is disable the stock messaging apps so you don't get any notifications at all, no sound, no vibrate. Do you also want nothing in the notification bar either?

    You only want notifications of Google Voice Texts correct?

    Simple. Set stock messaging app to silent, no vibrate, uncheck display notifications in status bar. That essentially disables any notifications from the stock SMS app.

    Now, set up notifications in Google Voice via the app.

    Select receive text messages "via the google voice app"
    Check off Text Notifications to get a notification in the pulldown bar.
    Check vibrate if desired.
    Select ringtone if desired.

    If you get a standard SMS/MMS via your phone number your phone will not notify you in any way.
    If you get a text via your google voice #, you will get a notification, a ring and vibrate (if selected)

    I think your confusion was with the term "via the google voice app". I think you believed that would mean you would see texts only if the app was open....when in fact it will handle notifications separately like any other service.
  13. Tim K

    Tim K Well-Known Member Contributor

    No. That's not necessarily true. I just did exactly what the OP wanted. Disabled notifications on my messaging app and enabled them in my google voice app. I ONLY get notifications on google voice texts. All you have to do is enable the "receive notifications via the google voice app".
  14. Tim K

    Tim K Well-Known Member Contributor

    To stop the announcements and to stop getting the transcript you have to log in to google voice on the web and go into settings there.

    www.google.com/voice

    Under "Voicemail Notifications" uncheck "Alert me when I have new voicemails"

    Under "Calls" set "Call Screening" to OFF.

Share This Page