Support Why is my Droid X sooooo slow?

Discussion in 'Android Devices' started by xsists, Jul 16, 2010.

  1. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    I just got my X like 2 hours ago now and it is a complete snail! I have rebooted it twice and still it will not keep up with my texting. I run no other apps other than messaging and I've deleted all the widgets and am not using a live wallpaper. I really need to figure out whats going on because its so laggy and making me so frustrated. Again, no apps are running, I haven't even went into the market place yet.

    Even turning on the phone, the screen takes a while to come up and the opening animations are all glitchy. Happens every start up, even the first start up!

    Whenever I get a message the ringtone goes "dddddd..rrr..ooooooo.iii.dddd" and its all choppy even.

    Like I said, nothing is running nor is anything downloaded, what could be the problem?!?!
     

    Advertisement
  2. 8-Bit-Soldier

    8-Bit-Soldier Well-Known Member
    63

    Dec 10, 2009
    258
    59
    63
    Atlanta
    Are you using a task-killer?
     
  3. geno51

    geno51 Well-Known Member
    16

    Jul 11, 2010
    48
    7
    16
    Hrmm you must have a bad one or done something?? mine is faster then the wifes droid INC :thinking:
     
  4. phobic

    phobic Well-Known Member
    43

    Dec 7, 2009
    258
    42
    43
    Maybe you have a bad one? Mine X is noticeably faster than my overclocked Droid I stopped using yesterday.
     
  5. PurePursuit

    PurePursuit Well-Known Member
    38

    Jul 5, 2010
    120
    10
    38
    just got mine, and its insanely fast even on stock moto launcher. Try launcher pro.
     
  6. Paznos

    Paznos Well-Known Member
    68

    Mar 6, 2010
    499
    214
    68
    What's the default battery settings for the Droid X? is it the Smart setting?
     
  7. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    No task-killer.. Again, no apps at all. I'm not even opening anything but messages.

    I really hope its not a bad one because them I'm stuck with it until after next friday (I take it they won't have any available until all the other orders ship out). I can't goto the store because they can't pull up my account (I have a discount that doesn't allow me to do things in the store).

    I'm considering a full wipe and starting over.. I synced google and facebook at the same time and maybe something got messed up?
     
  8. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    it was on smart setting and I changed it to performance mode..
     
  9. jreed2560

    jreed2560 Well-Known Member
    173

    Dec 31, 2009
    3,922
    439
    173
    Male
    Sales Specialist/Wireless Consultant
    Tennessee
    try doing this. goto menu>settings>sound&display>disable all window animations. this should speed things up a tremendous amount. also if you aren't using the widgets on the homescreens, then get rid of them. if you notice keyboard lag, disable haptic feedback as well. hope this helps

    also goto menu>settings>applications>running services. clear out all the updates for the widgets as well as anything else you see in there thats running that you don't need.
     
  10. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    I disabled everything listed above and am running launcher pro and its still super slow... really really unhappy right now..
     
  11. jroc

    jroc Well-Known Member
    363

    Apr 10, 2010
    2,614
    358
    363
    I'm just throwing out guesses....try running the phone with the sd card out see if that changes anything.
     
  12. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    I just did a restart after launcher pro was installed and its ripping pretty good right now.. I just would like to use the phone stock for a bit before I start messing with adding stuff.

    I'll try the memory card trick (worked with my bberry before).
     
  13. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    Well, as I just was typing that, the phone decided to go back into crawling mode.. :(
     
  14. NKT

    NKT Well-Known Member
    313

    Feb 5, 2010
    1,571
    3,009
    313
    Try booting into safe mode and see if you still get lag.

    To start Safe Mode:

    Press and hold down the Power Key.
    Touch Power Off.
    Touch OK.
    Press and hold the menu key, then press the power key to power on device
    Continue holding the Menu key until Safe mode appears in the left corner of the screen.
    This may take up to 30 seconds.
    Safe Mode will appear in the bottom *left* corner
     
  15. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    there appears to be no lag in safe mode..
     
  16. NKT

    NKT Well-Known Member
    313

    Feb 5, 2010
    1,571
    3,009
    313
    Try a factory reset and see if lag returns in normal mode.

    Make sure you've synced your contacts. This will wipe the phone.
     
  17. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    Care to tell me how to do a factory reset?

    Sorry, its my first android phone...
     
  18. NKT

    NKT Well-Known Member
    313

    Feb 5, 2010
    1,571
    3,009
    313
    Reset

    To reset your phone to factory settings and erase all
    the data on your phone, press Menu > Settings
    > Privacy > Factory data reset > Reset phone.
    Warning: All data on your phone will be deleted.
    (Nothing on your memory card is deleted.)
     
    xsists likes this.
  19. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    Thanks! I'm trying it now..
     
  20. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    Ok after reboot it was still a bit sluggish. I took out my memory card and everything was fast. Put it back in and it started to be sluggish again. I am now back to running without it and its fast as everyone else is saying it is.. Weird. Gonna have to see if I can get a replacement memory card. So far this is my finding.. I'll report back later with anymore info I find.
     
  21. jroc

    jroc Well-Known Member
    363

    Apr 10, 2010
    2,614
    358
    363
    Try re-formatting the SD Card before taking it back. Its good to see u narrowed it down.

    What class is the SD Card? Just curious. It has a lil circle with a number in it.

    We have to tell ppl that see a slow X at the store to take out the SD Card first...lol

    I've seen SD Card issues with some ppl trying to make a Nandroid back up or restore one on a rooted phone running custom ROMs. I think those were bad or corrupt cards.
     
  22. syntrix

    syntrix Well-Known Member
    163

    Nov 6, 2009
    2,418
    303
    163
    engineer
    The South
    stock card that came with it is 4.

    OP never said if he's using the stock card or one from another phone.
     
  23. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    Yes, its a 4, yes I am using the stock card and yes I did try to reformat the card before narrowing it down to a bad card.

    [Quoted offensive post removed by Mod]
     
  24. xsists

    xsists Active Member
    15

    Apr 21, 2010
    41
    0
    15
    Well its been a couple hours now, again I'm still not using anything but messages and the phone has went back to crawling along. This is so damn frustrating because I can't even play with my new phone its so messed up.. Works great in safe mode but works like crap in regular mode..
     

Share This Page

Loading...