Support Why Long Sms are getting converted in to MMS !

Discussion in 'Android Devices' started by augustya, Dec 25, 2011.

  1. augustya

    augustya Well-Known Member
    36

    Sep 19, 2010
    133
    2
    36
    Hi Guys,

    Is there any such thing that when you are typing a text message which you are trying and wanting to send it as an SmS if it exceeds certain character limits, number it auotmatically gets converted in to an MMS (Multi-Media Message) which I dont want. If I am trying to send a text message a SmS, I want all my SmS to remain as SmS and not get converted in to MMS right now what is happening is beyond a ceratin limit my Long Text Messages are getting converted in to MMS which I dont want... How do I stop this from happening ??

    Thanks.
     

    Advertisement
  2. skimminstones

    skimminstones Well-Known Member
    53

    Sep 20, 2009
    335
    52
    53
    dont think you can with the stock message app unless you root and install a mod for it.

    you can if you use handcent though as your messaging app. theres an option in settings to not convert to mms if messages exceeds 3 sms
     
  3. augustya

    augustya Well-Known Member
    36

    Sep 19, 2010
    133
    2
    36
    Message setting just says Text Message limit, which I think suggests how many messages you can set per onversation. I dont think there is anything in settings which can allow me to set maximum letters in a SMS.

    So what is it that you are suggesting ? where do I change it ?
     
  4. Slug

    Slug Check six!
    Moderator
    1,943

    Aug 1, 2009
    20,537
    16,931
    1,943
    Male
    Mobile phone retail
    Inverness, UK
    You can't change it in the stock app - that's what Skimminstones said.
     
  5. Remeniz

    Remeniz Well-Known Member
    43

    Aug 20, 2011
    399
    46
    43
    Computer Tech & Audio Engineer
    Peterborough - UK
    Any message you compose that has 480 characters or more will be converted into an MMS. This is a restriction on SMS technology, I think?, due to the amount of data involved.

    In fact the limit is 160 characters per text but latest technology allows you to string 3 x 160 blocks together as one message, then it's up to the receiving device to put the 3 blocks together as they were composed.

    So either break up your messages into 480 character messages, carry on composing and send as MMS, or send an email instead.
     
  6. augustya

    augustya Well-Known Member
    36

    Sep 19, 2010
    133
    2
    36
    So what do I do to make sure that messages which I wanna send as SMS and only SMS and not MMS (Long or Short) are sent as SmS and are not converted into MMS.
     
  7. Remeniz

    Remeniz Well-Known Member
    43

    Aug 20, 2011
    399
    46
    43
    Computer Tech & Audio Engineer
    Peterborough - UK
    Messages > Menu > Settings > Creation mode. And select Restricted.

    Edit:

    If this doesn't work then just look out for the little warning message when composing.
     
  8. augustya

    augustya Well-Known Member
    36

    Sep 19, 2010
    133
    2
    36

    I previously had a Nokia N900 and it would never convert no matter how long is your text even if it is like a email. Too sad can't do this.
     
  9. augustya

    augustya Well-Known Member
    36

    Sep 19, 2010
    133
    2
    36
    Ok, doing this would do what ?
     
  10. skimminstones

    skimminstones Well-Known Member
    53

    Sep 20, 2009
    335
    52
    53
    dude, just download handcent and use that
     
  11. Organon

    Organon Well-Known Member
    16

    May 7, 2011
    62
    3
    16
    I use handcent and it still converts long sms' to mms. even though it's set not to do it.
     
  12. skimminstones

    skimminstones Well-Known Member
    53

    Sep 20, 2009
    335
    52
    53
    in which case it cant be done. End thread!
     
  13. Russell Ng

    Russell Ng Well-Known Member
    143

    Sep 29, 2011
    1,384
    166
    143
    Male
    Engineer
    Kuala Lumpur
    I think that's true. I remember doing something like 5 messages once. Of course it might have been changed to MMS without you noticing it. No warning ever came up like in SGS2. Regardless, why do you write such long sms?
     
  14. Pedro_XXL

    Pedro_XXL Member
    6

    Sep 15, 2011
    5
    2
    6
    Hi,
    Also annoyed about the auto convert from "free" to "charged" messages and I'd like to switch it off. Either allow more messages to be concatenated or just stop allowing entry at the end of the third message. Simples.

    In reply to anyone who thinks that more than three SMS cannot be done due to some limit in the protocol, my daughter just got a new (white) SGS2 on Orange (same as me) and she sent me a 4 x SMS message today...(screengrab)...but when I try it the "0/3" changes to "1KB" and the "converting" popup appears.

    Her phone is evidence that it can be done. She's on 2.3.4, I just went from 2.3.3 to 2.3.5 and I still can't get to the 4th SMS. :mad:
    Must be a "deep"/hidden config setting of some kind. I guess the carriers just want the money.
     
  15. slatyford

    slatyford Well-Known Member
    43

    Jan 13, 2010
    231
    34
    43
    Download and install Handcent > settings > send message settings > uncheck auto convert
    and away you go.
    In the stock app settings uncheck notifications and that will allow only hancent notification in the task bar
     
  16. buntoo

    buntoo New Member
    5

    Dec 29, 2010
    3
    0
    5
    On stock application it is not possible. Use "GoSMSPro". I'm using it on my SGS2 and you can send more than 3 text messages as sms. It wont convert it to an mms. Plus it is free, with lot of customizations and without any ads. :)
     
  17. augustya

    augustya Well-Known Member
    36

    Sep 19, 2010
    133
    2
    36
    What is "Stock app settings" ?? What does it mean ??
     
  18. Slug

    Slug Check six!
    Moderator
    1,943

    Aug 1, 2009
    20,537
    16,931
    1,943
    Male
    Mobile phone retail
    Inverness, UK
    Disable notifications in the standard messaging app (the "stock" one) if using third-party apps so as not to receive duplicate notifications.
     
  19. augustya

    augustya Well-Known Member
    36

    Sep 19, 2010
    133
    2
    36

    Ok, and how do I do that ? Say, if I am using a different APP then the inbuilt (Native) SmS App in my phone ! How do Disable the notification for my native SmS App ?
     
  20. geoffibs

    geoffibs Well-Known Member
    16

    Jul 11, 2011
    67
    9
    16
    Handecent will switch off the stock notification for you.

    Start Handcent.
    Menu - settings
    Application Settings
    Default Messaging Application
    Select "All (SMS & MMS)"

    Then, to stop it converting to sms make sure as others have said, go into :
    menu - setting
    send message settings
    Untick "Auto converto to MMS"
     
  21. trailblazer

    trailblazer New Member
    15

    Jan 10, 2012
    3
    0
    15
    GO SMS Pro did the trick for me.
     
  22. jimmyjoey2

    jimmyjoey2 New Member
    5

    Feb 27, 2012
    1
    0
    5
    Journeyman Laboer/Local 440
    Seattle WA
    messages>settings>multimedia message limit> set your own limit......
     
  23. Russell Ng

    Russell Ng Well-Known Member
    143

    Sep 29, 2011
    1,384
    166
    143
    Male
    Engineer
    Kuala Lumpur
    Not what the OP asked. That multimedia message limit does not prevent changing of SMS into MMS.
     
  24. flugga

    flugga New Member
    5

    Mar 27, 2012
    1
    0
    5
    No way to fix the issue in the stock messaging app. Had to install Handcent. by the way you can report the issue here :

    code.google.com/p/android/issues/detail?id=2318
     
  25. dynomot

    dynomot Well-Known Member
    263

    Dec 4, 2011
    1,897
    902
    263
    Male
    Sheffield U.K
    All SMS on any phone has a limit. An N900 (great phone still) sends any size SMS, but check your bill you'll find a l ong text will use more than one standard text. It is the way some phones handle SMS that is different.
     

Share This Page

Loading...