General Why won't all pages zoom?

Discussion in 'Android Devices' started by Rafalema, Dec 28, 2011.

  1. Rafalema

    Rafalema Well-Known Member
    38

    Jan 22, 2011
    90
    13
    38
    Finland
    So we recently got a Galaxy Tab 10.1 for my mother and today she asked me, why won't all websites zoom in?

    Now I tested this, and I know that the pinch-to-zoom function works on everything else, but on few pages. Why? Why can't I zoom that page?

    Thanks in advance!
     

    Advertisement

  2. Szadzik

    Szadzik Well-Known Member
    223

    Feb 15, 2010
    5,413
    715
    223
    Male
    FAS Admin
    When you get onto a website and it is the mobile version, it will not zoom.
     
  3. bfksc

    bfksc Well-Known Member
    143

    Aug 29, 2010
    1,262
    201
    143
    Canada
    While most mobile webpages won't zoom (because cell phones have small screens and formatting should be correct), there is a way around this if you don't mind viewing all pages in full "desktop" format like on your computer. This will use a bit more data as it will download the full webpage rather than the more concise mobile version, but I prefer it as it looks much better on the 10" tablet.

    To make this change, you need to adjust the hidden "debug mode" settings.

    To enable debug mode, open the browser and type in the address "about:debug" without the quotes and hit Enter. Now just tap the Settings icon in the upper right corner of the browser. You will see a few new options to select at the bottom of the list, just tap on Settings. Now look for Debug in the list of settings on the left part of the screen. Tap on it to open the debug settings. Tap on UAString to open the choices for the info string that will be passed along to the website - this is part of what controls the formatting of the webpages. Tap on Desktop to select it and the popup window will close. Now just hit the Back button a few times to get back out to the browser window. You can now either continue to use it as is, or turn off Debug settings (the UAString will be remembered between sessions) by typing the same "about:debug" in the address bar to turn off the Debug options.

    That's it...now enjoy full webpages on your tablet that can be zoomed!
    :D
    PS - if you don't like the full desktop view, you can just go back into the debug mode and change the UAString back to Android or NexusS or whatever to show mobile views.
     
  4. Rafalema

    Rafalema Well-Known Member
    38

    Jan 22, 2011
    90
    13
    38
    Finland
  5. bfksc

    bfksc Well-Known Member
    143

    Aug 29, 2010
    1,262
    201
    143
    Canada
    Nope that page doesn't zoom for me either. I guess it has something to do with the HTML coding to prevent zooming for some demented reason.
    :eek:
     

Share This Page

Loading...