Why would the calander be keeping the phone awake? (Running official 2.1)


Last Updated:

  1. scottmbolt

    scottmbolt Well-Known Member This Topic's Starter

    Joined:
    Feb 13, 2010
    Messages:
    624
    Likes Received:
    47
    -Phone unplugged from the charger at 9:12 with 100% Battery power (according to battery indicator)
    -Access the market once
    -wake up the phone at 9:43 and the battery indicator is down to 94%

    wtf? Check spare parts partial wake usage since last unplugged and the Calander is up there at the top above the Android system.

    Comments, answers, anyone else have this issue? I hope its not some bug, because I didn't touch a calendar once, nor did I update or even sign onto my Gmail from my computer and make any changes.
     

    Advertisement
  2. Kelmar

    Kelmar Done by choice VIP Member

    Joined:
    Nov 28, 2009
    Messages:
    11,815
    Likes Received:
    4,750
    No issue here....

    Try rebooting and see if it continues.
     
  3. toasty

    toasty Well-Known Member

    Joined:
    Jan 17, 2010
    Messages:
    290
    Likes Received:
    25
    My battery life has been plunging as well, and I've also noticed the calendar app at the top of the list. Don't really have a solution, though...
     
  4. Kelmar

    Kelmar Done by choice VIP Member

    Joined:
    Nov 28, 2009
    Messages:
    11,815
    Likes Received:
    4,750
    My poor battery was due to the updated radio that was released with 2.1. It made my phone constantly lose and look for a signal.
     
  5. bluemark

    bluemark Active Member

    Joined:
    Feb 13, 2010
    Messages:
    43
    Likes Received:
    5
    Did you find a remedy?
     
  6. Kelmar

    Kelmar Done by choice VIP Member

    Joined:
    Nov 28, 2009
    Messages:
    11,815
    Likes Received:
    4,750
    I'm rooted so I just flashed an old radio and all is good again. With the updated radio included with the 2.1Release, my phone went w/o signal 57% of the time (and the rest was hit and miss). On the old 1.5 radio I'm w/o signal only about 20% of the time.

    ***All tests and numbers done at work***
     
  7. Ricket

    Ricket Member

    Joined:
    Jun 22, 2010
    Messages:
    5
    Likes Received:
    2
    Do you mind if I bump this? I'm having the same problem.

    I've been wondering why my up time = awake time; I just discovered Spare Parts and it indeed says that the partial wake time has been spent on Calendar.

    [​IMG]

    Please tell me this is a solved issue.... I really like my Calendar, I use the widget on one of my home screens to check it frequently but not THAT frequently!! (like, I've seen it only once today, so it's not because I'm constantly checking it - and I didn't even open the actual app at all, it's just sitting as a widget on my home screen)
     
  8. scottmbolt

    scottmbolt Well-Known Member This Topic's Starter

    Joined:
    Feb 13, 2010
    Messages:
    624
    Likes Received:
    47
    Have you tried a reboot?
     
  9. Joehunni

    Joehunni Well-Known Member

    Joined:
    May 27, 2010
    Messages:
    1,001
    Likes Received:
    77
    I used to have the same problem with "calendar", then I unchecked the sync calendar option under Google account seeing as I don't use it, that fixed it for me.

    Sent from my HERO200 using Tapatalk
     
    Simba501 likes this.
  10. Ricket

    Ricket Member

    Joined:
    Jun 22, 2010
    Messages:
    5
    Likes Received:
    2
    But see, the problem with that is that I really do want to use my calendar. I'm a student, I keep my Google Calendar up to date with my busy schedule, and I need to check it often. So it is actually handy, but not when it's running my battery down all the time...

    Any other solutions? And yes I have rebooted.

    For now, since it's summer time, I'm choosing battery over calendar and I've killed all sync, reminder, and cleared data from HTC calendar, Android calendar, and Calendar widget (also HTC I think).

    If there's no other solution then I guess I'll just hope a new version comes out (or the phone is rooted) by the end of the summer.
     
  11. cjberg

    cjberg New Member

    Joined:
    Oct 15, 2009
    Messages:
    4
    Likes Received:
    4
    I was having the same problem. I rebooted the phone, went in to the manage applications list and hit clear cache and clear data in the calendar app. Then I went to accounts & sync and re-synced the calendar and it has been working fine ever since. I also use spare parts to monitor the battery useage and awake time, so I can see if it ever pops up again. Been about a week now and the calendar is not keeping my phone awake any longer.
     
    Simba501 likes this.
  12. Ricket

    Ricket Member

    Joined:
    Jun 22, 2010
    Messages:
    5
    Likes Received:
    2
    After a couple days I have found the solution, which is basically what everyone has been saying but I just didn't test enough: kill calendar.

    It seems that if you just kill Calendar once when you first start your phone (by going into settings > applications > manage > Calendar > force stop), it behaves fine from then on, even if you start it again. I've been testing this for the past few days now, starting calendar, doing random things, using it like normal (with the widget as well), and my phone has been correctly sleeping now as long as I just kill it after powering on my phone, every time I power on my phone.

    So, I'm happy for now. I do hope they will update and fix this bug (and the other little bugs in the stock apps - Peep doesn't correctly handle mentions, the date in Calendar is wrong when you try to set it for an all-day event, etc.) but at least my phone is sleeping and my battery is now lasting quite a bit longer -- though not quite two days, so I will continue to charge it every single night...

    Thanks for the help and suggestions!

    By the way: rather than installing Spare Parts from the market, to see what has been keeping your phone awake just dial the code *#*#4636#*#* and you'll be put into a secret menu, then hit battery history and change the top dropdown to partial wake usage.
     
    jnativ likes this.
  13. Wiskid

    Wiskid Well-Known Member

    Joined:
    Dec 31, 2009
    Messages:
    189
    Likes Received:
    5
    I'm not sure if your still having this problem or not... but are you using the stock Calendar Widget? Or some third party widget?
     
  14. Ricket

    Ricket Member

    Joined:
    Jun 22, 2010
    Messages:
    5
    Likes Received:
    2
    Just a quick update which should put to rest this thread, once and for all!

    First of all, it turns out my previous solution of killing Calendar was not perfect. I've been doing this for the last few days (since I posted it) and occasionally Calendar will sneak another wake lock, an hour or two after you kill it; if you don't notice, it can drain battery. Even more concerning is that if you DO notice, but you go to kill it, the force stop button often is grayed out, as if it's not really running.

    However there is a perfect solution!!

    Credit goes to rweckhoff over at incredibleforum.com for his post with the solution:

    Indeed, I had my Flickr account linked to my phone, though I never use it so I had no worries about deleting the account. After going to Settings > Account & Sync > Flickr and hitting the Remove account button, and then restarting my phone and using it for a little bit (including starting Calendar, using my Calendar widget, etc.), Calendar isn't even on the list of things that held a partial wake lock.

    I haven't tried this solution for very long yet so I'll post back if I have any problems, but it looks like it works perfectly.
     
    sleepyEDB likes this.
  15. sleepyEDB

    sleepyEDB Well-Known Member

    Joined:
    Oct 8, 2009
    Messages:
    67
    Likes Received:
    0
    Thanks for the tip. I've removed my Flickr account and it seems to have made a difference. I'll post back if the Calendar returns to the top of the partial wake list in Spare Parts.


    sleepy
     

Share This Page

Loading...