Wi-Fi + 3g = fightSupport


Last Updated:

  1. ZNA03

    ZNA03 Well-Known Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    85
    Likes Received:
    3
    This wasn't an issue until the update came out a week or two ago but now, when I have mobile network on, and wi-fi on and have both available it chooses 3g over wi-fi. Shouldn't it choose the faster wi-fi signal when it's available? Is there a setting i'm missing? I'm using the power control widget on my home screen to switch between the two.


    Also with mobile network off and wi-fi on, it sometimes still uses 3g. Doesn't make sense to me, I must be missing something either really basic or something I just don't understand.

    Thanks in advance.
     

    Advertisement
  2. Abie6972

    Abie6972 New Member

    Joined:
    Sep 20, 2009
    Messages:
    2
    Likes Received:
    0
    My issue is about the same. If I turn WiFi that will be used as my data connection until I let it sleep for a bit then it just uses 3G instead of reverting back to WiFi. I didn't have this issue before the most recent update.
     
  3. ZNA03

    ZNA03 Well-Known Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    85
    Likes Received:
    3

    Yep, that's about what mines doing. Must not be widespread...

    Abie, do you connect to multiple wireless networks through the day? I hit about 3-4 a day.
     
  4. talz13

    talz13 Well-Known Member

    Joined:
    Mar 23, 2010
    Messages:
    111
    Likes Received:
    1
    I have noticed something similar, too. When I turn the phone on after letting it sit for a while, I will see the 3g icon with arrows blinking (indicating data transfer over 3g), and then 1-3 seconds later the wifi icon will appear and take over. Does this mean that it's using 3g when sleeping instead of wifi?
     
  5. THEFORCE

    THEFORCE Well-Known Member

    Joined:
    Mar 17, 2010
    Messages:
    608
    Likes Received:
    198
    Try this...settings, wireless and networks, wifi settings, turn wifi on, press menu, go to wifi sleep policy and change it to never.
     
  6. br0ck

    br0ck New Member

    Joined:
    Jun 4, 2010
    Messages:
    3
    Likes Received:
    0
    I have two Evo's set as you've recommended, but still have the same exact problem as the rest of people in this thread.
     
  7. ZNA03

    ZNA03 Well-Known Member This Topic's Starter

    Joined:
    Jun 4, 2010
    Messages:
    85
    Likes Received:
    3

    Hey thanks for the response, unfortunatly my evo was already setup like this.
     
  8. Berner

    Berner Well-Known Member

    Joined:
    Mar 23, 2010
    Messages:
    316
    Likes Received:
    112
    Known issue. No known fix to keep wifi 100% alive 100% of the time.
     
  9. Neon8

    Neon8 Well-Known Member

    Joined:
    May 9, 2010
    Messages:
    53
    Likes Received:
    8
    Before the update wifi would stay connected and switch from home to work and back with no problem. Now have to manually keep turning on. Widget says wifi on but not connected. Have to turn off and back on to connect. Big ding on battery life as poor 3g signal at home - 1-2 bars. Wifi sleep is never but obviously not working. Hopefully fix for this soon. Something in update broke wifi.
     
  10. Cru

    Cru Well-Known Member

    Joined:
    Jun 8, 2010
    Messages:
    73
    Likes Received:
    11
    Had the same problem and tried everything under the sun. The only thing that fixed it for me was rooting the phone. I used Unrevoked 3 method and didn't change anything else. I haven't loaded custom roms or anything and now my wifi works as it should again and my phones battery life has increased dramatically. I found this to be very strange. Just thought I'd share my experience.
     
  11. spridell

    spridell Well-Known Member

    Joined:
    Apr 15, 2010
    Messages:
    333
    Likes Received:
    166
    Same problem with my phone.

    Keeps disconnecting me from my wifi and i have to manually put it back on.
     

Share This Page

Loading...