1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!

Support Wi-Fi issue


  1. Jay73108

    Jay73108 Member

    Hi,
    I just got the S4 yesterday, and I have been having problems with my wi-fi connection. It indicates that I have a strong connection, yet it takes for ever to download, it actually is faster to turn off the wi-fi. Even google play takes a long time to load (with wi-fi) turned on. One thing I noticed is that even though I am connected to a wi-fi, the phone is constantly scanning for a wi-fi network every 5 seconds (I see this in the Wi-Fi settings), and think this may be causing my problem. Is there a way to turn it off. Are others seeing any issues with the wi-fi?
    Thanks

    Advertisement
  2. Ambival

    Ambival New Member

    I also got one last week and am seeing similar problems. My hub works very will with every other device, but the S4 continuously disconnects from it, even with a strong signal. It will even stop receiving data in the middle of a stream while the wi-fi incoming arrow still flashing.

    I brought it to work and it stayed attached to wi-fi for what seemed like an extended period, but I'll need to keep testing to be sure it's a compatibility problem between the S4 and the hub.

    I tried some of the tricks recommended for S3 wi-fi issues (disabling low-power mode, turning off auto-connect to AT&T, removing the battery), but nothing is fixing this issue.

    One would think the standards are fairly, well, standard. The S4 seems to have an issue where other devices don't. The S3 seemed to have some as well...
  3. rkkeller

    rkkeller Well-Known Member

    Mine is fine on wifi, been using 3 different routers. 2 on Comcast and one Fios. A linksys, netgear and the default Fios one.
  4. SMALBA

    SMALBA Well-Known Member

    Guys i had the same problem with both the one and the s4. The only solution I got to work was buying a completely new router. For reasons unknown to me, my s4 didn't like the old router. So I bought a new netgear $100 router with both 2.5 ghz band and 5 ghz band . I connect to the router using the 5 g band and have not had any issues at all.

    I know this is an expensive solution but it worked for me. Good luck guys.
  5. Pappy35

    Pappy35 Well-Known Member

    No WiFi issues for me either. Solid.
  6. Srwilliams777

    Srwilliams777 Member

    My phone stays connected to my network and works well but its always scanning for new networks. don't know if that normal or not.
  7. Ambival

    Ambival New Member

    Thanks for the affirmation. I've found several other places around where the S4 had some compat issues with certain routers. As I said, it works fine for me at the office, but at home, it repeatedly hangs and re-acquires a lease every once in a while.

    I understand that other people have not had this issue, the point was to discover which routers they might have trouble with. This one is an older 802.11n/g/b D-Link RangeMax from several years ago.

    I've also read online that the S4 supports the newer AC standard as well. I might get a new router that supports it...
  8. trparky

    trparky Well-Known Member

    No issues with my Linksys E3200 running TomatoUSB.
  9. paully

    paully Well-Known Member

    fwiw...

    I just had a similar thread here.

    wife's gs4 was stuck in 'obtaining ip' mode.

    updating the router's firmware did the trick. more info in the thread if you'd like.
  10. XplosiV

    XplosiV Master X is Watching You VIP Member

    Is this issue symptomatic of the device sleeping? The S3 has an optipn in the settings to sleep the wifi connection if the screen times out.

    You could try toggling airplane mode on then off. That used to sort some APN issues on 3/4G

    You might also want to check the channel your routers broadcasting on, as it may be a cluttered channel. Also check that your not using WPA encryption, but WPA2 & PSK for better compatability and speed.
  11. Ruff4ge

    Ruff4ge New Member

    I had this exact same issue and resolved it. :)

    I've a Netgear router downstairs and a Linksys router upstairs, and the S4 was struggling with keeping a connection with both. As this was a new device I though the issue might be hardware related, as it was showing a wifi connection but pages weren't loading, Facebook had no pics etc. Then I was in McDonalds and trying to jump on the "very strong" wifi and it was losing a connection before I could login to the wifi page.

    Aaanyway, it's all down to allowing the wifi to switch off when the device is in sleep mode, to save power. I found a thread from last year where this issue plagued the S3, and the fix worked a treat for my S4:

    http://androidforums.com/samsung-galaxy-s3/566171-wifi-issues-disconnects-etc-fixed-me.html

    It's been fine ever since, and no reduction in battery. Strange thing is I've just gone back into that service menu and power save is set to "On" again, yet if I go via the GUI and advanced wifi settings, swifi during sleep is set to Never. No matter, wifi's working like a dream now. o/
  12. Poweranimals

    Poweranimals Well-Known Member

    Don't you have to actually set up a wi-fi connection though before it tries to connect to it. It shouldn't do so without your consent. Unless this is a new feature.
  13. Jay73108

    Jay73108 Member

    I am using a dlink DIR655, its a few years old. Hardware version A2, and firmware 1.33NA. I have done a speed test, and have done the channel test using wifi analyzer and don't see any problems. I may have to get a new router as SMALBA suggests
  14. Ambival

    Ambival New Member

    That's a coincidence. I'm using a D-LINK 655 (Rev A4, vers 1.34NA). Again, I've only seen this problem with this specific router.

    I also had gone through all of the tests of turning off low-power mode, auto-scan, auto-connect to AT&T, etc. but can still have it lock up in the middle of loading a page.

    This weekend I can hopefully try it on a few more networks (also a good chance to hit a McDonald's with impunity).
  15. Ambival

    Ambival New Member

    As a bit more info, I am seeing packets back to the phone getting blocked/ignore by the router. I created a connection to Google's streaming server on 443 and was able to stream almost exactly 60 seconds of a movie.

    This has been a consistent issue (connections seem to go dead after 60 seconds).

    The hub seemed to forget about this connection. After searching around for some similar stories, I found this:

    (from a site I can't link to)

    Here's what's happening:
    TCP 3 packet handshake takes place
    Client issues a data request
    Client issues a FIN/ACK since its done transmitting info
    Netfilter drops the state time out to 60 seconds
    Server starts transmitting data back to the client
    More than 60 seconds goes by
    Netfilter removes the state entry
    Server can never complete the data transfer and continually tries to
    issue a FIN/ACK to close the connection
    Netfilter drops all FIN/ACK's because the state table entry is gone


    The work is ongoing...
  16. reilus

    reilus Well-Known Member

    I have two S4s. One works fine on wifi; the other does not. It connects for a time and then it keeps uploading (green arrow lights up) but does not download (orange arrow does not light up) and nothing happens. All downloads stop, all syncs stop, and I get a "cannot connect to server" message in certain applications. Is there any way to fix this or do I need to swap out the handset? =(

    ------edit-------------
    I've tried the following:

    Rebooting the phone several times
    Restarting the router
    Changing from DHCP to Static IP
    Turning off the new open network notification
    Clearing data from Google Play store
    Disabled wifi power save with *#0011#

    The wifi will work for a short while and then it won't work. It was working fine before. What should I do?
  17. EarlyMon

    EarlyMon The PearlyMon Moderator

    It's possible that your router has some hosed addressing tables - if it has a reset button, not a bad idea to try that.

    I've seen issues like this where one handset is singled out a network - doesn't matter make or model, or even Android or iDevice.

    Also, a good idea (on your working phone) to download and try Wifi Analyzer, it's free. If you're sharing a channel with a neighbor, it will show that and you can correct that at your router, the problem could be radio collisions.

    And for best results, never use the default router name. I've been in neighborhoods where I've seen 5 different routers from 5 different homes all sharing the same channel and network name. Those people are all getting lousy network service without knowing why.

    If it's not that, then it's your phone.
    IOWA and Rxpert83 like this.
  18. serge183

    serge183 New Member

    Ok I just got the Galaxy s4 and I connect to my WI FI it stays connected for about 2-4min then disconnects and it also keeps scanning for connections if I turn wi-fi off and on i'll get about another 2-4min b4 it quits again i'm still connected to router and strong signal but phone wont do anything as far as data
  19. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Hello and welcome, serge.

    Does your S4 behave the same way no matter which wifi network you're using? If you have not tested that yet, it might be a good idea to do that because if it's just one router with the issue, well, that might be the issue: the router. ;)

    It could be a setting in the router or it could be firmware needing to be updating. Routers have a provision for updating the firmware somewhere in their settings area.

    Some find success by resetting the router, often via a tiny pinhole which you insert a pin or other small thin object. Some have a reset button, and some are reset by merely unplugging them from the power source (along with the router/data cables) and waiting a full minute, then plugging back in.

    But again, first tell us if the phone is ok on other networks or not. If it shows that behavior across more than one wifi network, we may have some configuration to do or a factory data reset.
  20. serge183

    serge183 New Member

    I haven't tested it on another yet I'll try and find a spot to do so thanks :)
  21. bridge

    bridge Member

    Just got my wife the S4, same Wifi issues and I've got a DIR655 with the most current firmeware as well. I'm not buying a new router. AT&T can buy me one if they want, but I ain't doin' it.
  22. EarlyMon

    EarlyMon The PearlyMon Moderator

    Similar threads merged.
    Frisco likes this.
  23. speedlever

    speedlever Well-Known Member

    Linksys WRT54g running Tomato... no issues with wifi on the GS4.
  24. Eric618

    Eric618 Well-Known Member

    From what I read, it's an issue where our GS4s don't play nice with our Dlink routers. I have a DIR-655, and had issues. It's fixable. I tweaked the router to utilize 802.11G *only*. I use WPA2 security. I also disabled WiFi power save mode on the phone. All better now. :)
  25. bridge

    bridge Member

    I changed mine to N only and it seems OK now. The S4 seems to disagree with the mixed mode on the 655.

Share This Page