Wi-Fi issueSupport


  1. charliehowes

    charliehowes Well-Known Member

    How do I disable wifi power save mode?
    I'm assuming that's why my wifi appears to disconnect when the phone is idle?
  2. Eric618

    Eric618 Well-Known Member


    1. Go to your (stock) phone dialer
    2. Dial *#0011#
    3. Select "WiFi"
    4. Turn off "Wifi Power Save Mode".
    5. Exit this menu, turn off your Wifi and turn it back on. If you already entered all your wifi credentials, forget your network info (remove it) and re-enter it again.
    charliehowes likes this.
  3. Eric618

    Eric618 Well-Known Member

    I still had issues with N. Using G only seems to work perfectly.
  4. DekonR

    DekonR Member

    Edit:
    Nevermind, found it.
  5. paul1222

    paul1222 New Member

    May i ask sir. My samsung s4 cant connect to my wifi router. But my other gadget connect easily.. it says AUTHENTICATING THEN SAVEF, SECURED? PLz help me to solve my problem. Tnx
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    welcome to AF!!!!!!

    i moved you to the s4 forum where folks who have your phone can help you out better.
  7. paul1222

    paul1222 New Member

    Tnx plz help. Tnx
    ocnbrze likes this.
  8. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    how old is your router? what setting do you have on your s4 as far as wifi is concerned? have you tried to reboot the router? sometimes that works for me......but i do not have your phone.
  9. samsungs4

    samsungs4 New Member

    The Problem:
    My S4 can't connect to the internet

    What is happening when I try to connect:
    1.
    Obtaining IP Address....(It will literally stay like that for about 5 minutes or more)
    2.
    Can't connect to the network because the internet is slow. (What the actual ****?? I'm sitting on my room with the router in front of me! How can I have a slow internet? I can download a 1gb movie in less than 5 hours for god's sake!)
    3.
    Failed to obtain IP Address....(there slowly goes the trust i have for android products.


    Things i tried to do and failed miserably....
    1. Restart the router (I did this for like 20x already ad still nothing!)
    2. Restart my phone (same thing happened
    3. Factory data reset (did this 2x already and still the same)
    4. Proxy Settings: Manual, IP Settings: Statics (no freaking effect!)
    5. Tried to disconnect all the other devices that is connected to the wifi and only let my phone use it...(it didn't work either!!

    PS.
    1.Other gadgets and laptop at my house COULD CONNECT to the wifi EXCEPT my S4
    2. My S4 COULD CONNECT to other wifi (malls, starbucks, my cousin's wifi) EXCEPT the one at my home.
  10. The_Chief

    The_Chief Accept no imitations! Moderator

    Hi S4 and welcome to Android Forums!

    Wow, wifi problems. Not good. I am taking the liberty of moving your post to the S4 forum. There other S4 users can get eyes on the issue and hopefully resolve your issue quickly. Always feel free to ask any questions you may have.

    It's great to have you here :)
    ocnbrze likes this.
  11. aylaeron

    aylaeron Member

    My internet is through Comcast/Xfinity, and after troubleshooting with 3 different techs, the third one told me that Comcast is working on an update that will fix the issue with the WiFi. He said something about it not being fully compatible with this phone. Hopefully soon because I can't afford to keep using 4G.
    ocnbrze likes this.
  12. Slug

    Slug Check six! Moderator

    If that's the case then the problem is most likely to be with your home wifi and not the handset.

    Check that your wifi router is running the most recent firmware, and also that it's using AES rather than TKIP encryption as I've had problems with several different Android devices connecting to APs using the latter.
  13. speedlever

    speedlever Well-Known Member

    I run a Linksys WRT54g with Tomato firmware. Early on, I had a brief time where my GS4 also showed saved, secured but wouldn't connect. I believe this was the morning after I got the GS4 and had already established a wifi connection the night before. I piddled with it for a few minutes... and honestly don't recall what I did, but it finally connected and I've had no trouble since.

    Sorry, I know that's no help. But I did think that an odd problem but since it only occurred once and has been rock solid since, I haven't thought much about it.

    I'm curious what you find when you get the issue resolved.

    FWIW, I set a static IP from within the router firmware. But it also connects just fine via DHCP in other wifi environments.
  14. peacesong

    peacesong New Member

    Hi,

    Got the Galaxy S4 with ATT service.

    It connects and stays connected to
    *) unsecured wifi
    *) WEP enabled security

    Tried every combination of WPA, WPA2, or WPA mixed mode using TKIP or AES and none of them work.

    The phone gets stuck in a cycle of "Obtaining IP Address", "Saved, Secured"...
    Sometimes it reads "Authenticating", "Saved, Secured"...
    while Scanning/Connecting... it never connects.

    Tried the other post suggestions of turning off the wifi power save mode (*#0011#), DHCP and static...

    Note - if the password is entered incorrectly, there's an immediate failure and prompt to enter a new password.

    Since it works fine with no security and WEP, i'd guess this is a software issue?

    Any suggestions? Hard to believe this product could actually ship without being able to connect to the most common wifi.

    Thank you for your help!

    Peace
  15. NullReference

    NullReference New Member

    Throwing my hat into the ring here, my first post so I hope I'm doing this right...

    My Samsung S4 is also having wifi issues. It often will show a strong wifi connection but will have no data transfer (web pages won't load, etc...). Disconnecting from wifi and reconnecting always fixes the problem for a short period of time (from a few minutes to several hours).

    There are 2 wireless routers in the house, one is a DLink DIR-655 and the other is one provided by my ISP (Bell; sorry, not sure of the model or if it matters). We also have 2 S4 phones in the house, so I'm able to troubleshoot a bit more than others. The DIR-655 is troublesome for BOTH S4 devices; they stay connected for a few minutes (or longer in some cases) but will always end up not transferring data even though they show as having a very strong signal. I read that there are compatibility issues with DIR-655 routers and the S4 devices, so I switched both S4's over to using the Bell router. Now only one of the devices (mine!) has the wifi issue described above; after being connected for a while, it just stops transferring data (switching the router to 802.11n ONLY reduced the frequency of this happening). The same thing happens to my S4 when I'm on wifi at work.

    Both S4's have the most up-to-date firmware as do all of the routers in the house. No other devices (iPhones, laptops, apple tv, etc...) have any issues with the wifi.

    I've tried resetting the routers, forgetting the wifi connection and setting it back up, rebooting the phone, smashing my head against the wall; nothing seems to have worked permanently.

    Is it possible that this is a hardware issue and not a software issue? Does anyone know if Samsung is aware of this issue?
  16. The_Chief

    The_Chief Accept no imitations! Moderator

    Hi and welcome to Android Forums!

    I have taken the liberty of moving your post to the Galaxy S4 forum so experienced eyes can get on the problem and resolve it quickly. Feel free to ask any questions you may have.

    It's great to have you here :)
    ocnbrze likes this.
  17. SpenceJT

    SpenceJT Member

    Just throwing this out there for someone to try (I won't have an S4 until a 64gb one is released ...which means perhaps never).

    While I upgraded away from the DIR-655 long ago, I have had similar issues with my GNex on my Asus 66AC router, and found that once I disabled IPv6 related protocol settings on my router, the problems went away. It may be something to check on the DIR-655.

    Hope it helps.

    Regards,
    Spence
    ocnbrze likes this.
  18. soooperpotato

    soooperpotato Member

    I was wondering if anyone else had this issue:

    Just got a new S4 and it works fine except for WiFi. I noticed a limit of a 4Mbps download speed (upload is fine) when using WPA2-PSK (AES) or (TKIP/AES) security modes on my router. All other 802.11n phones and computers in the house are hitting around 30+ Mbps download on this setting.

    However, when I set the security mode to the older WPA2-PSK(TKIP), I get speeds at about 20 Mbps dowload on my S4. This is an improvement, but now using TKIP I've limited all other devices in my house to 802.11g speeds instead of the faster 802.11n speed that AES uses.

    Does anyone else using WPA2-PSK (AES or TKIP/AES) security on there router have this issue? I've tried messing with every networking setting on the S4 and on my router to get this to work properly. Thanks :)
  19. Poweranimals

    Poweranimals Well-Known Member

    It sounds like a glitch with your phone.
  20. soooperpotato

    soooperpotato Member

    I might try to swap out the phone for a new one today. I don't want to have to wait for patches or updates for this problem right now.
  21. soooperpotato

    soooperpotato Member

    Update: I replaced the phone for a totally new one and still the same issue :( Oh well. I'll just have to stick with TKIP security and the slower speeds for now until hopefully its fixed in an update for the S4.
  22. sincarafan

    sincarafan Well-Known Member

    Im having no issues on mine.
    sd_Ngalaxy likes this.
  23. Canesfan

    Canesfan Well-Known Member

    Two weeks with a new S 4 coming from an iPhone 4.

    I notice when I get to a new location with WiFi on, I get the notification a WiFi is available, then it says "WiFi connected" even though I know I'm not. I want to use my data but this limbo between being on and not holds me up. Eventually (like after 5+ minutes) I get the sign-in screen. In wanting to use the web sooner I've even tried turning it off and using LTE but it still acts like it's on and attempts to get me on WiFi. Similarly some places have more than one WiFi to sign on to but when trying the preferred one it goes to the other. Then when trying to discard or delete one of them it still tries and will disable the preferred choice. When I try the opposite it does it vice versa.

    This is sooo frustrating cause it gives me the false sense I'm on WiFi, yet I'm not and in this "no-mans land" where I can't do anything, and it seems to have a mind of its own and takes its time getting on WiFi.

    Anyone else have this problem and any solutions?

    Other problem: how can I stop my emails from trying to connect when I thought I did so in settings?
  24. soooperpotato

    soooperpotato Member

    I exchanged the phone for a new one and still the same issue.

    Maybe its a compatibility issue with my router/gateway and the S4 because its works fine on an S3. I'd have to try it on a different router perhaps to see if its a problem there too.
  25. sd_Ngalaxy

    sd_Ngalaxy New Member

Loading...

Share This Page