Wi-Fi issueSupport


Last Updated:

  1. smortguy

    smortguy New Member

    I have 2 of the same kind of routers, one at work and other at home. One of them doesn't allow the S4 to obtain IP address whereas the other one has no issues. The tricky part is that all the 4 S4(s) have the same issue. I swapped the routers and they still don't work with bad one. I have also contacted Trendnet support and they are trying to show me all kids stuff. I'm software programmer and hardware literate.
    The S4(s) work at so many other routers and hotspots without any issues, only this particular router. It's brother works without a glitch.
    Any insight would be helpful.

    Advertisement
  2. zomgitbeandy

    zomgitbeandy New Member

    My Samsung can pick up my wifi and it'll work for about 2 minutes and then it'll stop downloading data from my wifi until I turn off my Wifi in the settings and turn it back on again. My old iPhone could pick up the Wifi easily but it's only the S4.

    I tried resetting the phone and the modem but doesn't seem to work very well. . Anyone got a solution?
  3. rkkeller

    rkkeller Well-Known Member

    No problems at all here using 4 different routers daily and going back and forth between them at times. Didn't fool with any settings on the S4 or routers, it just works.
  4. zomgitbeandy

    zomgitbeandy New Member

    I also found out it works everywhere else but my house, so can anyone tell me the modem settings?
  5. EarlyMon

    EarlyMon The PearlyMon Moderator

    Welcome to the forums! :)

    I've merged your question in with the thread where others are discussing the issue, maybe info here can help or someone can share their router info.

    FWIW, please say what router/modem you have, cheers, thanks!
    ocnbrze likes this.
  6. Canesfan

    Canesfan Well-Known Member

    Just to clarify. My Samsung GS4 works about flawlessly on my home Motorola DOCSIS 3.0 combination cable/router.

    My WiFi connection issues occur at multiple facilities where I work. AT&T Tech. Support suggested I set the sleep mode from constant WiFi to never, then toggle back on. Needless to say, it didn't help.
  7. soooperpotato

    soooperpotato Member

    My S4 doesn't play nice with my Technicolor gateway from Xfinity. Have to use slow TKIP security just to get any speed over 4 Mbps down.
  8. OneSickS4

    OneSickS4 Member

    I'm still having trouble with my D-Link DGL-4500....i wrote D-Link and Samsung about this. Hopefully one of them addresses it!!
  9. seagull

    seagull Member

    I have had these issues with s3 and htc desire and htc hero. Although not tried this aes fix . I wonder if htc one peeps have the same problem?
  10. Canesfan

    Canesfan Well-Known Member

    Problem seems improved after downloading and utilizing the free app., "WiFi Fixer".


    My phone, even when sleeping, would keep trying and failing to connect with each mailbox. This problem was solved using the Yahoo Mail App. to handle my Yahoo mailboxes.
  11. speedlever

    speedlever Well-Known Member

    Had this problem again today, including my wired internet was down too. My GS4 could see the network, but it had some sort of error and couldn't connect. I would just see saved/secured or somesuch linked to the SSID.

    I had to repower the modem and the router and then everything came back normally.

    Stray electrons and such. :rolleyes:
  12. wdy2047

    wdy2047 New Member

    ----------------------------
    I met the same problem, normal or not?
  13. Shocky

    Shocky On Probation

    No issues with WRT610N
  14. Canesfan

    Canesfan Well-Known Member

    Unfortunately, as of today, the WiFi problems have continued. I keep getting the WiFi icon that I'm on WiFi, as well as notifications I'm on WiFi when I am NOT. Even if I turn off WiFi and rely on 4G, WiFi comes on itself like it's some sort of a zombie with a mind of its own. It keeps unsuccessfully but SLOWLY trying to get on WiFi.

    This phone and/or the provider (AT&T) have some real problems with WiFi. Local Verizon dealer told me it has addressed these WiFi issues, a reason for its delayed launch, but this is NOT SO.
  15. wallstreet123456

    wallstreet123456 Well-Known Member

    The issue I have when I am connected to wifi is it shows 4g in the upper screen also, to me it seems like both 4g and wifi are connected, can others let me know if you see both wifi and 4g on when you are connected to wifi?
  16. Canesfan

    Canesfan Well-Known Member


    When you are truly connected to WiFi, the 4G icon is replaced by the WiFi icon with 2 small blinking arrows beneath it. With what I call "false WiFi", I've had the icon with non-blinking arrows, then minutes later after getting "connected" notifications, I'll get the WiFi sign-in screen or notification. This is absolutely maddening and dysfunctional. If I didn't have the unlimited data plan, I would be worried about my data usage.
  17. jms493

    jms493 Active Member

    I have a Galaxy Note 2 and our home network WIFI works perfect. I leave 4G and WIFI on all the time and it switched automatically with no problems and stays connected to WIFI.

    My wife's S4 just wont stay connected to WIFI. I can get to connect but it is very intermittent and unreliable. It just randomly disconnects when it wants.

    Anyone else having WIFI connectivity issues? Is there a setting I dont know of?

    FYI - Both are Verizon phones
  18. epphllps

    epphllps Active Member

    I'm having an issue with wifi as well. I tether my gs4 to my verizon unlimited hotspot for use at home and the data terribly slow. Subpar 3G speeds when I download apps from the App Store. I've seen something about going into the wifi menu with *#0011# but that does nothing on my verizon gs4. Any help from fellow verizon users?

    To answer you, Samsung has acknowledged wifi issues with D-Link routers and their firmware.
    jms493 likes this.
  19. jms493

    jms493 Active Member

    I am using an Apple Airport Extreme router with a Net Gear Extender and Apple Repeater.

    What is weird is the the Note 2 works perfectly fine...the phones seems so similar.
  20. jms493

    jms493 Active Member

    I have a verizon s4 and when I enter these numbers in the dialer nothing happens. IT is a stock s4. why?
  21. jms493

    jms493 Active Member

    I want to try this method but I cant get into the service mode.

  22. Jay73108

    Jay73108 Member


    Finally I invested in a new router (asus N66U), and I no longer have any wi-fi problems. I am only using wireless N.
  23. Canesfan

    Canesfan Well-Known Member

    Again.....I have no issues at all with my S4 functioning on WiFi with my home router.

    Unfortunately, to me the main issue with this phone's WiFi is connecting when away from home where I use 95%+ of my phone's data. It then fails miserably to work effectively with WiFi.
  24. richmondva

    richmondva Member

    I have been told that this issue is with many models of d-link and a few other brand routers.. to date the only work around is turning Wi-Fi off with these routers or purchasing a new one. I am told both D-link and Samsung are aware of the issue.
  25. speedlever

    speedlever Well-Known Member

    I have an old DI624 DLink router on the other side of the house that's wired into my Linksys in the office. I can connect at will to either wifi source in seconds.

Share This Page