Wi-fi no-broadcase SSID

Last Updated:

  1. mcrider

    mcrider New Member

    I have a D-Link WAP set up for G/N and also set so that it does not broadcase my SSID.

    My new Hero is able to connect at work to our WAP (WEP security), but at home it can't find my WAP (WPA security). If I change my setting so that it now broadcasts my SSID it can connect, but what the heck? Why can't it connect if I've input the SSID and WPA code, but the SSID isn't broadcasting?

    Thanks for any suggestions.

  2. JoeC

    JoeC Well-Known Member

    I have my wireless router so that it doesn't broadcast the SSID, also. I have noticed a bug on my HTC Hero that requires me to go into the wireless settings, and force scan twice for it to detect the prior WLAN setting and connect. I don't use a WEP key for mine, I use MAC address security instead.

    I suggest that you initially broadcast your SSID in order for the Hero to "remember" the configuration.

    After that, go ahead and disable the SSID broadcast and try force scanning (twice) the WiFi in settings to see if the Hero obtains the IP address.

    My apologies if you've already tried this.
  3. showson1

    showson1 Member

    I have the same issue and I have already tried Joe's advice.

    If I'm not broadcasting my SSID the Hero doesn't even see the phone.
    If it's broadcasted I can connect no problem, with WAP, but as soon as I hide it that's it.. no connecting.

    Oh and Joe, I'm another San Diego Android fan. ;)
  4. Slug

    Slug Check six! Moderator

    Confirmed in the Euro versions too. Look on the bright side - it may stop some misguided souls using a hidden SSID as their sole means of security.
  5. ticho

    ticho Well-Known Member

    A bit off-topic, but I hope you do realize that with setup like this, anyone can connect. And even if they don't, they can still watch all of your traffic.
  6. Slug

    Slug Check six! Moderator

    Only if they spoof one of the trusted MAC addresses, which means knowing it in the first place.

    A problem with wireless networks in general. Even encrypted traffic is still visible to any NICs running in 'promiscuous mode', and given enough time and processor cycles, can be analysed and 'cracked'.
  7. daveybaby

    daveybaby Well-Known Member


    Which is trivially easy to find out, since any device that wants to talk to your router has to transmit its MAC address, and you havent bothered to encrypt it.

    But they still have to go to all of the time to crack your key (and, if youre doing it right by using a strong key it's still a VERY long time).

    An analogy for you. Cos i like crap analogies.

    Disabling SSID broadcast is like trying to secure your house by taking the house number off of the door, but leaving the actual door open when you go out.

    Limiting by MAC address is like trying to secure your house by having a security guard at the wide open door, but that security guard will let anyone enter and leave as long as they wear a name badge with your name written on it. But how do they find out your name? By looking at your name badge as you leave the house one day.

    Encrypting traffic is like closing and locking the door. It's not foolproof (nothing is), but a burglar has to be pretty determined to get in. WEP can be cracked pretty quicly these days but if you use WPA-2 that's like having a steel door and bars on the all of the windows. A burglar with a hacksaw and a drill will still get in after a lot of time and hard work but theyre not going to bother unless they know youre keeping huge amounts of cash on the premises.
  8. Slug

    Slug Check six! Moderator

  9. wormser

    wormser Active Member

    If I was in range I could get your MAC address in less than a minute. Daveybaby is right and you should use WPA-2. Use it with MAC filtering and a hidden SSID. The more hurdles you give them the less likely they will try to crack it. They will go for the low hanging fruit instead.

    Ok, back to the topic of not being able to connect to a hidden SSID. I have the same issue with a CLIQ. I can connect when the SSID is visible, but when its hidden I cannot. Scanning it multiple times doesn't help.

    This seems to be a bug. Where do you report bugs? Has anybody found another app or a work around?
  10. frederikk

    frederikk Member

    Hi, i have the same problem, but it seems to disappear after i installed wifinder : a free wifi finder application... got to test it on several "hidden" SSID networks..but it would be great. And even if i use the classical wifi widget of the hero..not even the wifinder application (but it seems to be a good application ).

    Edit : in fact it does not work with the stock wifi application...you have to launch wifinder in order to connect to the network...

  11. wormser

    wormser Active Member

    Wifinder didn't work for me. I had to enable the SSID broadcast to connect with wifinder. When I disabled the SSID broadcast it still wouldn't connect. It doesn't see the AP. I even rebooted.
  12. JoeC

    JoeC Well-Known Member

    First of all, I understand about the SSID and MAC address security. For me, it's secure enough. Why? Anything I use standard port 80 traffic with is of little concern to me, as it would mainly be streaming music, webcam video or general web browsing. If someone really wants to sniff the air to acquire the MAC and spoof it only to catch flying packets of one user's uninteresting session traffic, then he can be my guest.

    Anything that I need to provide passwords to, such as banking via web, credit-card transactions, etc., would all be encrypted via SSL. Even if one can decode that traffic, nobody would.

    Now, on the main topic, one interesting note is that ever since I rooted my Hero, and loaded MoDaCo ROM 2.9, the issue with the Wi-Fi connection disappeared. I'm not exactly sure why, but if my home connection is the only remembered SSID in the phone, and I activate Wi-Fi, it instantly connects.
  13. wormser

    wormser Active Member

    SSL should keep you secure from somebody sniffing your personal information, but it does nothing to stop somebody from using your bandwidth and downloading illegal materials. You are arguing against a 5 minute step to secure your network. We will always find a hole in your argument against security just like the hole in your network. Its your network and you can do with it what you want. We are just trying to help you.
  14. JoeC

    JoeC Well-Known Member

    I can appreciate that.

    I'm a helper in this thread though, not the helpee :)
  15. wormser

    wormser Active Member

    I found a work around that worked for me. It involves installing another app and isn't the optimal solution. This is a confirmed bug and hopefully the next update will fix it.

  16. wormser

    wormser Active Member

    I found a real solution to not being able to connect to a hidden SSID. Try this first.

    Check your router mode to see if it is in Auto, B or G only. Then change the mode on your router to B and G. I connected right away.
    shiregator likes this.
  17. booklikeabook

    booklikeabook New Member

    This thread is a little technical for me but I will ask the question anyway...I have a Linksys WRT54G V.6 router, the Toyota Corolla of routers from what I have seen. My Cliq sees the home network, connects, but the signal is non-functional. The wifi icon shows, but I can't reach a page. My notebook and the GF's Droid see the network and connect no prob. I just updated the firmware, restored factory settings, and currently have all security turned off. It is set to B/G mixed. One thing...the Cliq picked up the network with a strong signal after the reset, but now back to the no-op condition. Any ideas? I really appreciate your thought.
  18. wormser

    wormser Active Member

    It sounds like you have a different issue than discussed in this thread. We were working on the issue of not being able to connect to a router when the SSID (the wireless signal name) is off and not being broadcasted. Your issue sounds different. I recommend you start a new thread because you will get more responses.
  19. v1nsai

    v1nsai Well-Known Member

    Eureka! For anyone using a router similar to my linksys, you wont find a setting for 802.11 b or g or n or whatever, but setting it to 54mbps is the same thing.
    shiregator likes this.
  20. shiregator

    shiregator New Member

    This worked from me on two different Netgear routers. On my newer router the mode was "up to 54Mbps" (which I suppose means B or G). Thanks for the post!

Share This Page