Wi-Fi ProblemSupport


Last Updated:

  1. h2o pete

    h2o pete New Member This Topic's Starter

    Joined:
    Jun 10, 2010
    Messages:
    4
    Likes Received:
    0
    Had a wi-fi problem on my htc desire for a while now..

    One time I went to turn wi-fi on and it just said "Unable to start wi-fi". It had worked totally fine up until that point.

    I've tried doing a factory reset, rooted, updated rom but it's still not working.

    When the problem happened I had not rooted the phone or changed anything really.. it just happened.

    In logcat it says:

    flg=0x10200000 cmp=com.android.settings/.wifi.WifiSettings bnds=[124,404][236,531] }
    D/SettingsWifiEnabler( 548): Received wifi state changed from Enabling to Unknown
    W/SyncAllWidget( 151): activeSynch is null false
    I/ActivityManager( 79): Displayed activity com.android.settings/.wifi.WifiSettings: 495 ms (total 495 ms)
    I/WifiHW ( 79): wifi_load_driver enter
    D/SettingsWifiEnabler( 548): Received wifi state changed from Unknown to Enabling
    D/dalvikvm( 1805): GC freed 3806 objects / 257536 bytes in 97ms
    D/NetworkLocationProvider( 79): onCellLocationChanged [1363,22890]
    I/WifiHW ( 79): wifi_load_driver end error 2
    E/WifiService( 79): Failed to load Wi-Fi driver.
    D/SettingsWifiEnabler( 548): Received wifi state changed from Enabling to Unknown


    Anyone got any ideas on how to fix this?
     

    Advertisement
  2. nicmel

    nicmel Well-Known Member

    Joined:
    Apr 29, 2010
    Messages:
    103
    Likes Received:
    7
    I had this issue on my once-orange-branded desire after I accepted an OTA update. I fixed the problem by rolling back to a 1.15 rom.

    If this sounds like the issue you have (ie if you have a debranded handset) I'd recommend reflashing the rom to an earlier version.
     
  3. h2o pete

    h2o pete New Member This Topic's Starter

    Joined:
    Jun 10, 2010
    Messages:
    4
    Likes Received:
    0
    My handset was sold sim-free and it's never been locked to a network. Is that what you mean by debranded?

    Thanks.

    Also here's some of my phone information if this helps:

    Firmware version:
    2.1-update1

    Baseband version:
    32.37.00.32U_4.06.00.16_2

    Kernel version:
    2.6.29-97da29ed
    htc-kernel@and18-2 #1

    Build number:
    1.15.405.4 CL155070 release-keys

    Software number:
    1.15.405.4

    Browser version:
    WebKit 3.1
     
  4. PJD

    PJD Well-Known Member

    Joined:
    Mar 3, 2010
    Messages:
    111
    Likes Received:
    6
    looking at your phone information
    mine is simfree and unlocked Wifi is working after the update

    This is my info

    baseband version
    32.36.00.28U_4.06.00.02_2

    kernel version

    2.6.29-ocb9f166
    HTC-Kernel@and18-2#1

    build number
    1.21.405.2CL174215 release-keys

    software number
    1.21.405.2
     
  5. splette

    splette New Member

    Joined:
    Jun 14, 2010
    Messages:
    1
    Likes Received:
    0
    Hey,
    I have the same problem with a debranded T-mobile phone.
    I did not root, neither did I get the recent OTA update (still on 1.15.110.11)
    Any ideas? Thanks!

    Update: Ok, a hard-reset of the phone solved the problem. Still wondering though what it was caused by...
     
  6. h2o pete

    h2o pete New Member This Topic's Starter

    Joined:
    Jun 10, 2010
    Messages:
    4
    Likes Received:
    0
    Fixed it by setting a static IP address.

    Wi-Fi > Menu Button > Advanced > Use static IP
     
  7. h2o pete

    h2o pete New Member This Topic's Starter

    Joined:
    Jun 10, 2010
    Messages:
    4
    Likes Received:
    0
    It's broke again. Setting a static IP doesn't fix it any more. Any ideas?
     

Share This Page

Loading...