Widget option gone from long pressSupport


  1. zbeach111

    zbeach111 New Member

    When I updated my operating system late last year I can no longer get the widget option to appear when I long press the home screen. The only options that appear are wallpapers even though I have a fastnotes widget that is installed and was working correctly.

    Wondering if anyone else has experienced this or has a solution.

    Advertisement
  2. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Welcome to Android Forums, zbeach.

    It sounds like a background update to the system borked that function. Have you tried going into the recovery area and wiping cache, or using an app to clear all app/widget cache and data so you can start over (start over short of a factory data reset, which would be the next thing to try failing the data and cache clearing methods).

    I'm also wondering if you've changed launchers off the stock one, thus being in need of configuration of the home screen or other menu items that provide that widget setting function.
    zbeach111 likes this.
  3. doogald

    doogald Guides Guide

    In ICS you no longer add widgets that way. Open the app drawer and you will see "Widgets" at the top. Touch that and you will see all available widgets; you can drag the one that you want to the screen.
    zbeach111 and Frisco like this.
  4. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Well those ICS devs. ;)

    Nice catch, doogald.
  5. New Rising

    New Rising Well-Known Member

    You can try a 3rd party launcher like nova or apex from the playstore. They both give you the option to long press and add widgets. I prefer using Nova Prime.
    zbeach111 likes this.
  6. zbeach111

    zbeach111 New Member

    Thanks! I'm not computer savvy enough to change launchers or anything like that. Only did the system upgrade. Haven't tried to clear a widget cache since I am not sure how.

    When I drag a widget from the apps menu it places it on the screen as described but it doesn't function like before the upgrade. I have a great widget called fastnotes - when I needed a quick reminder I would long press and the widget list would come up and I would press the notes option from the list. A blank post-it type note would appear and I could enter a quick list. Could have several notes if needed. But after the upgrade there's no widget option and dragging the widget from the list of apps is too many keystrokes to be useful unfortunately. I appreciate the advice and will look into the Nova Prime app.

    Thanks!
  7. zbeach111

    zbeach111 New Member

    Installed Nova then Nova Prime and my widgets are back! Amazing - thanks for the suggestion!
    doogald likes this.
  8. SNeitzel

    SNeitzel Well-Known Member

    I'm glad Nova Prime got you what you needed, but to be clear, there is a difference between dragging a program from the apps menu to the desktop (that will create a shortcut to the app) and putting a specific app's widget on the desktop. In the apps menu there is a completely different tab for widgets vs programs. It sounds like maybe you just created a shortcut, not a widget.
    doogald likes this.

Share This Page