Widgetlocker and Tasker


  1. spaceman-spiff

    spaceman-spiff New Member

    Hi all,

    So what I wanted to achieve was to delay widgetlocker for a while after the display turns off. This is because the display turns off frequently while I'm distracted or in the middle of doing things, and it's a hassle to have to swipe every time to get back to what I was doing.
    So I thought of putting a delay onto widgetlocker using tasker, but I have 2 questions:

    1. Would disabling and enabling widgetlocker everytime the screen turns off drain the battery? I imagine starting and restarting an app would have some kind of effect.

    2. My attempts so far haven't worked. I tried a simple one where:
    Display Off -> Suspend Widgetlocker -> Tasker Wait 2 minutes -> Resume widgetlocker

    I also tried it with Disable and Enable. Seems straightforward enough but neither worked!

    Advertisement
    :
  2. amlothi

    amlothi Well-Known Member

    No way to know until you try it. I doubt you'll see any major impact.


    Could you be more specific? What part didn't work?

    Note that, when you use a Wait command, it only queues the following actions. The "Resume" action will occur 2 minutes later, regardless of whether the context (Display Off) is still true.

    You could also try:

    Display off > Set Variable %WLSWITCH = 1, Wait 2 minutes, Set Variable %WLSWITCH =0

    new profile

    Variable Value (%WLSWITCH =1)
    Enter Task > Disable WL
    Exit Task > Enable WL
    spaceman-spiff likes this.
  3. spaceman-spiff

    spaceman-spiff New Member

    Thanks for the reply!

    Ah, I think you may have it there. That might explain the strange behaviour I've been getting. It seems to enable or disable widgetlocker sometimes, and on others it doesn't. I couldn't figure out why.

    Well when using suspend and resume, widgetlocker was resumed, but in tool mode. After that I tried enable/disable. It worked once, and then wouldn't work again.


    Ok I see what you did there. As someone new to tasker, and new to androids in general, this level of customization is pretty mind-boggling, but I can see the learning curve with tasker is pretty steep.

    So basically when the display turns off, the variable wlswitch is set to 1, and after 2 minutes to 0.

    When wlswitch is at 1, wl is disabled

    But it still doesn't work! Tasker tells me I have no active profiles and wl is seemingly randomly disabled or enabled.

    I added another profile:

    Display On > Set Variable WLSWITCH to 0

    But I still get the same result: random locking and unlocking :(

    I'm thinking that tasker sets the value to 0 after the 2 minutes is up regardless of whether the display is on or off, and this is screwing with the system. I can't be the only person to try this with widgetlocker!
  4. amlothi

    amlothi Well-Known Member

    First, check the WL settings. You may need to have it open in Lock Mode and not in Tool Mode. That is one thing.

    Second, try changing it to this:

    Display off > Set Variable %WLSWITCH = 1, Wait Until (%SCREEN matches off, in the time field put 2 minutes), Set Variable %WLSWITCH =0

    Now, Tasker should wait until the screen is off before changing it back to 0. It will check every 2 minutes whether the screen is off, and then proceed only when it is off.


    If that still doesn't work, could you post more specifics about exactly what happens (when you turned the screen on, then what happened, what you pressed, etc.)
    spaceman-spiff likes this.
  5. spaceman-spiff

    spaceman-spiff New Member

    Ok so it still doesn't work. Here's what happens:


    Widgetlocker was disabled, and did not turn on again despite waiting for longer than 2 minutes.
    I checked widgetlockers settings, and "enable" was unchecked. So tasker had disabled it and failed to enable it again.

    So I manually clicked on enable and then turned off the display - waited 30 seconds - turned it on again - and widgetlocker was on.

    Turned off the display again - waited 30 seconds - widgetlocker on again

    Turned off display - waited 30 seconds - widgetlocker on again

    It actually worked better before, only it was counting 2 minutes regardless of whether the screen had been turned on or off in that time, so sometimes I'd wait 30 seconds, not find wl, turn if off again, wait 30 seconds and find it on. Then I'd turn it off, wait 30 seconds, turn it on again and wl would be off.

    So the key is to get tasker to stop counting after the display has been turned on, and always have wlswitch set to 0 when the display is on. I'm surprised this isn't a native system to android or wl considering it's been on other phones for years now, including other samsung phones.

    The difference is that this time tasker was telling me that there is 1 active profile.

    I'll experiment with it and post some results.
  6. cr4zydi4mond

    cr4zydi4mond Member

    Having a similar problem with Tasker and WidgetLocker. Did you ever manage to resolve this ?
Loading...

Share This Page