Widgets do not refresh anymoreSupport


Last Updated:

  1. aguida

    aguida New Member

    Suddenly all my widgets do not refresh anymore. None of them. After booting the phone some of them are refreshed, and some never show up just showing the text "updating widget". After that they are not rfefreshed anymore (Time is stuck, whether is not updated, calendar is not either, and so on. None of the other widgets are update either).

    What on earth happened, everything was working fine until this happened. I am running on ICS and there were no problems before this. I have installed Fancy Widgets (clock and wehater), launchx-pro, androidpro calendar and google reader, twitter and none of those refreshes. I tried also the TW standard widgets and those don't refresh either.

    I checked the market and none of the widgets has pending upgrades. I don't think it has anything to do with connectivity either since the clock widget does not update either.

    Does anybody have any clue? It must be something global (perhaps a setting I have accidentaly switched off?).

    Any suggestion is appreciated.

    Thanks

    Advertisement
  2. Hawker

    Hawker Well-Known Member

    You need to delete the widgets in question from your homescreen(s) and add them again
  3. aguida

    aguida New Member

    Thanks. I'll try that, but why is that? Is this a known problem of ICS? Why it happens for all of them at once?
  4. Hawker

    Hawker Well-Known Member

    The only time I've had this is when restoring my launcher's data after upgrading firmware. It never ties the widgets back in correctly. It just leaves the placeholders on the screens.

    As for why this happened to you, I'm not too sure, unless you have restored or reset anything in some way.
  5. aguida

    aguida New Member

    You could be right except that after upgrading to ICS I had placed the widgets back manually and not restored settings. Probably I should take the plunge and do a factory reset, whihc I hoped to avoid after the upgrade.

    For now I removed all the widgets and left only the fancy widget with time and weather, which now it started working again.... The last widget I had installed before things stopped working was the launch-x pro widget. I don't think this widget has any type of backgrund refreshing so I can't imagine it was the one blocking the refresh. Or what?

    Very weird.
  6. earlabs

    earlabs Member

    I have the same issue. Has this been solved in the meantime?
  7. aguida

    aguida New Member

    In my case it was due to the fact I had installed another widget (launch-x pro) that in some configuration was killing the whole refresh of all widgets.

    When choosing too large icons it would stop everything from refreshing (probablyu due to running out of memory). I uninstalled and everything went back to normal.

    If you are not using Launch-x pro perhaps some other widgets are blocking the backgorund refresh process. Try to remeber the last one you installed before it stopped working and try to remove them once at the time (and restart the phone in between).
  8. Balderick

    Balderick Member

    I tried this and it did nothing to help. The toggles, widgets and clocks are all still doing their own thing. Sometimes refreshing, more often they do not.

    My favorite is when my 2 clocks are both different form each other as well as being different from the notification bar, which incidentally is correct.

Share This Page