Widgets not updatingSupport


  1. ptardivel

    ptardivel Member

    Hi All. I've recently switched from an iphone to my first Android device. I've fl got a Samsung Galaxy Note 2 on Vodafone in the UK. I'm really impressed and would definitely recommend the switch to others. One thing I really like is the widgets. However I have an issue with a few of my widgets not updating/refreshing unless I reboot the phone (although some times they seem to wake up after a weeks hours). The widgets that don't refresh are: the built in dual digital clock, calendar (splanner), alarm clock, also the 3rd party my reminders app widget. The Accuweather app clock always seems to update fine though.

    I'm on Android version 4.1.1. Any views on what the issue may be and how I can fix it?

    Many thanks

    Paolo

    Advertisement
    :
  2. !on

    !on Well-Known Member

    Quite often widgets are actual apps, but the widget is a simple user interface of it.

    If you go in the app draw to find the app corresponding to your widget, there might be extra settings in there that may or may not be accessible from the widget itself.

    Also, apps with widgets should stay on the phone (not on SD card). The widget won't appear if it's on the card.
  3. ptardivel

    ptardivel Member

    Many thanks for the swift response. I've checked the corresponding apps and there doesn't appear to be any settings that I'm overlooking. Also with the same issue across 3 separate widgets i'd be surprised if it was a widget specific issue. I don't have an SD card so that can't be it either.

    Are there any known Samsung Galaxy Note 2 or Android v.4.1.1 widget refreshing issues? If not any other thoughts?

    Thanks again

    Paolo
  4. ptardivel

    ptardivel Member

    Any thoughts anyone?

    Thanks

    Paolo
  5. clayq

    clayq New Member

    I have the same problem - Note 2 LTE with 4.1.1. Annoying...
  6. ptardivel

    ptardivel Member

    Thanks Clayq - it is frustrating isn't it! I'm new to posting in these forums, does the lack of responses mean people don't know what might be causing the issues, or am I being too impatient?!
  7. ExtremeNerd

    ExtremeNerd Well-Known Member

    There are no known bugs like this. There are common mistakes people make which cause this to hapen, though. A few things which could prevent you from updating:
    -Background Data turned off
    -No/bad data connection
    -Update settings for each app set too long
    -Battery Manager preventing apps from updating regularly.
  8. clayq

    clayq New Member

    Some good news - I think I fixed the problem. Basically I removed all the non-standard widgets and rebooted the phone. I then re-added all the widgets. While adding, I also checked the settings.

    For example, Audio Manager Pro has a setting for how often it updates itself - it was set to never. I changed it to every 1 mins (since the GN2 battery is so good).

    So far I have gone the whole day without the problem happening again (usually it would happen within 2-3 hours and would need a reboot). Hope it can work for you also - I think it is a corner case problem, as I searched far and wide and this was the only account of the problem I could find.

    I just rooted my phone tonight, so will see if it stays working with root also.
    carguyjohn350, tsingkong and seththom like this.
  9. ptardivel

    ptardivel Member

    Thanks Clayq. Following your advice I removed all widgets, rebooted then added them back one by one (leaving it half a day or so in between to see if the issue returned). Turns out to be the myreminders widget that caused all the other widgets to stop updating. Nothing in the settings for this app/widget so will just stop using the widget!

    Thanks for all the advice all.

    Paolo
  10. buck351

    buck351 Member

    So we got our S3's, wife and I, and the wife found a place to manually set the town on the weather widget when we first got them. I don't like big brother or apps tracking me so I keep all GPS functions off unless I need them. My weather app is still working but the wife's only updates when the GPS is on? How come, same phone same version of android. We moved up to Jellybean. We tried wiping the data files for the app and stopping it and rebooting. Mine works fine with the GPS off. Any ideas?
  11. ScandaLeX

    ScandaLeX Wasn't Me Guide

    Maybe. :D
    You'll find more people read than reply- esp. when they've no idea how to help.

    It'll stay rooted until you either unroot or perform a system update that knocks out root. (Stay away from OTA (over the air) updates & wait for the dev community if you don't want to loose root.

    Widgets are not an exact science and as you've discovered, one can throw the others out of whack making you think the problem is more widespread than it is- when it's actually just related to your phone- meaning people cant help as you may like them too because we've no idea what apps you're using.

    I'm glad you got it worked out.
  12. tsingkong

    tsingkong New Member

    Thank you, clayq! You're my hero!
    It's a weather widget which stop all widgets updating.
  13. stewbuntu

    stewbuntu Member

    Same problem for me. No solutions found yet that work. I check every couple months For new solutuin. Sucks. sometimes the ram refresh when holding the home button down refreshes everything. So sick of it!
Loading...

Share This Page