wierd data on t-mobile issueGeneral

Last Updated:

  1. scotty85

    scotty85 Guides Guide

    i have a factory s-off,supercid international one x i use on t mobile.

    in a nutshell,i can only get working data on stockish JB roms :confused:

    ive done a bunch of reading and reasearch,and understand the newer gba one s micro sim is not fully compatible,requiring an older "50.01" non-gba micro sim.

    im using a cut down normal sim,wich to my understanding,should work fine.

    on ICS stock or stock based custom roms,there is no data,and no APNs,and the "no simcard" error. however,voice calls and texts do work. trying to enter an apn manually fails,since it thinks there is no sim card. since im supercid and soff ive been able to go up and down in firmwars,and across regional/carrier firmwares. anything ICS gives the same result,even the uk t mobile ICS(build

    on JB stock,or stock based custom roms,data is fine. apn is present,and it even shows my phone number in about phone/identity.

    any AOSP rom is a no go,JB or ICS.ive tried several. no phone signal until i switch to "gsm only" on the programing menu,and then pick t mobile as a carrier. after that,voice works,but no apns,and manually entering an apn doesnt work,presumably because it thinks there is no sim present.

    as i mentioned,ive done quite a bit of flashing and experimenting with this,even tried cutting down a second sim. i can go into more detail about what ive flashed,if anyone interested.

    anyone got any ideas? if it dint work,period,id try a new sim. the fact that with stock JB it works fine is confusing.i feel like theres gotta be something i could change in ICS stock or any AOSP rom to make it work.

    any thots appreciated,its driving me nuts to not be able to run cm10/AOKP roms :mad:

  2. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Scotty, I've got to be honest, if you're stumped, there isn't much hope for the rest of us :p.

    Have you tried a different RIL? I had issues on AOKP, I couldn't get a signal and the RIL/Baseband matched, I was clutching at straws, flashed an unmatched RIL and that sorted it. Worth a go?

    I used GetRIL.
    scotty85 likes this.
  3. scotty85

    scotty85 Guides Guide

    thanks for the reply EP,ive been hoping you had a some input,since you have one of these :)

    i wouldnt think that ril would matter when running a stock ruu... but you never know. and it very definately is worth a go in getting it to work on AOSP. ifn i could figure that out,i think i could get over the inability to run stock ICS ;) :D

    ill give that link a look

Share This Page