WiFi acting flakySupport


Last Updated:

  1. omidk

    omidk Member This Topic's Starter

    Joined:
    Jun 21, 2010
    Messages:
    5
    Likes Received:
    0
    Is anyone having problems staying connected to wifi? Mine is configured for WPA PSK and it drops every now and then.

    Even worse, when it drops it goes crazy trying to get an IP address after that and never connects until I reset the phone.

    I thought i had heard about something similar with the old droid.....
     

    Advertisement
  2. ZeroOveride

    ZeroOveride Well-Known Member

    Joined:
    Nov 4, 2009
    Messages:
    64
    Likes Received:
    3
    Instead of restarting, try turning WiFi on and off again. When mine acts funny thats what I do and it work great at that point.
     
  3. omidk

    omidk Member This Topic's Starter

    Joined:
    Jun 21, 2010
    Messages:
    5
    Likes Received:
    0
    I tried that but it seems to continue to do the "obtaining IP address thing".

    I saw on the moto forums that if you switch to WEP the problem goes away. That actually did work for me but WEP is pretty insecure from what I hear.
     
  4. ZeroOveride

    ZeroOveride Well-Known Member

    Joined:
    Nov 4, 2009
    Messages:
    64
    Likes Received:
    3
    Yes WEP is insecure. I can crack it pretty quickly. WPA is the way to go
     
  5. behold_guy

    behold_guy Active Member

    Joined:
    May 28, 2010
    Messages:
    30
    Likes Received:
    1
    I just got my DROID 2 yesterday and I am having the same issue. My router is not broadcasting the SSID and am using wpa. The Droid can connect for less than 10 sec sometimes before it can no longer find or access my router. It keeps scanning then connecting and then disconnected. Its very frustrating, but there are times when I can connect to an open network and keep my connection. I spend a lot of time using WIFI so I may return the phone.
     
  6. dwbrewer

    dwbrewer Active Member

    Joined:
    Aug 28, 2010
    Messages:
    39
    Likes Received:
    1
    Testing Droid 2 for work. 2.2.20 update from Verizon applied this morning. If you enable Wi-Fi from the main page in Wireless & networks settings, it goes into endless loop of turning on, scanning and turning off. If you turn it on from inside the Wi-Fi settings sub-menu, it turns on, scans and connect correctly.
     
  7. Dambuilder

    Dambuilder New Member

    Joined:
    Aug 14, 2010
    Messages:
    1
    Likes Received:
    0
    Does not matter where I change the setting from; main page and within WiFi settings both end up in an endless loop of trying to connect
     
  8. jon hazle

    jon hazle Active Member

    Joined:
    Aug 21, 2010
    Messages:
    28
    Likes Received:
    0
    I tried app "wifi keep alive" and it keeps me online, before when the phone slept it would drop the connection and I would get to watch it try to connect for 5 minutes(or it feels like it), have you guys found a fix for this issue elsewhere yet? I keep reading that its a "known issue".
     
  9. redpanda

    redpanda Well-Known Member

    Joined:
    Jun 24, 2010
    Messages:
    169
    Likes Received:
    27
    My phone sometimes randomly disconnects from wifi or goes into a loop as it tries to connect as well.

    I've also had issues where it doesn't automatically switch to 3G when I leave a wireless area. So I'll be walking out of work and wanting to put Pandora on, and even though I have full bars and live in Chicago, the 3G indicator won't come up, and Pandora won't play. Sometimes deactivating wifi works, but today I had to turn my phone off to get 3G to come back on.
     
  10. Richman21

    Richman21 Well-Known Member

    Joined:
    Nov 6, 2009
    Messages:
    452
    Likes Received:
    320
    Is there a fix yet? Mine does the same exact thing. I just got the D2 last Friday converted from the D1, did not have problems like this with the D1. The endless cycle of turning wifi on, off, on, off. I tried the widget from Beautiful Widgets and got the cycle, but tried the Moto widget and it connected with not problem, what the heck?? Anyone else?
     
  11. Redflea

    Redflea Well-Known Member

    Joined:
    Oct 6, 2009
    Messages:
    2,623
    Likes Received:
    289
    The 2.3.15 and 2.4.0 D2 leaks both seem to fix wifi issues (2.3.15 fixed mine, anyway, and others report 2.4.0 is also solid, maybe better) so one option, if you don't want to wait for the next OTA is to root and update to one of those releases.

    I know, not for everyone, but wanted to put it out there...

    BTW - WPA TKIP is cracked as well...if you really want to be as secure as you can now, it's wpa2 and AES.

    Also, if your router supports 20mhz/40mhz channel settings, you might want to try setting it on 20mhz...saw some posts that that might help.
     
    left4dead likes this.
  12. dag175

    dag175 Member

    Joined:
    Sep 12, 2010
    Messages:
    14
    Likes Received:
    5
    Same exact problem... When i try turning Wifi on from a widget or even the first Wifi toggle in menus where the bluetooth and airplane toggles are I get the on/off loop. Only way to stop it is turning airplane mode on or turning the phone off. It will eventually settle but takes forever. Going directly to the Wifi settings screen and using that toggle and it conects fast and stays connected. Added a shortcut to my homecreen to the wifi settings but still annoying. Hoping the next OTA fixes this.
     
  13. left4dead

    left4dead Well-Known Member

    Joined:
    Sep 4, 2010
    Messages:
    62
    Likes Received:
    6
    Any idea when the next update is supposed to roll out?

    I need these update(s) ASAP because the on-off Wifi cycling is killing me. Had that problem w/ the Droid X (returned) and having the SAME problem w/ Droid 2.

    I really hope that Moto fixed this issue because I've chewed their asses out multiple times in my calls to their 'Tier 2' tech support.
     
  14. Redflea

    Redflea Well-Known Member

    Joined:
    Oct 6, 2009
    Messages:
    2,623
    Likes Received:
    289
    Not the slightest idea, sorry.

    How about "soon." ;)
     
  15. left4dead

    left4dead Well-Known Member

    Joined:
    Sep 4, 2010
    Messages:
    62
    Likes Received:
    6
    Well my D2 just updated to 2.3.20 and my WiFi is still bouncing on/off (same as before).

    I'm using a Netgear WNDR3700 router.....but when I go to my sister's house, my WiFi connection is stable on her router (different brand).

    Ihat I was told by Moto level 2 support is to set the security to "WEP" and when I did that, my WiFi connection was fixed but it's not worth it at the expense of security.

    Does anyone know what router setting changes I need to make to get WiFi to work with Netgear?

    BTW, this is the LAST Moto Android phone I buy. Same crap happened with the Droid X before I took it back to the store.

    When iPhone hits Verizon in a few months, my Droid 2 is going in the garbage can.
     
  16. iavswn

    iavswn Well-Known Member

    Joined:
    Sep 29, 2010
    Messages:
    103
    Likes Received:
    2
    I have had trouble with wifi too. That person that was talking about wifi going into the loop is the same thing I get.
     
  17. DGRYAN1977

    DGRYAN1977 Well-Known Member

    Joined:
    Aug 6, 2010
    Messages:
    152
    Likes Received:
    4
    Anyone have the issue where you can surf the internet/ market place but cannot do another else that requires data?

    For example...I was downloading from the market..no problem.
    I went to reply to a post on FB from Motoblur and got "no data connected"
    same thing when I tried to refresh my email..
     
  18. RJT185

    RJT185 VIP Member VIP Member

    Joined:
    Aug 21, 2010
    Messages:
    550
    Likes Received:
    51
    Sounds like router issues. I'd check out the Motorola message boards for troubleshooting routers to work with the D2 and DX. Otherwise SBF Flash 2.3.2 and start from scratch. It's so easy to do now that with a couple hours you can determine if the problem is the phone or the routers.
     
  19. Cedward453

    Cedward453 New Member

    Joined:
    May 5, 2012
    Messages:
    1
    Likes Received:
    0
    Wifi keeps cycling off and on after root whether downloading or not. I set my "Display" to "Never Sleep". Cannot get through a download...AND cannot connect with USB , because the phone is invisible to to my PC, though rooted Droid X will charge on USB. (Did all the driver stuff too...but obviously NOT the right one)

    I tried Airplane mode w/Wifi on.
    Tried rebooting, several times.
    Unmounted/remounted SD card
    Reset "permissions" w/Root Manager
    Removed Wifi tether sw, and rebooted.

    HELP!... please!

    Sorry if this has been covered. Searched Google and AF (and other forums)

    Thanks for any help!
     

Share This Page

Loading...