wifi and mobile data at the same time?Support


  1. jmt9779

    jmt9779 Well-Known Member

    is there a setting that i'm missing that will tell the phone to turn off mobile data while connected to wifi and then turn mobile data back on again when disconnected from wifi? right now, i'm connected to wifi and i still see the 4G/LTE icon at the same time.

    (i'm coming from a droid razr and used to have a smartaction for this.)

    thanks!

    Advertisement
  2. SebaKL

    SebaKL Well-Known Member

    There is no automated toggle to use either one. You will need some 3rd party app for it, or simple profile in tasker. If you have tasker. Or simply turn it off via notification.

    Wifi will be the Primary Data connection IF you are connected to a WiFi. If your Wifi connection is lost
    BigRedGonzo likes this.
  3. sincarafan

    sincarafan Well-Known Member

    Juice Defender will do it for you as well. I have it set to turn off mobile data except when needed.
  4. jmt9779

    jmt9779 Well-Known Member

  5. SebaKL

    SebaKL Well-Known Member

    Ok, understand what you mean. In here, my data icon disappear as soon as I activate wifi. I'm using international, unlock unit.

    Tasker extends to so many apps and devices. All the way from NFC to Pebble watch :)
    It's certainly one of these apps worth buying. Not easy to use, but web is full of Tasker enthusiasts and help is widely available.

    This is what I found. Perhaps give it a go:

    This is due to the Caller Name ID app that's already installed on your phone. I noticed that when this app is enabled 4G LTE stays on while the device is connected to wifi.

    To turn off Caller Name ID:
    Go to settings
    More
    Application manager
    Go to ALL tab
    Scroll down and find Caller Name ID
    Remove the checkmark from "Show notifications" and hit "Disable"
    Hit OK if a warning message comes up

    The 4g icon should go away if you are connected to wifi
    Furrner and jmt9779 like this.
  6. BigRedGonzo

    BigRedGonzo Well-Known Member

    The S4, as awesome a phone as it is, does not have two, simultaneous data reception paths. I will default to WiFi, if WiFi is available. In fact, if connected to WiFi and your WiFi loses internet connection, the phone will set there and do nothing until the data(internet) connection is repaired. If you completely lose WiFi, the phone will switch back to 4G/3G. Someone stated above that if you don't have data you can't receive SMS, this is untrue. SMS amd MMS are sent over the carrier(phone) signal not over data.

    For your issue, I would try a factory reset (from the recovery menu) before I got to involved into setting things up. The first thing the store is going to do is a factory reset, so you may as well go ahead and try. My phone only displays the 4G/3G indicator when it is actively on network. When on WiFi that indicator vanishes. If you can't get it resolved with the phone only being a day old, the store should make good on the product. Believe me, it is a superior device and well worth having.

    BigRedGonzo

    ** Edit **

    Seba's post came in while I was typing, so I didn't see it until I had already posted.

    If his solution works, then by all means do it. I hadn't heard that, but I disabled a lot of the crapware on the phone before I did anything else.

    I hope the Caller Name ID thingy does the trick, because it is by far the simplest solution.
    SebaKL likes this.
  7. jmt9779

    jmt9779 Well-Known Member



    That did it! Thank you so much! I was just about ready to do a hard reset but I'm SO glad I checked this thread one more time before I did :)

    (I think I still may give tasker a shot for some other stuff once I get this thing set up the way I want it.)
  8. BigRedGonzo

    BigRedGonzo Well-Known Member

    @Seba,

    I was gonna hit you with a Thanks for the post (and research) you did for the guy, but that one post doesn't have a Thanks button. I'll hit your previous post.

    BigRedGonzo
  9. SebaKL

    SebaKL Well-Known Member

    I'm glad you got it working :)

    I hate hard resets. Takes me hours to do all the fine tunings and settings.

    Anyway, you have a great weekend ahead :)
  10. SebaKL

    SebaKL Well-Known Member

    You are very kind.
    If you ever find yourself in Kuala Lumpur, do not hesitate to call me up. Will do coffee or beer ;)

    Cheers

Share This Page