wifi authenticating error


Last Updated: 2012-10-21 13:55:27
  1. vishal vince

    vishal vince New Member

    does any one know why i have this problem on my samsung galaxy s3....my phone connects to wifi but when it comes to authenticating.....
    my phone says authentication error occurred

    Advertisement
  2. Rush

    Rush {<>}~{<>} Guide

    Hello and welcome to Android Forums. I'm not sure of what is going on, but have you tried pulling the battery for a minute or two. This and a restart of the router might help as well.

    I hope the information you find here will be of help to you.
    Cheers! :)
  3. vishal vince

    vishal vince New Member

    yea i have tried it...i have the same problem when i try to connect through wifi at my mates place.....it gets connected but when the phone goes to authenticate it says authentication error
  4. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Vince, On behalf of the Staff and the Members here at AF we would like to welcome you, :ciao:, look around and enjoy. :congrats:


    Also if you want to be able to connect to the Forums from your Android device, be sure to check out the free Phandroid app in the Google Play Market. Cheers!!!!
  5. frosty17

    frosty17 New Member

    Hi, I have encountered the same issue.

    I have a Samsung Galaxy S3 that was originally on firmware 4.0.3 (what was shipped with the device). Everything was working fine, I was able to connect to my wifi at home no problems.

    I received an OTA upgrade to 4.0.4. Ever since then, everytime I try to connect to my home wifi, I get the "Authentication Error Occurred" message. My router settings have not changed, my password has not changed - all other devices in my household are able to connect to the wifi without any issues.

    I have tried rebooting my phone, rebooting my router. I have also tried factory resetting both my phone and my router - no luck. My wifi has a WPS function - I also tried using this without any success (no authentication error occurred message - just times out when trying to use the push button or pin technique).

    I have disabled mac address filtering, firewalls etc. the most bizarre thing is, i turned off my router security (i.e. no security settings) and i STILL get authentication error occurred message.

    The weird thing is, it seems to work on some routers and not others. I am able to connect to my parents wifi, and my friends wifi, but not my own, and not at my work (was previously able to prior to upgrading to 4.0.4).

    Another weird thing - my router is dual band - 2.4GHz and 5GHz. I am able to connect to the 5Ghz band, but not the 2.4Ghz band. Using 5Ghz is not an option for me though, as the range is quite poor. I need to be able to use the 2.4Ghz band.

    I'm at my wits end, I dont know what else to do. Does anyone else have this problem? Has anyone had any luck fixing it? Does anyone have any suggestions?

    I am very close to throwing this phone in the bin and getting myself an iPhone 5 >.<
  6. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Have you checked in your device forum, you will get the proper help and support there, enjoy the site.



  7. hiisty

    hiisty New Member

    I'm experiencing same thing as frosty, problem started after latest update to 4.0.4.
    I've tried to reboot my home router, even though other devices are working fine with it.
    I've also tried to connect 5 different wi-fi networks which were working fine before, rebooted my phone several times, and also tried to forget networks and connect them again and made sure that the password is correct.

    So this clearly is not router problem, but something wrong with my 4.0.4 and wi-fi.

    I also found out that someone had fixed this by going to servicemode *#0011# and set wi-fi power save mode to OFF. But this did not fix this issue?


  8. lpallard

    lpallard Guest

    Guys, not meaning to hijack this thread, but I came to realize that this is an exact duplicate to several other threads here on Androidforums in regards to this WIfi problem, and on the other thread I kindly recommended people to post a comment with their device info and problem description on my Google bug report at

    Issue 36993 - android - wifi no longer working in ics 4.0.4 - Android - An Open Handset Alliance Project - Google Project Hosting

    If you have a Google account, please post there and make Google so something about this!

Share This Page