Wifi Authentication issueGeneral


  1. The Naf

    The Naf Active Member

    Ok so I've had this problem with work router since day one and till date have found no solution. Basically unable to connect to work wifi. I type the password in and try and connect and it basically goes into this auntentication loop thing and eventually ends up showing saved but wont allow me to connect.

    I have tried using a static IP address but without success. Also tried wifi fix app again without success. When I go into advance the IP Address is "Unavailable". Im really not sure what to do anymore. My only thought is perhaps I'm not doing the static IP address thing correctly so please feel free to explain how to do it properly. Other than that not sure whats going on. All my other phones connect to this network without any issue...

    A guy from another forum explained his issue which appears to be similar so I'll post that here:​
    I am trying to get my new Gnex connected to the work wifi. Unfortunately, it is failing during the authentication process. LogCat is showing this:

    Code:
    ( 2987): wlan0: Trying to associate with 00:22:55:f3:42:40 (SSID='SDI-wireless' freq=2432 MHz) I/wpa_supplicant( 2987): wlan0: Associated with 00:22:55:f3:42:40 W/wpa_supplicant( 2987): wlan0: WPA: Failed to set PTK to the driver (alg=2 keylen=32 bssid=00:22:55:f3:42:40) I/wpa_supplicant( 2987): wlan0: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=0 D/dalvikvm
    I get the same problem on 4.0.4 and 4.1.1. I believe the problem is specific to this router, as my home router works fine. Also, my NexusOne has no problems connecting to the router with the same settings. I have noticed that the displayed signal strength drops to almost nothing during authentication, but I am not sure this means anything since it does the same thing with my home router.

    From some googling, I have determined that PTK is some sort of handshake process, but no enlightenment on how to fix the problem. "


    Any help will be greatly appreciated...

    cheers​




    Advertisement
    :
  2. Skyroket

    Skyroket Well-Known Member

    This network always been pain in the ass especially wireless. Have you tried adding your mac address to the router?
  3. The Naf

    The Naf Active Member

    Nope. Unfortunately I dont have access to router/wifi settings :-(
  4. Skyroket

    Skyroket Well-Known Member

    I dont know seems complicated. Try resetting your router...
  5. The Naf

    The Naf Active Member

    unfortunately don't have access to anything. As I said its a work set-up and not allowed anywhere near the servers, routers etc nor given access network settings etc...

    Sigh what a pain...pretty much anyone else with any other phone can connect to this network except me and my galaxy nexus :-(
  6. The Naf

    The Naf Active Member

    anyone else wanna chime in?
  7. Petrah

    Petrah Psychotic Female Guide

    If the work router is set to where the admin has to add the mac address of the phone, there's no way you're going to get it to connect.

    If the router isn't set up that way, then perhaps the admin just needs to put the router on another channel.
  8. locotoro

    locotoro New Member

    I have a similar problem except with a home router. I've used this home router for a long time and it has never given me any problems but all of a sudden I'm getting this authentication problem all the time. I have connected it without difficulty to other wifi networks but not the home one.

    Initially I thought it was a problem with the phone i haven't changed any settings or upgraded.

    Very confused.

    I've got a SG2 on 4.0.4

    Anyone help?
Loading...

Share This Page