Wifi automatically turning off fix for Samsung Galaxy Note 2


  1. acallegari

    acallegari New Member

    Just in case you had the same problem that I and some other people were having. The problem was that our wifi setting in our Galaxy Note 2 was turning off automatically and randomnly. Many times while trying to set the wifi parameters.

    It turned out that AT&T has some apps like "Smart WiFi" that causes problems with the wifi. Once you stop the AT&T apps, the wifi will not turn off by itself anymore.

    I had various friends that they were about to return the phone back to AT&T until we discover that the AT&T apps were causing the problem.

    Hope this helps somebody and hopefully AT&T will fix their apps that are causing serious problems with the Note 2 wifi settings.

    Advertisement
    :
    dle68 likes this.
  2. laffery

    laffery New Member

    Samsung chat support had me convinced it was a new app or app updates I had installed recently. Before I found your post, I'd already uninstalled 8-10 apps. Samsung's next solution was a factory reset!

    I wish there was a way, shorting of rooting my phone, to uninstall all the crapware, particularly the AT&T bloat.

    THANKS for saving me a reset/rebuilt and my sanity!
  3. RWinDenver

    RWinDenver New Member

    I just acquired a Galaxy Note 2 and had horrible wifi connection problems at home. It was the only device having the problem, so I assumed it was the phone. A 2nd phone did the same thing.

    I'm on Verizon so I don't have the AT&T app issue.

    After several attempts, I found that turning off 20/40MHz on my D-Link Dir-655, it is amazingly and solidly connected. I was able to move a couple gigs of music files from my 10.1 Tablet to my Note 2 without a hitch this morning.

    I had also set the IP as static. That may have helped. But limiting it to 20MHz seems to be the cure!

    Best to all

    Galaxy-land Denver
  4. Fr0stTr0n

    Fr0stTr0n Well-Known Member

    Mines been doing weird stuff also. I disable 2.4ghz and went to 5ghz on the 40mhz only band on my Asus Dark Knight router and gonna see how that works with my new replacement Note 2.
  5. foobar99

    foobar99 New Member

    April 4, 2013 ---- Purchased the GT2 a few days ago. Had problems with WiFi disconnecting, scanning and reconnecting every 10 seconds. Samsung support was no help (reset device several times and followed other instructions, finally was told to return to place of purchase). Got another, same problems. Clearly the GT2 has either software or hardware bugs. I have a Netgear Dual-band wireless router - top of the line having no problems -- error log is clean. Other devices connect without difficulty. I found this work-around: 1) turn off CPU power saving 2) Keep Wi-Fi on during sleep: never. After those changes the problem was much improved. I then loaded the Skype app and since then no problems. I otherwise like the device, but this experience has been a disappointment.
  6. ashoor

    ashoor New Member

    Mine is the complete opposite. MY Note 2 turns on the wifi automatically even when I manually turn it off. Any idea?
  7. ashoor

    ashoor New Member

    It's official, my Note 2 has been taken over by a ghost. It turns on the wifi all by itself, even after I turn it off manually. I've tried everything, I think, any help on resolving this issue?
  8. dankirk3868

    dankirk3868 New Member

    Posting this in case someone else finds this old thread, as I did. I stumbled on a fix for wifi turning itself *off*. In summary, just boot into safe mode, then reboot again normally. That's it.
    ---
    My Wi-Fi would consistently turn itself off 12-15 seconds after being turned on. None of the other fixes I read about worked - I don't have Power Saving enabled, I don't have other power saving apps, changing whether wi fi stays on during sleep had no effect. Power level or charging makes no difference. And I'd rebooted multiple times over several days.

    Finally I booted into safe mode (hold down volume key for 45 seconds after switching on) and found there was no problem. In safe mode wi fi stayed switched on. That suggested that an app was causing the problem. So I rebooted again normally with a plan to start uninstalling apps, until I found the troublesome one. That proved unnecessary. As soon as I'd rebooted from safe mode the problem went away.

    I have a Galaxy S3 (GI-9300) running Android 4.1, UK.
Loading...

Share This Page