1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

WiFi connection not staying connected in sleepSupport


  1. ColinNUK

    ColinNUK Member

    I have a fully updated GN GSM (4.2.1), that simply will not stay connected to WiFi networks in sleep mode.

    The settings in WiFi related to battery saving and "stop WiFi in sleep" are unselected, and I just tried restricting it to 2.4GHz which doesn't help!

    Has anyone seen this behaviour before? A factory reset didn't fix this....

    Advertisement
    :
  2. tube517

    tube517 Well-Known Member Contributor

    Did you check "Keep Wifi on during sleep" in the Advanced wifi menu?
  3. ColinNUK

    ColinNUK Member

    Yep, that is set to "Always" and "WiFi power saving" is turned off (if that made a difference....)
  4. tube517

    tube517 Well-Known Member Contributor

    I don't have the "Wifi power saving" option. Where are you seeing that? Are you talking about the Wifi Optimization option?
  5. ColinNUK

    ColinNUK Member

    Sorry, that's the one. I just read the summary which talks about power savings....
  6. tube517

    tube517 Well-Known Member Contributor

    Ok, is this going on with all wifi connections or just at your house?
  7. ColinNUK

    ColinNUK Member

    All of them.
  8. tube517

    tube517 Well-Known Member Contributor

    Are you using any battery saving apps (i.e. Juice Defender)?
  9. ColinNUK

    ColinNUK Member

    No.
  10. tube517

    tube517 Well-Known Member Contributor

    Have you tried rebooting your router at home?
  11. heat57

    heat57 Well-Known Member

    Hi, don't worry, I have been having this same issue on my (retired) Nexus S and Galaxy Nexus ever since both were updated to JB. I could never really figure out what is going on, other than the suspicion that my wireless router (a Netgear DGND3700) N600 could be the culprit in tandem with changes in JB 4.1.x. I n the end I gave up trying different custom ROMs and kernels and figured out that if I disable Wifi during the night and get it fired up again in the morning everything works fine. The advantage is battery saving during sleep at night and saving precious data allowance during the day by having Wifi running at home.

    The annoying part of the problem is that when Wifi is left on during an extend sllep period, and this seems to be during night time, then you need to either disable Wifi and re-enable it or turn on/off 'airplane mode' to get the data connection going again. As I said, when the connection to Wifi goes off in sleep mode it also looses data connection.

    What I did to resolve this was to look for a work-around in the form of Tasker (available from Play Store). I ran a task/script the tells Tasker to turn Wifi off from 00:10 hours to 06:00 hours every day. When I wake up all email etc is there and Wifi connected for the rest of the day.
  12. geckocavemen

    geckocavemen New Member

    My Galaxy Nexus has this same wifi problem as well. I've narrowed it down to turning on cellular data for my phone. If I restart the phone with cellular data turned off and wifi turned on, the phone will sleep without wifi dropping out. However, if I go out I usually turn wifi off and cellular data on. When I get back home, I reverse this and turn data off and turn wifi back on. At this point, wifi will drop out when the phone sleeps. To get wifi to stop dropping out I have to restart the phone again with wifi on and cellular data off and the wifi dropping issue is gone again until the next time I turn cellular data on and wifi off.

    I just figured this out the other day and haven't had time to test any variations. Also, there is a thread going on over at XDA with several people who have this same problem as well. No solutions yet. I would link to it but I'm not sure if that is ok here or not.
  13. geckocavemen

    geckocavemen New Member

    This morning I decided to just turn off wifi for a few minutes and then turn it back on without messing with cellular data. Before turning wifi off I was having no issues with wifi dropping out. After turning it off and then back on a few minutes later it began to drop out when sleeping.

    So I guess the problem isn't related to cellular data at all but is related to turning wifi off and on. FWIW, I use widgetsoid in the notification menu to turn it off and on. Not sure if that has anything to do with it or not.
  14. blahblahyoutoo

    blahblahyoutoo Well-Known Member

    I'm having this problem as well.
    My settings:
    Keep Wi-Fi on during sleep: ALWAYS
    Avoid Poor Connections: OFF
    Wi-Fi Optimization: OFF

    When the phone goes "idle", meaning the screen goes off for an undetermined amount of time, and I turn the phone back on, the Wifi and signal bars are gray meaning no internet connection. Then it takes a good 15-30 seconds to lease an IP address (my assumption), and then the 2 indicators go blue which restores my network connections, and my alerts, messages, emails come in.

    And to top it all off, I've noticed my battery usage to be even worse than before. I lose 15-20% overnight.

    This is all after 4.2.1 or somewhere around then.
Loading...

Share This Page