1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Wifi connection problems after ICSSupport


  1. uzee

    uzee Well-Known Member

    hi

    my internet with 3G/H+ works fine, but since ICS update doesnt with home wifi. I tried the below but no luck:


    Advertisement
    :
  2. Dalby

    Dalby Active Member

    I've got the same problem. Have you found a solution yet?
  3. Rheumatoid

    Rheumatoid Well-Known Member

    does your phone work fine on other wireless networks? If so I would tell the phone to forget the network Reboot your router and then try again.
    Praneel and Dalby like this.
  4. thesmellyone

    thesmellyone Member

    my S2 ICS was working fine with my home wireless until a few weeks ago now all i get is authenticating, optaining ip address :( common problem apparently. Allocating a static ip address to the phone i supposed to work. I don't know what's changed
  5. Sheshnag

    Sheshnag Well-Known Member

    It does not seem like many people are having this problem so I am assuming there is a quick fix to this.

    Basically since I updated to ICS, it takes ages for the wifi to turn on and then to connect to the router. Is there anyway to fix this??:confused:
  6. Dalby

    Dalby Active Member

    I did a factory reset last night (what a pain putting all those apps and passwords back on) and today the phone wifi is working fine. Just hope I've fixed the problem.
  7. timbop37

    timbop37 New Member

    I had this problem after updating to 4.0.3.

    I ended up doing a factory reset on my router, which sorted out this particular problem.

    I have since carried out a factory reset, cleared cache and Dalvik cache, routed the phone and haven't had a minutes trouble with ICS. It appears to be fast and trouble-free (touch wood).

    Tim
    margol1 likes this.
  8. margol1

    margol1 Member

    Hi Tim,
    Thanks for the information. I have exactly the same issue. I just did not understand whether a factory reset of the router alone has resolved the problem ? If so, why did you do the same with the phone ?
  9. TobesEtc

    TobesEtc Well-Known Member

    I connect my S2 (UK, sim-free, ICS 4.03) to both my work and home wifi. Often it fails to connect to one or the other, but a quick off/on fixes it. Never had this problem before ICS.
  10. fuzzy1918

    fuzzy1918 New Member

    I am having the same problem. Just updated my SII to ICS and now, it takes ages to connect. The only way to quickly connect I have found, is to reset my router. Immediately after I reset my router, my SII connects immediately.

    Must be a Software bug in Samsung's update.
  11. TobesEtc

    TobesEtc Well-Known Member

    Yes, I have an identical issue. I reboot the phone as it is marginally faster than my router.
  12. crazysith

    crazysith Member

    Hi, I upgraded my contracted virgin S2 3 days ago and have this problem. Other phones are connecting to wifi no problem. I have reset the phone and my router and still nothing.

    I have tried basic fixes including removing the battery for 5 min.

    Surprised there isnt many people who have posted about this problem on this site and others, including virginmobile, providing any updates on their posts if they have found a fix.

    Its now frustrating the hell out of me and i regret upgrading now. Someone, hopefully you can help.

    Thanks
  13. Praneel

    Praneel New Member

    I will agree with Rheumatoid.

    If factoring-resetting either the phone or router solves the issue, it only makes sense that there is a problem with the wifi connection between phone and router itself.

    Its simpler to do 'forget network' rather than factory-resetting anything. Plus it is the easiest option to try before going onto next thing :)

    I had same issue when I upgraded to ICS, but the wifi is flawless now!

    Good luck!!
  14. johannes

    johannes Member

  15. Praneel

    Praneel New Member


    Wow that link has got 1000s of people having the same issue.

    Btw, have you tried to do 'forget network' for all the network, and rescanning to create an all new connection. So far all that we have tried, it does the trick! Just a suggestion
  16. Alex59

    Alex59 New Member

    I have two home wifi routers. SE arc S upgraded to ICS 4.0.3 can't connect to one of them (which, as usual, I need more). Router resetting helps connection only ONCE. After breaking connection, it can't connect again. Any action on the phone doesn't help. I think I will downgrade to Gingerbread.
  17. peter ho

    peter ho New Member

    I upgraded my Galaxy Note with the new ICS firmware and also did experience wifi connection which took ages to connect or else says no connection. Then I read the threads on this forum and found that it is a problem with other users too.

    So following one of the suggestions along the thread, I went to
    my setting,
    then to the applications
    then to my facebook
    and cleared the cache.

    and facebook connected easily and so did my internet explorer.
  18. Njd4

    Njd4 Well-Known Member

    Glad this worked for you...

    Alas, not all of us have facebook but still have this problem, so I guess we'll have to wait for another android update..

    :(
  19. peter ho

    peter ho New Member

    I take back every word I type in on the wifi problem.

    It is still a problem. I cannot log into the internet explorer and facebook after logging out. When I log in again it cannot connect - no connection etc...

    So.... I went to the setting
    wi-fi click on again
    it will go off
    then you on again

    then re connect with whatever is required
    went back to facebook - it worked again.

    The gingerbread OS did not have this problem. Hope it can be resolved. I had been using the note for 6 months on Gingerbread until the recent auto upgrade of firmware.
  20. sfrick

    sfrick New Member

    I THINK I HAVE THE SOLUTION. This same problem has been making me CRAZY for nearly 3 months, but I think I have solved the issue to Galaxy SII dropping wi-fi after updating to ICS. In my situation, there were some networks where the wi-fi stayed on and worked without any problem, but then there have been many (probably 60%) others where the wi-fi would consistently get dropped right after connecting or within 30-60 seconds and it wouldn't save the password. It had been playing well with my home network until I upgraded it about a month ago with completely new hardware and then it basically stopped working with my home network. I thought maybe it had something to do with ICS and certain kinds of hardware since it had been working fine on my home network before the upgrade. To some degree I guess this is true, but I think I have figured out the ROOT of the problem. Tonight, I was looking at my apps and read more closely what AT&T Smart Wi-fi app does. I UNINSTALLED it and my wi-fi has now been working for a few hours completely fine on my home network. I hope the same solution works for all of you. I suppose if you don't have AT&T Smart Wi-fi but some other similar app you should try uninstalling that instead. There may be some kind of setting within the app that would fix the problem, but I didn't try that. I just got rid of it. ​
  21. Anahitamaleki

    Anahitamaleki New Member

    hey guys , a few days back i wanted to connect my galaxy s2 to a new wifi network , and before doing so i deleted all the previous saved wifi networks and since then anytime i am turning on the wifi , the phone doesn't find any available network !! have you got any suggestion for me ??
  22. bot2929

    bot2929 New Member

    I believe I have found a fix for you guys.

    The things you need to do:

    1) You need to assign static IP to your device in the router settings (fixed host). Search for the router specific instructions online. You will need to enter phones MAC number and then assign ip. You can find MAC number settings>about phone>status>wifi mac address.
    2) Not sure if necessary, but on you phone you need edit WIFI details for your router. In advanced settings for the router you need to change IP settings from DHCP to static.

    Not sure why it works. Must be something related to dynamic IP in DHCP network.

    Enjoy working WIFI connection!
Loading...

Share This Page