WiFi Connectivity FixTips

Last Updated:

  1. Creighton

    Creighton New Member

    I'd like to propose a very simple solution to possibly fix WiFi connectivity issues that some users (like myself) have been facing with their Droid RAZR phones. This may also work on other Android phones that face a similar issue.

    My setup:
    Phone: Droid RAZR MAXX (Android v2.3.6, System v6.12.181.XT912.Verizon.en.US)
    Router: Linksys WRT54G v8 running alternative firmware [DD-WRT v24-sp2 (08/12/10)] - SSID set to broadcast on channel 6, WPA2 Personal security with AES

    The problem:
    Upon turning on WiFi on the phone to connect to the internet using my home network, the RAZR would successfully do so (get an IP address, etc), however the icon on the top notification bar would stay white or switch between white and blue seemingly sporadically. My understanding of this is that white means it's connected to the access point, while blue means it is connected to the access point AND also connected to Google's servers (thus the data connection is available). Turning WiFi on also makes the 3G icon white, probably because the phone wants to at least attempt to route data through the WiFi connection. Unfortunately this doesn't happen while the WiFi icon is white and anything that needs to use the internet/network is rendered embarrassingly useless. Sometimes the icon will stay blue long enough to get what I need done, but more often than not it doesn't (we're talking blue icon for a minute at most, then back to white). Needless to stay this isn't how such a great piece of technology should work. So I searched around the web, tried various suggestions (even as far as to factory reset). Nothing worked.

    The original solution:
    The only way I found I could get the WiFi on the phone to stay connected and consistently send and receive data (blue icon) without ever returning to the white icon is to unplug or reboot my router and then reconnect on the phone once it's back up. The WiFi would then work flawlessly...that is until I disconnected. When reconnecting at a later time (or even immediately after sometimes), the issue would reappear. So I got one shot on my WiFi per router reboot.

    The permanent fix:
    After thorough testing yesterday and today I can say that I feel as though I have conquered my issue (and possibly others' similar issues) meaning the WiFi icon stays blue during the entire WiFi connection, and will consistently be able to reconnect at later times without having to reboot my router or deal with the insufferable consequences (the dreaded white icon).

    My router was setup to use a mixed network mode (both B & G wireless connections were allowed). By simply changing this option in my router's settings to allow G ONLY, the issue disappeared. I haven't been able to reproduce the initial problem since changing this setting.

    The end:
    That's all I got. One little setting routers have to support older devices needs to be changed to support newer devices. Out with the old, in with the new. If you have experienced similar WiFi issues, I invite you to try this "fix" and see if it can't work for you as well as it did for me. Let me know how it goes, if so let's get this spread around so Google can figure out where they went wrong with wifi connectivity.

    -Creighton Linza

  2. rnlcomp

    rnlcomp Well-Known Member

    Its the routers problem not google or motorola, you may need to flash the routers firmware to a newer version (if there is one) our buy a new (er) Model. I use linksys(Cisco)
  3. Creighton

    Creighton New Member

    Hm, no.

    The router isn't even remotely at fault here. Before I had to change the wireless mode in my router's config (as described in my OP), my laptops would all connect fine. My old phone, a Blackberry Torch, would also connect flawlessly to it.

    Maybe I should have stated in my OP that I didn't change anything with my wireless network other than the device I was using to connect with (my new droid razr maxx), in order to combat anyone with their thumb up Motorola/Google's butt. I should have also stated that this issue doesn't only occur on my home wireless network, but also at times when I'm elsewhere.

    Router firmware should be assumed to be up to date given I took the time to list it. Although it's almost two years old, (DD-WRT has internal issues) the firmware has the ability to do more than most stock firmware of new routers today.

    And while I would agree, a new router (perhaps N) would be great, that's beside the point entirely. The router isn't at fault here, it's the phone. I shouldn't have to accommodate a single device's needs on my network when its WiFi capabilities as-advertised equal my other devices - which all work correctly.

    I've seen several other instances and variances of my problem throughout RAZR/Android forums, so this isn't as simple of an issue as "it's the router's fault" - hence my reason entirely for posting this tip/hopeful fix.

    Thanks though.

    Edit: I'm going to hook up a D-Link router I have lying around to do some further testing to hopefully rule out the router as being an issue entirely.
  4. seVer

    seVer Well-Known Member

    new equipment should be backwards compatible to work with anything ever made. /sarcasm
  5. dmodert66

    dmodert66 Well-Known Member

    Not really a "fix" for my house, but great for some people. In my house there are too many mixed device between G and N. Changing to G only would kill the speed for the N devices, while changing to N only would not allow G devices to connect.

    I can see this being a solution for people who only have a wireless G router though (or N router and only wireless N devices in the house).
  6. MasterGadgets

    MasterGadgets Well-Known Member

    Same here. The Linksys would not automatically change channels to accommodate the device being used at the time.
    Had to go to a D-Link router. Works fine now [and stronger signal].
  7. Creighton

    Creighton New Member

    New equipment should not claim to be if it isn't, as seen in the RAZR specs "IEEE 802.11b/g/n." It's really more of an issue of the device being able to deal with wireless mode switches it seems. /intelligence
  8. slsmag

    slsmag New Member

    I was unable to get my Razr-M to hold a WiFi connection with my old B/G router. Saw your message, changed the setting on the router to 'G Only' and now I've got a perfect, consistent, strong connection.

    Thank you!

  9. DroidInJax

    DroidInJax Well-Known Member

    I, too, was having problems with my Maxx's WiFi. Just got the phone last week and was getting really bummed about the WiFi issues. I work from home, so it is a necessity.

    After reading this post, I changed to G only, and it seemed to work after restarting my router. Well, that was short lived as the problem was back again.

    I read some other posts about having to revert to WPA encryption. My Netgear router was set to WEP, so I changed it to WPA encryption and have not had a problem since. Two full days with speedy WiFi on the Maxx!
  10. Pete999Tete

    Pete999Tete New Member

    You probably aren't watching this thread any longer, but what you posted is not correct. Changing a router's settings to N-only means a G device can still connect, but only at G speeds. It will also force the entire network to G speeds, regardless of whether they are N or not. It is certainly not an optimal solution, but it will work. Mixed mode is better, it allows all-N transmissions, and then it encapsulates (or embeds) the N-transmission into G transmissions thereby protecting the rest of the network from the legacy device (ie. doesn't reduce the entire network's speed due to a single device).

    What I suspect is happening here is that the Razr is not properly identifying itself as an N device. When the router is set to Mixed Mode and starts using Mixed Mode Format Protection, it embeds packets in G transmissions but should only do that for older non-N devices. The Razr then receives the transmission as G while it was expecting N, and thus loses the connection. Creighton's solution works because by setting the router to G-only, you force all devices to connect as G and there is no transmission embedding.

    What would be a better solution would be to figure out why the Razr is not properly identifying itself as N, fix that, and that should take care of it. I don't have a Razr, but my neighbour does. I'll see if there is a way to force it to N. Perhaps it too is set to B/G/N but is simply choosing the wrong transmission type when presented with a choice.
  11. gigicheyne

    gigicheyne New Member

    How do you fix the issue when you are attemting to get wireless at a coffee shop, library, or work? It used to work just fine, and stay connected blue, but now suddenly drops the wifi connection after a few minutes. I can't go change the router in these places.
  12. dieselglider

    dieselglider Member

    Not sure if this is linked, but when I bought my Maxx in Dec '12, I noticed WiFi throughput patchy. ie, Some sites would load, others wouldn't.

    What I did was to play with the router MTU setting, ending up at 1380, down from the default of 1492 for my PPPOE connection. This seems to be the highest setting that my Razr Maxx is happy at. I have just tried the default 1492 setting again, and noticed the WiFi icon staying white, with very little traffic being let through. I don't seem to have a dedicated router setting for either G or N, just mixed.

    I should add I'm still using Android 2.3.6.
  13. mail2cuc

    mail2cuc New Member

    I have Motorola Fire XT530 which supports all B, G, N modes. And I have Linksys WRT54G router *2.4GHz, 802.11g) which is set in mixed mode. I tried to set to B only and G only. It doesnt have N only in drop down.
    I am able to access internet on many wireless networks, but i am having problem only with this WRT54G router. What could be the solution?
    I tried resetting my phone to factory settings and resetted the router many times. But it just doesnt get internet (though it is connected).
  14. doniago

    doniago Well-Known Member

    Have you checked to ensure the router isn't filtering MAC addresses or otherwise restricting access?
  15. Powers9040

    Powers9040 Member

    Excuse my ignorance, but how do I check to see if the router is filtering Mac addresses? Ever since I downloaded JB my wifi will not connect. Thanks.
  16. doniago

    doniago Well-Known Member

    You need to log into the router itself and check its settings. If you can't access it by wi-fi you may need to plug in with an ethernet cable.
  17. MeatLoafT

    MeatLoafT Well-Known Member

    From what I understand, JB will no longer allow WIFI connections to WEP, you have to change your router to either open or WPA2. I lost connection at a local restaurant running WEP after upgrading to JB (AND DOING AND FDR!) Talking to the owner, got him to change to WPA2 and have had absolutely no problems since.
  18. RickInSJ

    RickInSJ New Member

    XT912 Razr here, rooted but factory JellyBean ROM.

    Connected just fine to my home router but not to my CLEAR wifi hotspot

    what worked was, turning off "mixed mode", i.e setting my hotspot to G only instead of B/G.

    Why my home wifi worked is because I have two separate zones, one for G only and one for N. I have no legacy B hardware to worry about.

    Once I set for "G Only" the Razr connected in seconds.

    Hope this helps

Share This Page