wifi connects but does not load web pagesSupport


  1. jxs1984

    jxs1984 Member

    I have a problem with the wifi... its able to connect to my router but im not able to use the internet. web pages wont load, ebuddy wont connect, fring wont connect, android market wont load. the wifi internet was working before and now its not.

    currently my laptop is connected via wifi and its confirmed I can browse websites and chat through aim. 3G network works fine but I want to save battery life when I'm at home.

    what seems to be the problem?

    Advertisement
    :
  2. Covert_Death

    Covert_Death Well-Known Member

    my brother had this happen to his Hero, i fixed it for him by going Menu>Settings>acounts&Sync and pressing sync all, it refreshed everything and syncd everything that wasn't before and then the internet started working as well
  3. justryan

    justryan Member

    I'm having this same issue on a regular basis. Yesterday, I fixed it by resetting the phone. WiFi worked until this morning where it broke again. Not sure what's causing the problem, but the "sync all" is not a working solution for me. WiFi shows it's connected, I have an ip address. I'm getting good, strong signal, but none of my apps will connect. No internet, Qik, or mail. Nothing.
  4. try turning off or changing the wireless security of the router. some security protocols wont work with phones.
  5. zanza

    zanza Well-Known Member

    +1, having same problem on HTC Incredible, tried several different router passwords and nothing worked. IT seemed to stop working out of the blue (was working fine, didnt' change anything, then suddenly stopped working).
  6. EarlyMon

    EarlyMon The PearlyMon Moderator

    Try a router reset.
  7. lamposts

    lamposts New Member

    Hi, having all the same problems. The youtube app works fine and so does the gmail and talk app but the browser will not load a single page. I've reset my router, messing with nearly every setting. Please help!
  8. Drew5150

    Drew5150 Well-Known Member

    yes do this. my evo seems to kill my router. works fine and then it will stop. it will also sometimes block the wifes laptop.

    if my evo is on wifi and her computer loses the internet but keeps wifi connection. i just turn off wifi on my phone and have her switch off her airport and then back on and she is good.

    when its just my evo that doesn't get the internet i reboot my modem and router and all is good.
  9. The Batman

    The Batman Active Member

    I am the exact same issues with my Evo. When I am on 3G, everything works great, but as soon as I switch on the WiFi, forget it.

    I have tried deleting the network off of my phone and putting it back on, but nothing happened. Reset the modem, the router, all of it... Still nothing..

    Please guys, there has to be someone out here that knows what the heck is going on and what to do to fix this (at least I hope there is)....:(
  10. Mr. Ed

    Mr. Ed Well-Known Member

    sounds like ip conflicts. have you guys completely reset the router to factory settings and set everything back up..one at a time connect the devices to the router so everyone gets a fresh ip?
  11. The Batman

    The Batman Active Member

    I ended up resetting my modem, router, and then deleted the WiFi connection that i had on my Evo. When I connected back ti my network everything worked.

    So far so good... keep your fingers crossed lol.
  12. Bealebe

    Bealebe New Member

    Make sure that you don't have your static IP checked off. To get to that screen go to your settings>WiFi and wireless networks>WiFi settings>push the menu button>advanced. Then make sure it doesn't have the setting for the static IP checked. it worked for me!

    Samsung Captivate Galaxy S
  13. Ppop

    Ppop New Member

    Had the same problem. Turned out that I had a proxy address set to 1.1.1.1. Everything except the Android browser worked. I tried Opera, which worked. It was after that that the Android browser stopped. Uninstalled Opera, and it still did not work. Cleared the proxy address and it started working again.
    0zzi and ronafire like this.
  14. kside

    kside New Member

    I had Galaxy S2, and problem where wifi connected fine and worked with Market and any Apps, but not for normal web browsing, i think i finally fixed by going to advanced wifi settings, cleared proxy and port info i forgot i had put in there, went to web browser and did reset settings/clear history. Now it works fine :)
    jainmaine likes this.
  15. LBPHeretic

    LBPHeretic Well-Known Member

    I had this issue, or one that was similar, with the stock ROM of my Sprint HTC Hero. I could connect to my Wi-Fi router, and it would work just fine, but then after I put it to sleep, some minutes later it would stop working but stay connected.

    This all happened after I had moved to my Sprint HTC EVO 3D, but was still using my Sprint HTC Hero as a Wi-Fi enabled Internet device. I tried a static IP address and that seemed to help, but it never eliminated the problem completely until I flashed a different ROM.
  16. TwoEleven

    TwoEleven New Member

    Signed up because I had this problem and found a easy solution that I dont see posted here:

    TCP/IP STACK RESET:


    Just do the following:

    click Start, type CMD in search bar, right-click CMD, select "Run as Administrator" to open a command prompt.


    Reset WINSOCK entries to installation defaults typing: netsh winsock reset catalog
    press enter

    Reset IPv4 TCP/IP stack to installation defaults: netsh int ipv4 reset reset.log
    and press enter

    Reset IPv6 TCP/IP stack to installation defaults: netsh int ipv6 reset reset.log
    and press enter

    Reboot the machine.

    Problem solved:D
  17. ronafire

    ronafire New Member


    I joined just so that I could say a huge thank you to you for this advice!! It worked brilliantly and I was just so relieved I wanted to thank you personally.. My Ex was the computer buff..I am a total computer Bimbo..Lol..A month ago he was removed forcibly from my house by the police after going beserk with a butchers knife through the furnishings..He also damaged my pc and threw my phone across the room..My pc is beyond repair..Am using my sons laptop atm..I could not get my Hero phone to connect to the net at all..Was just about to call Virgin and beg a new contract phone off them which would've pushed my monthly bill up considerably. But first I borrowed my sons laptop and came online for a possible solution..Found nothing at all till your reply that worked!! I am now happilly connected to the net again. I can't begin to thank you enough for this..So very much appreciated, xx
  18. 0zzi

    0zzi New Member

    This totally worked. The proxy wasn't the same "1.1.1.1" it was a phrase to do with proxy (sorry I deleted it without reading it all) but when I deleted it my browser worked! SWEET!!!:driver:
  19. jainmaine

    jainmaine New Member


    Thanks that worked, just cleared what was in the port info line and it works...thanks for posting
Loading...

Share This Page