Wifi disconnect problemsSupport


  1. pindemad

    pindemad Member

    Hi

    My i7500 keeps losing the connection to the local wifi, this happens both at home and at the office; but laptops and other wifi phones have no problems connecting to either network.

    Sometimes it helps to disable and enable wifi - but at other times it takes a few minutes before phone actually connects.

    I have tried the "wifi fixer" app but it does not solve the problem.

    Any ideas?

    Peter

    Advertisement
  2. Rastaman-FB

    Rastaman-FB Well-Known Member

    try going into wifi advanced (hit menu) and change the amount of channels to a higher value and see if that helps

    i found my phone doesnt like mix mode G and N routers and if i change the router to just be G its stable
    chknhwk likes this.
  3. kam187

    kam187 Well-Known Member

    Ahh good one Rastaman, I had similar problems. Fixed it here.
  4. ressu

    ressu Well-Known Member

    If you wish to comply with your local regulations, set it to 11 for the US, 14 for Japan and 13 for pretty much rest of the world.

    List of WLAN channels - Wikipedia, the free encyclopedia
  5. kam187

    kam187 Well-Known Member

    That's just the max channel number it will scan upto. Changing to just G seems to fix the problem tho.
  6. pindemad

    pindemad Member

    Thx for the reply

    I have changed the channel setting on the phone but it does not seem to make any difference.

    Unfortunetely my home router has bad firmware so I cannot change the channel it uses (number 6 according to the wifi analyzer app).

    Actually the phone does not lose the connection to the wifi, the problem is reconnecting to the wifi after the phone has been in screen off mode.
  7. Rastaman-FB

    Rastaman-FB Well-Known Member

    oh ok, this one should be easy enough

    settings> wireless controlls> wifi settings> press menu and click advanced> wi--fi sleep policy> click never.

    hopefully that will help

    btw what sw version are you on
  8. Xenon

    Xenon Well-Known Member

    How does WiFi chipset work? If WiFi is disabled, then it does nothing. Clear
    so far. But what does it do when enabled? Does it periodically scan for networks?
    It probably does, as it connects to my WiFi when I get home. But does this
    scanning operation drain battery? Do you people disable WiFi when you are
    away from familiar networks? Should I be doing it?
  9. kam187

    kam187 Well-Known Member

    By default, it sleeps when the screen turns off. when you unlock, it searches for a network. So in those conditions its not using battery untill you unlock.

    In your example it sleeps, and when you get home and unlock it searches and locks on.

    So worst case you leave it on, and you unlock lots of times while away from a hotspot. That would drain some battery on each unlock.

    Overall it probably won't drain that much battery.
  10. Xenon

    Xenon Well-Known Member

    Thanks. It probably drains some battery in my case, since I use GTalk
    on a daily basis and hence do lots of unlocking. But I didn't notice a
    performance hit compared to when I had disabled WiFi, so, as you say,
    it's probably not a huge drain.
  11. kam187

    kam187 Well-Known Member

    Yeah, who knows it might be smart enough to check if your location changed before it scans again!
  12. pindemad

    pindemad Member

    I have firmware version I5

    I just checked my router at home, it was set to Super G wireless mode, now I have switched it to G mode and changed the wifi channel (not possible in super g mode). The phone seems to connect a lot faster so that was probably the problem.
  13. kam187

    kam187 Well-Known Member

    You should check other wireless networks in your area, and what channel they are using. Usually they're on channel 6 or 11. If you're router supports channel 13 or 14, use that because only the latest routers support it, and even then only if you change their region to outside US and UK. So its unlikely any other n00b on your street will use that channel :)

    You'll need to check your computers can handle that channel too tho. I'm always using channel 13... shit you dont live on my street do you? If so ignore everything i said ;)
Loading...

Share This Page