Support WiFi Disconnection

Discussion in 'Android Devices' started by Nighthawk4, Nov 14, 2010.

  1. Nighthawk4

    Nighthawk4 Well-Known Member
    26

    Nov 6, 2010
    55
    3
    26
    Male
    IT Network Support
    UK
    I find that whenever my San Francisco goes to standby it seems to lose the WiFi connection - so when I remove the lock and try to use it again I have to reconnect to my WiFi. My old iPhone always stayed on WiFi even when the phone was in standby. The iPad also stays connected.

    Is this just the way Android phones work or is there something I can do to stop the disconnection please?

    The 3G signal is very poor at Home, so I rely on the WiFi for email updates and calendar and todo updates.
     

    Advertisement
  2. xene68

    xene68 Member
    6

    Nov 9, 2010
    8
    6
    6
    IT
    England
    Hi - i had the same problem - if you install 'Blade wifi fix' from the market (its free) it should resolve it. If the wifi is disconnected when the device resumes from stand by it restarts the connection. Its worked everytime for me :)
     
  3. Nighthawk4

    Nighthawk4 Well-Known Member
    26

    Nov 6, 2010
    55
    3
    26
    Male
    IT Network Support
    UK
    Thanks, I will give that a try :)
     
  4. master_yoda

    master_yoda Well-Known Member
    53

    Jun 17, 2010
    260
    50
    53
    United Kingdom

    I concur ... this fix worked for me too.
     
  5. Nighthawk4

    Nighthawk4 Well-Known Member
    26

    Nov 6, 2010
    55
    3
    26
    Male
    IT Network Support
    UK
    I tried the fix. It now reconnects but it insists on connecting to my neighbours WiFi instead of mine. Is there any way to persuade it that doing that is not conducive to its health?

    Can I make it ignore certain signals, which it can detect and only go for the one I select? No other WiFi device I have ever used does this - iPhone, iPod touch, iPad, Nintendo DS, laptop, netbook, etc. All of these select the one I told them to use. Only the San Francisco connects to the wrong one.

    Incidentally, it also forgets the password every so often, although not always. Then I have to enter the password 2 or 3 times before it accepts it, even with 'show password' on - so I can confirm I entered it correctly.
     
  6. Nighthawk4

    Nighthawk4 Well-Known Member
    26

    Nov 6, 2010
    55
    3
    26
    Male
    IT Network Support
    UK
    I might have discovered why my WiFi is giving problems.

    When it prompts for the password, I entered the correct password and then pressed 'Done' to remove the keyboard. Is it possible the system assumed the password was therefore '**********<return>', instead of '**********' ?

    I just tried again and again to get it to connect correctly and it failed, each time connecting to one of my neighbours' systems instead - which then failed as the signal is not strong enough.

    Finally, I entered the password and pressed the back button to remove the keyboard and it worked. This is the back button on the phone, not the 'back' or 'delete' key on the keyboard.

    I will see if that has resolved my WiFi problems :)
     
  7. Tye

    Tye Well-Known Member
    36

    Aug 5, 2009
    157
    4
    36
    South East England
    Please keep us updated on this Nighthawk4 as I have bought the San Fran for my girlfriend for Christmas and knowing that she is not the most technically minded person out there, I would like to keep the whole experience as simple as possible for her :)
     
  8. Nighthawk4

    Nighthawk4 Well-Known Member
    26

    Nov 6, 2010
    55
    3
    26
    Male
    IT Network Support
    UK
    It seems the idea about the password was wrong. It still keeps forgetting or refusing the password. I check the box for showing the password when entering it so I know I am entering it correctly.

    This is extremely frustrating.


    Edit - Is there any special WiFi connection app which other people use please? I get a strong signal showing from my own WiFi, which I moved on to a different channel in order to improve the connection ages ago. Everyone else near me is on channel 1, all clashing with each other.

    This was all fine before I bought the San Fran. My iMac, iPod Touch, iPhone, iPad, Wii, DSi, etc. all connect fine. Only the San Fran has any problems :(
     
  9. BurnCK

    BurnCK Well-Known Member
    43

    Nov 18, 2010
    232
    44
    43
    SQL Analyst
    Manchester, UK
    Your phone wouldn't (or at least shouldn't) automatically connect to a Wi-fi network unless you've previously told it to. I can only asume that at some point you've connected to your neighbours Wi-fi meaning that your phone now has it stored as a favourite. When your phone looks to reconnect to a network in range it is seeing that you've previously connected to your neighbours Wi-fi and therefore reconnecting.

    Try telling your phone to forget your neighbours Wi-fi. In the Wi-fi settings look for your neighbours network on the Wi-fi list and hold your finger on it for a second or so. A menu will pop-up and there should be a 'forget network' option. If there is choose it and your phone should no longer auto connect.

    Hope that helps :)
     
  10. BubbaHotepUK

    BubbaHotepUK Well-Known Member
    16

    Jun 24, 2010
    97
    6
    16
    Same here - worked immediately on install, not even a reboot required. Great tip Xene68.
     
  11. musulman

    musulman New Member
    5

    Apr 8, 2011
    1
    0
    5
    Hi
    I could solve this issue with blade wifi alive hack from market on my orange sf.
     
  12. sah367

    sah367 Active Member
    26

    May 30, 2010
    28
    1
    26
    Bus Driver
    Romsey, SO51 (UK)
    Hi all,
    I have just read this thread as i have been having the same problem. I have installed 'Blade wifi fix' and all seems good so far.

    Thanks for the tip off guys!

    Scooter
     
  13. oldcaz

    oldcaz New Member
    5

    Sep 26, 2012
    1
    0
    5
    On BT router - set router to wifi b/g NOT n.

    Solved the link break issue for me.
     
Tags:

Share This Page

Loading...