WiFi doesn't connect!General


Last Updated:

  1. Jsilence13

    Jsilence13 Member

    Hello, first post here :D

    Anyway, I want to connect to my home network (Wifi) but it doesn't connect and keeps saying disconnected even though it's signal strength is excellent.:confused:

    It doesn't connect to my home network (Orange) but it connects to open networks like BTOpenzone and BTOpenzone-H.....

    Please help!

    Advertisement
  2. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member

    Welcome to the Forum!

    One question, is your home network open or password protected?
  3. Jsilence13

    Jsilence13 Member

    It's password protected and I have entered it correctly.
  4. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    You may want to look at updating the firmware of the router.
  5. Jsilence13

    Jsilence13 Member

    And how do I do that?
  6. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member

    You need to go to the manufacturers website of your router and find a How-to guide to update it.
  7. Jsilence13

    Jsilence13 Member

    No new update.... What now :confused:
  8. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    Ok, something else to try is downloading Wifistatic from the market then open the application choose to add configuration. before you add the configuration though, remove and reinsert power to the router and then attempt to connect the phone.
  9. Jsilence13

    Jsilence13 Member

    WAIIIIIIIIT!!...

    Forget about all the posts above.... MY WIFI WORKS NOW :))
    It was the key... The '1' looked like a 'I'... Curse my eyesight :|

    Thanks anyway, you guys are awesome :):cool:

Share This Page