WiFi Error in Android 2.2 / Froyo / Samsung Galaxy MiniSupport


Last Updated:

  1. rugrln

    rugrln New Member

    Hey,
    I just recently got a Samsung Galaxy Mini with Android 2.2 and it's all great and all, except for one thing.

    The WiFi stops turning on after a couple of times of turning it on and off.
    It just shows WiFi error, and will not turn on unless I restart the phone.

    I've read around..and it seems various people have this problem but not quite the same.

    Anybody know a fix to this problem?

    Notes:
    My android is not rooted or anything, nor was it upgraded.

    Plz help!


    Advertisement
  2. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Welcome to the forums, rugrln.

    You're right, we are seeing a few issues like that on Froyo around the various device forums.

    There are several things tried, which work for some in varying degrees of success, but all worth a try as they are simple:

    - several reboots of the device.. just turn it off, leave it dead for a minute, then turn it back on and check wifi after about three of those cycles

    - live battery pull.. with the device on, remove the battery, wait for a minute, then put it back in and check wifi

    - factory data reset.. menu > settings > privacy > factory data reset.. you'll lose all settings and return the device to original settings.. your SD card will not be touched
    popasback and armanke13 like this.
  3. rugrln

    rugrln New Member

    Could you clarify exactly what does soft reset do?
    ie Does it delete my apps? my contacts/calendar?

    Well I do restart my phone everytime it has appeared...but it's every few days..since I was keeping my WiFi on all day to avoid this problem which lead to a horrible battery life...woke up one morning to find my phone completely dead..turned on with 30% batt life?!
  4. agarwalneha1

    agarwalneha1 New Member

    Best Answer
    I have tried factory reset and i have done it by removing my sim and external memory card...
    and it deleted all my apps, memos and calender data. Also, i think it could delete contacts ... in my case contacts were not saved in my phone memory so my contacts were saved.....

    but factory reset solves almost every problem... it resets all setting done by me to default....

    yes.. its the last alternative to use....
  5. rugrln

    rugrln New Member

    Thanks guys...trying the factory reset as I speak...Let's hope it works!! :)
  6. iipl

    iipl Member

    Hi,
    I have the same problem on my device. I found that it just shows `scanning...` and this message appear/disappear very quickly and frequently. I have Nokia E63 just beside this same Samsung device but Nokia works fine without any issue or errors. Settings are done perfectly on both devices (of course both has own IP) but still unable to make 1st wifi connection from android.

    Let me know if anyone has any suggestion to try (without harming device).

    Thanks
  7. murtazatalib

    murtazatalib New Member

    hi i have just bought my Samsung galaxy mini and i am having same problems i have tries resets battery pull...
    now what i tried was i had put manual ip add and it connected to my wifi but it does not browse what to do....
  8. murtazatalib

    murtazatalib New Member

    About Smasung galaxy see i tried this and it worked but wifi is connected but i cant browse

    Wifi problems after upgrading to Froyo
    I had the exact problem as that of yours. I upgraded my galaxy S from eclair (2.1) to Froyo (2.2). My Wifi was never connecting and even though it did, it was not recieving any data from the web. This may be the case for many others too. If you/ users with same prob haven't yet gotten through with this, then there is a simple solution.

    Follow these steps:

    1.Apps>Settings>Wireless and network>Wi-Fi settings
    2. Press the menu key on that page (left most bottom hap key)>advanced
    3. Select Static IP
    4. Now enter the IP address, gateway, Netmask, DNS1 and DNS 2. You can find these numbers on your computer by typing cmd (dos command prompt) in the Run and then check youre IP settings. Type ipconfig in the cmd prompt. It will tell you the exact IP address. Make sure the last digit in the IP address is different from that of your PC. Else it will result in a conflict. Typically, the Static IP data on your Galaxy S will have to be like

    IP Address: 192.168.3.8 (the last digit will be that of your PC/ devices that you are using. It has to be diff for your smartphone)
    Gateway: 192.168.3.1
    Netmask: 255.255.255.0
    DNS1: 192.168.3.1
    DNS2: 192.168.3.2
    NeroI and MatThePhat like this.
  9. JonSS

    JonSS New Member

    I've found that holding the Home button (or whatever the button at the front is called) until the task manager option comes up, going into task manager, then RAM manager, choosing Level 2 and the clear memory button is usually enough to get wifi to turn back on, rather than rebooting the whole thing.
  10. Aliapaydin

    Aliapaydin New Member

    hey i have same problem with my galaxy mini i sent my phone to service after 10 day I have bought it. they said me they updated firmware but the same problem goes on. :(
  11. Hamza1592

    Hamza1592 New Member

    That doesn't solve the problem for me! :confused:

    P.S. how do you choose level 2? :S
  12. krist0ph3r

    krist0ph3r New Member

    worked for me (smasung galaxy i5510). repeated reboots did not, neither did clearing the ram via the stock task manager. i didn't like the idea of a hard reset, as i have tons of apps and games, and would hate to download them again! (even worse, if it didn't work i'd have to download them without wifi *horror*)
  13. Aliapaydin

    Aliapaydin New Member

    i still experience the same problem unfortunately :(
  14. DrViktor

    DrViktor New Member

    Same here...
    Rebooting helps but does not prevent reoccurance...
    Anyone? Ideas?
  15. nonstopnate

    nonstopnate New Member

    I'm not sure if this has been posted yet (I didn't see it), but a fix that worked for my Samsung Galaxy 551 running Android 2.2 was:

    go to phone/dialer, enter:
    *#*#526#*#*
    it'll display "driver installation successful" or something similar, and then Wifi magically works.

    Glad it was so simple and didn't involve patching or anything.

    Found it at the following:
    SOLVING THE
  16. jolsten

    jolsten New Member

    rajgsm and jonathankpeter like this.
  17. Wyctafitrti

    Wyctafitrti New Member

    Hi All,

    I have myself a Samsung Galaxy ACE s5830 which I got just 10 days back and had found this problem where the phone just displayed error while switching on wifi. I then restarted the phone and found that wifi was working fine. After this I began noticing that the phone occasionally (two or three times a day) got hung up with a blank screen while the keypad is locked. When I tried unlocking the keypad, the phone do not respond. I would then have to disconnect the battery or press and hold the power key for 10 seconds to bring my phone back to life. However, I can see that if I switch off wifi, the phone does not get hung up.
    Mine is running Android Froyo and I am yet to take it back to the service center. I hope to get some answers from you experts before that. Does anyone know of any application which logs system events on the phone so that I can inspect the problem? Thanks in advance for any help to bring my phone back to normalcy.
  18. crm92

    crm92 New Member

    Live battery pull worked straight away for me, thanks :)
  19. pam.thlo

    pam.thlo New Member

    Hi, I also I have a Samsung mini Galaxy, but my problem is wifi, I have this computer for two days, and yesterday I worked the wifi connection in my home, but now nothing, I write the key and leaves,''getting direction IP'', then remembering, until it finally comes out that wifi is disabled and is protected by WPA/WPA2 PSK ... I could not connect and I've tried everything!
  20. techlearn

    techlearn Well-Known Member

    Even i have faced same problem, when i went to samsung service centre, they said turn on your WiFi when it is rage, it works...haven't faced wifi connection error again :D
  21. johnnyflex

    johnnyflex Member


    this works for me
  22. karun_jain

    karun_jain New Member

  23. Gew

    Gew Active Member

    Thanks for your input guys. I own a GT-5660 (Galaxy Gio) which got Wi-fi "frozen" this way a couple of hours ago. Thing is, just the other day Kies let me upgrade to Android v2.3.3 (Gingerbread). So, in my case, the issue is not related to Froyo. I'm also going for a steady uptime, so I really wished for a solution which did not include me having to reboot my device. This thread gave me great expectations, when I read about the *#*#526#*#* trick. I ran the code in the dialer. However, I got Neat trick. However, I got
  24. babakslt

    babakslt New Member

    i have the same problem, i just bought my galaxy gio with android 2.2 yesterday!
    when i typed the *#*#526#*#* in dial-er the wlantest engineering mode starts but it was failed on loading the driver.
    what can i do? :(
    i enabled "Use packet data" so my cell can connect to web by mobile network but still cant load the driver.
  25. Zoom123

    Zoom123 Member

    The WiFi on my Mini didn't work when I bought it. I changed my WiFi router from AES encryption to TKIP and this seems to solve the issue.

Share This Page