WiFi Error in Android 2.2 / Froyo / Samsung Galaxy MiniSupport

Last Updated:

  1. m.yusuf

    m.yusuf New Member

    I recently bought galaxi mini and i had the same problem, wifi and bluetooth wont work after a few times of switching wifi on and off and i have to restart to solve it .fortunately ,problem solved out by just typing *#*#526#*#* just like our friend nonstopnate said ,thanks :) .

  2. lucky262

    lucky262 New Member

    I also face the same problem of "Wifi" displaying error.
    After i follow some advice from the forumers to switch my device (Mini) Off and On again, it works back.........

    This phone is so fragile.....phew
  3. alainsch

    alainsch New Member

    I had the same problem with my wife's Galaxy mini. A few weeks ago, my router was broken and I had to switch back to my old router. Suddenly, all wifi troubles with the galaxy mini where gone.

    My broken router got replaced and when I switched back to the new router, the troubles where back...

    Seems to be a problem with WPA2. My router (D-Link DIR652) supports auto WPA/WP2 and that causes the problem with the galaxy. I changed the config in the router to only support WPA and everything on the galaxy is working fine...

    I have a Galaxy I-9000 and that worked just fine with wpa/wpa2...
  4. Android Baja

    Android Baja New Member

    Hello i have a galaxy mini and this is my problem. When i try to connect to my wifi network it says obtaining IP adress a few times then it says remembered. When i click connect it says network out of range. I had to go to my computer and set to static ip but that dindt work long. IT worked 5 days then the same error came up. Please Help. This really annoying because my Fathers Nokia e52 connects without a problem every time.
  5. cyrilgeorge2

    cyrilgeorge2 New Member

    *#*#526#*#* did the trick !!

    Thank you !!
    jonathankpeter likes this.
  6. mijie la

    mijie la Member

    omg.. its still not working with me... When i try to connect to my wifi network it says obtaining IP adress a few times then it says remembered. When i click connect it says network out of range. help me plzzzzzzzzzzzzzzz
  7. Pravision

    Pravision New Member

    Hi, Tried this on my Samsung Galaxy Ace, it worked as in it did give me a message that said:
    WlanTest Engineering Mode

    Driver loading successful

    After that the WiFi did startup alright.. but it is showing my WiFi network as "Not in range, ...." whereas here I am sitting with my laptop connecting to the same router which is also right beside the phone!

    Any solutions for this one?
  8. armanke13

    armanke13 Member

    I have 3000+ memos in built-in Galaxy Mini Notes, does resetting destroy them?

  9. yagya

    yagya Well-Known Member

    I think it does destory them, resetting changes back to the state when you just bought the phone.... It delets all settings, so probably it will delete them to ... Sync them with Kies to the PC and then format your phone...:)
    armanke13 likes this.
  10. armanke13

    armanke13 Member

    I've tried to sync them tens of time, but it doesn't work.. :( it says sync success once but I think it false notification since I don't see them in Outlook..

    Also, I've rooted the phone, it means the warranty is voided. I plan to restore the ROM after I get a way to backup my memos..
  11. yagya

    yagya Well-Known Member

    Don't be sad.... You can always use alternatives if one fails...
    Try to use Android Wifi manager from mobile action (uses wifi to communicate betn pc and mobile) It requires you to download android sync manger app on your phone...
    Or use Mobile go application... You can also use Dropbox (cloud storage, you get 2 gb free. It also requires you to download an app for managing files on your phone...)
    :):) Try them one after the other (though all work) and see which meets your needs the best...
    armanke13 likes this.
  12. captinbiglegs

    captinbiglegs New Member

    i had same problem with my mini got it to work on my sky router by changeing
    securaity options

    in sky broadband router

    from WPA/WPA2 mixed mode
    to WEP (Wired Equivalent Privacy)

    hope this helps
    armanke13 likes this.
  13. MatThePhat

    MatThePhat New Member

  14. fabricioph

    fabricioph Member

    Same problem(wifi and blutooth wont turn on at all)

    I bought my Samsung galaxy Ace 3 days ago and wifi wont turn on unless I restart my phone U_U Its disgusting, It hapends to me twice!!! with a new phone!!! Samsung must be kidding
  15. fabricioph

    fabricioph Member

    I went to the shop and they give me a new phone
  16. Chris Jackson

    Chris Jackson New Member

    I seem to be having the exact same problem as a lot of people n here, but I'll add my voice to the chorus of complaint...

    Just got a brand-new Samsung Galaxy Mini s5570 running on Android 2.2 Froyo, and every time I attempt to connect to my home Wi-Fi network, it immediately disconnects.

    I've tried removing the battery, restarting the Wi-fi (on the phone and the router itself), restore factory settings, and using the engineering mode fix on *#*#526#*#*. So far nothing has fixed the problem, and using the 526 fix did nothing but make every network appear as 'out of range'.
  17. bravokilo

    bravokilo New Member

    Its same with me, got everythings done but nothing works.
  18. manjalara85

    manjalara85 New Member

    i'm facing same problem....already dial *#*#256#*#* but my wifi network appear scanning only.sorry if my english worse.
  19. digi23

    digi23 Active Member

    Try giving manual IP and gateways in advance settings for your mobile while using home router which assign IP using DHCP method.
  20. NeroI

    NeroI New Member


    I have the same problem, I try to connect to wifi and it stays on "getting IP" for a while and then just kinda gives up.

    Following what I found here I set up a static IP, did the 526 thing and rebooted like a million times.

    It connected for like a minute but in a weird way, it said it was connected, the app manager said the app market [I use it to check if it's loading right] was downloading, but it didnt really load, nothing came up on the screen and youtube did the same thing.

    So I disconnected just to connect again and see if it worked but now it wont even show my network!

    Help me D: I don't want to have bought an expensive phone for the internet not to work TwT
    dvijayananth likes this.
  21. jamilhisham

    jamilhisham Member

    hi, i having wifi problem also... my wireless modem use FIX IP... can connected but when open browser cant surf? why..... anybody can resolve this
  22. zheiwren

    zheiwren Active Member

    have these problems to before..
    samsung said that it was a normal problem on froyo 2.2.1
    so i decided to flash my firmware to gingerbread 2.3.4

    then my wifi problem is gone.

    just to check if the problem was the firmware.

    i flash my galaxy mini again to froyo and the wifi problem came back.

    so guys if you want to get rid of it.

    try to upgrade to gingerbread

    this would be helpful.
    just follow her steps.

    EdendroidChannel's Channel - YouTube
  23. a126

    a126 New Member

    that also happened to me a couple of times try upgrading it to android 2.3.4. never happens and some games dosent lag like angry birds :)
  24. dotchex

    dotchex New Member

    I upgraded to 2.3.5 WKS2 and i still get the wifi error
    When i try to type in *#*#526#*#* the wifi network says it is not in range after driver loading is sucessful.
    I have to restart my whole phone to make wifi to work, only to have an error a couple minutes later.
    I have tried so many things such as factory reset, clear cache, format sd card, changing firmware and i still get this error
  25. onerob

    onerob New Member

    [UPDATE] More testing has shown that this fix has to be re-applied whenever you go away from the wireless connection and then come back. So, not much of a fix at all. Now trying the code mentioned above *#*#526#*#*

    I bought a Mini last week and had some similar troubles with wi-fi. This is what fixed it for me (so far): Try logging into your router and changing the 'Wireless Channel' setting

Share This Page