WiFi fails with bad mobile signalSupport


Last Updated:

  1. DaveyDaveDave

    DaveyDaveDave New Member

    Hi,

    I've recently changed two things on my phone, and my wifi is behaving oddly - perhaps someone can shed some light?

    The changes are 1 - moving house and 2 - updating to 2.1 from 1.5 on my G2.

    My new flat has shockingly bad phone reception, the only place to reliably make calls is standing by a window, and I have various areas dotted around where I can put my phone for a data connection, anywhere else, and I have no mobile signal.

    I was hoping that would no longer be a problem today, having had my internet connection finally set up. However, it seems that when the phone loses its mobile data connection, it also kills off its WiFi connection, or something. If I have a decent mobile data signal (according to the number of bars displayed), with WiFi turned on, I have no problem connecting to the internet or my local network, but then if my mobile connection drops, so does my WiFi connection - web pages fail to load, and apps like GMote, using the local network fail too. Things like rebooting or cycling the WiFi on/off seems to make a difference, but it's not consistent enough to be sure.

    Any thoughts?

    Advertisement
  2. shotgunfool

    shotgunfool Well-Known Member

    I believe i have the same issue as you, my router is now currently about 4 years old, my 3 computers all running win7 are using it without any problems, so i know its definatly not the router, My Dads iPhone works perfectly with it, but me using my Hero, on Custom 2.2 Rom, It just doesnt connect. Not a clue why or how to fix, iv had this since i got my phone back on release.
  3. nellisere

    nellisere Well-Known Member

    it still could be the router, i have a htc hero, 2.1 stock, and a zoom x6, the zoom work fine with everything apart from my hero, so the router may be fine, but the wifi chipset in the phone doesnt like a few routers, you may have one of these routers

Share This Page