Support Wifi help/discussion


  1. SMALBA

    SMALBA Well-Known Member

    Wow I have had two weird issues with this phone already. Okay So everytime I connect to my home network with my htc one, and start browsing it all the sudden kicks everybody on my home network off the internet including me on the htc one. My router will then let everyone back on to the network and I can stay connected with my HTC one but the instant I start browsing or using any sort of data on the One it will kick everyone off again. I mean from my pc to my smart tv to my wifes phone, everyone gets kicked off like the router is resetting or something.

    Is this a known issue? Is there some setting on the phone that can help?

    Advertisement
  2. marctronixx

    marctronixx Moderator Moderator

    some questions:

    what band are you using? 2.4? 5?

    what encryption?

    do you have the phone set to "best wifi performance"?

    is the wifi preference set to "AUTO" or one specific band?

    what channel are you on?

    What router? Let me guess, netgear?
  3. SMALBA

    SMALBA Well-Known Member

    I am using D-Link router, on 2.4 band, WPA encryption, best wifi performance = not on, wifi is set to 2.4 on phone, and the router is on auto channel.
  4. marctronixx

    marctronixx Moderator Moderator

    def. turn on best wifi performance.

    can you test on 5ghz or does your router not have that freq?

    use wifi analyzer. its in the store, or any app that lets you sniff out AP channels to find the least crowded router channel. 2.4 shares a lot with cordless phones, microwaves, and other electronics.

    make sure your router is up to date. are you using 3rd party router software or is it stock router software?

    this phone does very well on 5ghz, but for now, turn on best wifi, sniff out a better channel (instead of just AUTO) and lock the router to it. reboot the sucker and reboot your wifi devices.

    pain in the butt i know but no pain no gain.. ;)
    KOLIO likes this.
  5. SMALBA

    SMALBA Well-Known Member

    I updated the router to the latest firmware but that didnt seem to help. My router does not have the 5ghz option. It keeps kicking me off the router after like 3 minutes of activity. What else can I do? Should I try another router? My galaxy s3 had no problems with this router though?
  6. marctronixx

    marctronixx Moderator Moderator

    could be issues with the firmware in the phone. its a new product and there are bugs for sure.

    i use a cisco e4200 and run mixed mode. the one uses 5ghz here and at the job it uses 2.4. no issues at all at either site. i am stock and not rooted.

    not sure if a new router would help but i can assure you i have no issues with my setup. i have several mixed mode devices and they are all playing nicely.

    i have seen a post or two about this issue you are seeing. its the weekend, so give it a day or so when others log on and check this space. you may have some others who have the issue.

    although i ALWAYS run "best wifi performance", some who initially did not run this setting ticked and then DID noticed things improved.

    also make sure fastboot is NOT ticked....

    EDIT: so i dont use any battery saver modes, do you by chance have your phone set to kill wifi at idle or sleep? this may be confusing the router if you have the phone set to shut off wifi when idle, etc..
    KOLIO likes this.
  7. sikclown

    sikclown Well-Known Member

    Assign every device on your network an IP Address. Anytime I have run into this kind of behavior is was a DHCP issue. In your router manual the steps to do this would probably be under Reserving IP Addresses. This way every device will be assigned the same IP Address every time rather than DHCP cycling through the available IP's every time something connects. This may fix the issue.
    KOLIO and marctronixx like this.
  8. marctronixx

    marctronixx Moderator Moderator

    great idea sik,

    or to just make it easy, give the htc one a static ip first before doing this to all of your devices... :)
  9. porthos7

    porthos7 Well-Known Member

    Uh... how do you do that?
  10. LordTumnas

    LordTumnas New Member

    Hi, is anyone else having 2.4GHZ wifi reception issues when your hand is blocking the top right corner of the phone?
    My internet/wireless isnt the greatest but, when my hand isnt there i can load HD youtube videos, and when its not, i cant...
  11. ScandaLeX

    ScandaLeX Wasn't Me Guide

    Sometimes the easiest fix is to unplug the router itself for a few seconds and plug it back in.
  12. LordTumnas

    LordTumnas New Member

    Thanks for the tips guys, i read all the posts and have since turned on best wifi and disabled power saver and fastboot, thanks!
    marctronixx likes this.
  13. bboonstra

    bboonstra New Member

    Hi,

    It's my first time here and I want to ask a question about my new HTC one. My brother was fiddling with it and said I should use data all the time and said he was turning off my wifi which was fine with me until I started wanting to use HTC share which seems to require wifi. Now I can't seem to turn my wifi back on. i just says error and no matter what I try in the advanced settings it doesn't seem to turn it on.

    Please help or direct me to some help...
    :(
  14. James_Bond

    James_Bond Well-Known Member

    So what happens when you go and try to turn the Wi-Fi back on? Does it just turn it right back off? Does it say that the Wi-Fi is on but you just have no internet? I might need a few more details to get to the actual issue and then a solution. If you are having issues connecting to Wi-Fi then check out Can
  15. bboonstra

    bboonstra New Member

    When I go to my settings to try turn on my wifi it won't flip the switch from off to on and it says error. Then when I click right on the wifi words I go to another pane that says To see available networks turn wifi on. So I try again here and it says error again. So I go into settings here and then into advanced because it is the only option I can choose. I can't really do much here either. It says both the MAC and IP addresses are unavailable. The article you sent talked about getting addresses and passwords right but I don't know where to do that or if I'm just not being asked for that. I am not in airplane mode but I have tried turning it on and off to see if it would kickstart anything. It won't work at home or at my office where connections work fine. I don't know how to a reset properly and I'm a little afraid I will do further damage. What are your thoughts?

    B
  16. James_Bond

    James_Bond Well-Known Member

    Yeah it
  17. Antmf

    Antmf Well-Known Member

    I have wifi active and connect to my wifi networks no problem, but when I am outside and I am not in range of my wifi networks my phone wont connect to data with wifi active. If there is a wifi in the area that my phone picks up and I dont have the password for it I have to shut my wifi off before I can connect using data. Shouldn't the phone do that automatically? Please let me know what to do. Thanks...
  18. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Hello Antmf.

    Just uncheck "notify me" in the main menu's wifi settings area. It'll still offer wifi connectivity when in range, but data will take over (as long as you have a data agreement with a carrier ;)) when no wifi network is selected by you.
    KOLIO and marctronixx like this.
  19. Antmf

    Antmf Well-Known Member


    It is unchecked. Allow me to explain more in detail. When not in wifi area my data works fine. But say I am in a cable wifi area like comcast or opt online etc. It shows up as though I am connected to those networks but need a password etc. to log in and due to the fact I don't access the cable wifi. I can't access the internet al all. It seems like it is trying to use wifi and data won't take over because of the cable wifi in area. Then I have to turn wifi off completely to use data. I would think the phone should do that itself. PLease let me know if there is anything else I could do. Thanks...
    marctronixx likes this.
  20. indybug

    indybug New Member

    At work we can connect our personal phones, ipads and laptops to the secure wifi network connection and surf the web on our breaks/lunch. Our office is very small and family run - this is not some big corporation. Two of my co-workers have had issues with the "I.T." guys making comments about pictures on their iphone and ipad - pictures my co-workers have never shown the I.T. guys. It freaks me out to think these guys are gaining access to our personal information. My questions are: 1. Is it possible for these guys to access info on our smartphones or iphones when we are connected to the wifi network? and 2. Is there an app that we can install on either Android (I have a HTC One) or iphones that will keep them out? It's not like we have anything to hide, it is just the principle of it all. It is not their jobs to snoop thru our phones.
  21. Tlicious1020

    Tlicious1020 Well-Known Member

    I am not an IT expert. But everyone is always being told not to connect to unknown or strange WiFi networks. Why? Because anyone can set one up and gain access to any data coming across it or any data on your device. If you are at work, your IT guys can look at whatever information they want on your device probably due to company policy.You probably need to look into company policy or ask the IT personnel directly what rules govnern the company's WiFi network. If you don't want them looking on your phone, don't utilize their network. It's as simple as that in my opinion.

    As a member in the Air Force, we have some people who don't access their bank or credit card accounts from government computers. They don't want our comm (short for communications, otherwise IT) personnel to see their passwords and sensitive information. We can be monitored at any time by comm because of utilizing a government computer while at work.
  22. TinCanFury

    TinCanFury Active Member

    I too am having issues with my WiFi, I can't connect to anything for more than a few minutes. This is with my two WiFi networks at home and my WiFi network at work.

    All three networks worked fine on my Cyanogenmod Droid X that I had prior to getting this phone.

    At home, where it is an option, I even tried a non-DHCP, Static connection, and still no go.

    I have tried combinations of all the Advanced settings, and currently I have "Sleep" set to Always on, "Optimization" off, "Best" On, and have tried forcing to both 5ghz and 2.4ghz.

    Once I connect and get kicked off, the only way to reconnect, for the brief period of time I am connected, is to turn off WiFi and then to turn it back on. which buys me another few minutes of connectivity.

    Quite a pain, thankfully I have grandfathered unlimited plan, but I still feel like this should not be happening...

    I read about this being an issue with other HTC phones, and things like wiping the cache through the recovery menu (some even so far as to wipe the entire phone) got things to work. I've only once been able to get through the recovery menu into the Wipe Cache menu, which is another annoyance only partially related to this topic.
    Regardless, the one wipe I attempted did not do me anything.
  23. kindakooky

    kindakooky Member

    My unrooted HTC One keeps forgetting my home wi-fi password. Once i put the password in again it connects and works fine, but it's getting very annoying having to put the password in every time. What's going on?
  24. Vance

    Vance Well-Known Member

    I am really getting annoyed at the wifi discovery notification popping up all the time, I just can't seem to get this turned off. I can always swipe it away, but it is back very soon. If I tap the notification, it takes me to an Android services app which won't disable (not sure if would want to anyway) and the checkbox for turning off notifications is greyed out so I can't uncheck it. In the wifi settings, under Advanced, the "Notify me" is already unchecked and there is no Network Notification checkbox there (it is only in the Android services, greyed out). There has to be some way to get rid of this thing without rooting.

    EDIT: OK, I just got off the phone with HTC and they said that it can't be turned off on the Verizon HTC One. They said Verizon has opted out of that turn off feature since they want you to use wifi as much as possible to stay off of their network. Great.
    KOLIO and marctronixx like this.
  25. Hadron

    Hadron Well-Known Member

    I only know VZW by reputation, but if any carrier would do that it would be them :(

Share This Page