WiFi issues disconnects etc (fixed for me)Tips


Last Updated: 2014-09-16 13:28:35
  1. Arkangil

    Arkangil New Member

    Awesome. Thanks. I will try this fix out.

    Advertisement
  2. dwaindibbley65

    dwaindibbley65 New Member

    Aerosigns tip worked for me, but I had to re-enter the fix every time the phone rebooted, I just got an OTA upgrade and was hopeful this bug would be fixed, but nope! Its still there! damned annoying!
  3. techguy111

    techguy111 New Member

    Hi,

    I'm new to this forum and new to the Galaxy S3 LTE version for about a week now but not new to smartphones. I'm in Canada and on the Rogers LTE network.

    Having the exact same issues as Arkangil above so our phones are similar in behaviour. Basically my phone will connect successfully to my wifi network at home but will disconnect/reconnect frequently and sometimes fails to reconnect (with error failing authentication even though it hasn't changed) and have to force a reconnect by disabling WIFI and re-enablilng it.

    I have determined that wifi works fine as long as the phone is plugged into a power source, however when running from battery is when I see the problem. I have disabled the general power save and enabled the feature to keep wifi always enabled.

    I also already tried to use the procedure noted above in this thread to take phone into service mode and disable wifi power saving at the lower levels, however that procedure fails completely on my phone with the error message "UNKNOWN APPLICATION". Makes me wonder if it only works on a rooted phone or whether the LTE version of this phone differs much more than the international version of it.

    I'm hesitant to take the phone back as everything else on the phone works well and generally really like this phone and features it provides.

    Thanks.
  4. ouchmaster

    ouchmaster New Member

    Hi,
    I have the international version S3 and the wifi was working fine for 2 weeks then it suddenly stopped. It stays connected to the router but no internet. I tried connecting other devices to the router and they all work fine.
    I tried the *#0011# trick and it didnt work for me
    So i accessed the router settings and found something called DYNAMIC ROUTING which was switched off. So I turned it on et voila...wifi works again
    Hope this helps you
  5. coleoptera1

    coleoptera1 Member

    I posted something in another S3 wifi thread, but thought I'd post here too.

    My husband and I just received our 32GB s3's this weekend. My wifi has no issues. His is doing the same things as described above. We did follow the steps for the *#0011# and that works temporarily but is not a permanent fix.

    Because my s3 is working fine, we know it's NOT the router.

    Has anyone come up with any other ideas? We'll be calling Verizon tonight.
  6. Nicholas68

    Nicholas68 Member

    I'm also having wifi problems, First off, when I turn off power saving mode it turns back on after I turn the phone off or restart it, is there a way to keep it off?

    Now our household has two networks, both coming from the same router, one is what we connect all the household devices to so they can talk to each other, and the other is the one we give to guest. My father manages them and the settings but I assume the home one has some upped security.

    When I'm connected to home I keep dropping and reconnecting maybe 10-15 times a day/night. Which is annoying. But when I'm on the guest one I can go weeks and not have a single problem. Just can't talk to my computer over wifi. So does anyone have suggestions? I assume it has to be a settings issue and nothing with the phone?

    Thanks
  7. butters123

    butters123 New Member

    Hello,
    i now have a wifi problem,
    Ive had the phone 3 days, the first two days the wifi was great, but today it is just not working.
    All other laptops and pcs and phones work fine with wifi just this s3 is not.

    The first two days when i turned wifi on - it connected automatically (after the initial connection asking for the password) and every thing was fine, but today when i turn wifi on no auto connection to the hub and no connection at all.
    When i click wifi- the list of local wifi connection points come available, so i click on mine (which is repeated twice - one has "wps available" under it) and it says connecting for a few seconds and then it just returns to scanning, it will not connect and it will just keep scanning over and over and over again till wifi is turned off, Also under my wifi point name it says "Saved".

    I press forgot network (on both of my repeated networks) and they just reappear.

    Any help would be great

    Thankyou!
  8. jaymf

    jaymf Well-Known Member

    Bump to get more input to the this thread.

    I tried using the *#0011# method when my wifi was repeatedly disconnecting and it did keep me connected to the router, but it also drained my battery, going from ~40% to 15% over the course of 5 hours without any activity by me on the phone. It seemed that the orange download arrow under wifi was constantly lit, so I'm not sure how the power save mode made it constantly transmit data (I don't even know what it was downloading). This would be more of a concern to me than having to re-toggle the power save mode with every restart, although that would be annoying too.

    Has anyone else who turned off power save mode noticed a significant (like my 25% drain over 5 hours without any activity) power drain? :confused:
  9. EarlyMon

    EarlyMon The PearlyMon Moderator

    Merged your post over here so that you may consider the tip in this thread.

    A few other good things to know (wish my neighbors did, LoL!) -

    - don't use the default network name that came with your router, be creative (and keep it short, no spaces)

    - do try Wifi Analyzer, free in the Store, to see if your wifi network is on the same channel as everyone elses - because that may work, but it's not the right way

    Both of the above can be set in your router.

    And in the event of phone once working and then not for no reason - try a router reset. Many ills have been cured with that one simple trick.

    Welcome to the forums! :)
  10. vipercwf

    vipercwf Active Member

    I've had my S3 for 4 days now. I didn't have this issue the first 2 days, but the last 2 I have. My home wifi is constantly dropping the signal, disconnecting, scanning and then reconnecting...over and over, as little as every 30 seconds it seems. I have other devices (the computer im using right now) that do not lose the wifi signal and do not have this issue. Any suggestions?

    I really don't know whats going on and I could be way off here but im wondering if its not some kind of compatibility with the settings on the router, I would guess the wifi radio in phone is different than the laptop and that's why the laptop isn't having the issue(?)...The only reason I think that is im coming from a Droid X and I had a similar issue with that phone on my home wifi (no issues on other wifi's, like work - just at home). I think my DX couldn't even find the signal at times though, even if I was right next to the router. Anyways, I don't know enough about router settings, and maybe im way off in that thought...any suggestions on where to start?

    Appreciate it!
  11. BigCiX

    BigCiX Well-Known Member

    This is a common know issue with android devices. Try wifi fixer from the Google play store. That worked for me.
  12. vipercwf

    vipercwf Active Member

    Thanks for the quick reply...so far so good. Appreciate it!
  13. vipercwf

    vipercwf Active Member

    Dang..doing it again..literally every 20 - 30 seconds...causing me to not be able to open web pages etc as its constantly switching between WiFi 3g and losing data in between
  14. EarlyMon

    EarlyMon The PearlyMon Moderator

    Moved your posts here, perhaps info in this thread can help.
  15. ldivinag

    ldivinag Well-Known Member

    anyone have issues with just the wifi DOWNLOAD speed?

    mine floats around 500-900kbps... upload though, it normal. 6-8+Mpbs.
  16. johnpeat

    johnpeat Active Member

    Came across this thread when doing some digging so I'll add my 10p.

    UK (Orange) International S3 here - can connect and use WiFi OK but there are 2 slightly irritating issues.

    1 - the phone will sometimes drop WiFi and takes a while to reconnect when you switch it on (resulting in the lockscreen being unresponsive and then going black instead of letting you in to use the phone)

    2 - the phone sometimes takes a LONG time to scan for WiFi networks - not a problem once the ones you use most are 'remembered' but not ideal.

    In both cases I'm pretty sure the issue is the WiFi going into powersave mode - which is annoying as the option to keep the WiFi alive, even when the phone is on standby, is selected.

    I'm going to try a Wifi Fixer/Keep-Alive tool to see if that helps any - but clearly a better fix is required ASAP from Samsung.
  17. EDTIVA

    EDTIVA Active Member

    When my phone sleeps for a duration of time, upon wakeup my Wi-Fi shows it is still connected but zero data can be transfered. E-mail/playstore/browers can not connect. I have to turn wifi off and on again for it to re-establish. This causes my email pushes not to come through. I've played with some router settings, but have not forced the phone onto 2.4 or 5ghz. WMM is enabled as well. I have now just enabled the wifi sleep trick in the service menu, and I had the keep wifi on during sleep already on in the regular menu. Now my screen won't time out after the service menu trick. I called for a handset replacement and got the speech about clearing cookies and wipe phone data. Sigh... So I have to remember to turn this on every reboot and make sure to turn my screen off each time. Regret is sinking in, as I told my self never again after a Behold II. T-mobile please get a good HTC phone, I think the S3 is going back!



    Carrier: T-mobile
    Memory Capacity: 16GB Blue
    Rooted? No
    Network Type: Dual radio 2.4GHz(b/g/n) and 5GHz(a/n)
    Network Security Type: WPA2-PSK(AES) single SSID
    Security Encryption: Shared Key
    Are there multiple networks near you? Some others but I'm on uncrowded channels
    Linksys E3000 with tomato varient
  18. EDTIVA

    EDTIVA Active Member

    Possible Fix

    My unit is presenting the connected wifi after sleep, with no data actually working. I have a dual radio 2.4ghz and 5ghz router. I split the SSID's for the bands so each is unique. The problem has yet to occur again. Note I only have entered one of the SSIDs at a time, but neither have presented an issue. Just another idea for you all to try.
  19. Travisimo

    Travisimo Well-Known Member

    This is exactly the issue I am experiencing with my VZW GS3 connected to my home Apple Airport Extreme. None of my previous phones (iOS and Android) had this problem, but the S3 is having it intermittently. After not using my phone for a while, I'll turn the screen on and have no data connection. However, it still shows it is connected to my WIFI, but no data will go through. If I go into WIFI settings and try to re-connect, it will not do it. Simply turning off WIFI and turning it back on corrects the problem immediately (it will re-connect to my WIFI automatically after doing this). I mostly notice this after checking my phone first thing in the morning after waking up. If I don't have my phone plugged into the wall charger, my phone will lose a lot more battery because it is on the 4G network instead of WIFI (even though it shows I'm still on WIFI).

    So far, it hasn't been a major issue for me, but definitely one that needs to be addressed.
  20. Gundato

    Gundato New Member

    Are there any special steps that are required to enable service mode?

    I have just been typing #0011# and then hitting the green call button. It tries, says "unable to process request" and boots me back to the main screen. Am I missing something?

    T-Mobile Samsung Galaxy S3

    [edit] Figured it out. Apparently that wasn't "#0011#" and was *#0011#, as in "type * first"[/edit]
  21. dervari

    dervari Well-Known Member

    Nope. 15.15 down, 10.25 up on my wifi.
  22. crboone

    crboone Well-Known Member

    Thx JayC -- this is the impression I've had as well. I had the same wi-fi issue with my DX, but my BB from several years ago and a Palm Pixi+ did not (well, not nearly as often anyway). I was a little surprised/disappointed that the S3 would also have this problem, but if it's something with Android itself it might explain it. Just surprised it hasn't been rectified by now. Otherwise the phone works pretty well in other respects where I had issues with the DX.

    Also, sometimes when my wi-fi stops working the 4G doesn't kick in, either. I usually have to reboot the phone. This is bad for me because I receive emergency email alerts from my work 24/7, which is why I notice it. I'll try the wifi fixer and see if that helps. (I do not have Power Save mode turned on).
  23. EDTIVA

    EDTIVA Active Member

    Try the SSID split I posted, let me know your results. So far it has been good here.


    Travisimo likes this.
  24. Travisimo

    Travisimo Well-Known Member

    Done. I will report back with the results later.
  25. rafian

    rafian Active Member

    *#0011# thingy must be done after every reboot. That's what I figured after a reboot of my phone.

Share This Page