Wifi Issues with school AP's - connects but no internetSupport


  1. sona1111

    sona1111 New Member

    Hello people of android forums! A small bit about myself: I am a programmer and heavy user of linux, both server and client versions. I consider myself very tech savvy with desktops and servers, but I am just now getting used to smartphones. I had been holding out a very long time to buy a phone for myself but people had been bugging me a lot lately so I finally broke down and got my first smartphone, the Nexus 5. It is unlocked with no sim card, which should not be a problem for me because I am only ever at home or school anyway. :)

    Anyway, I was having awesome fun setting up the phone at my home wifi, as well as at a friends house. Next I went to school and registered my MAC (they use mac filtering), and it was operational shortly after. Worked fine throughout that day. The next day It still connected correctly, but no data could be had from the internet. (chrome, email, any app, whatever) Network manager claimed that I had full bars. (of wifi) The school network staff claim it is a "known issue with androids", it "never happens with laptops, iphones, or any other type of device". Sadly, I can confirm this after talking to many people, and I also never had any issues connecting my ubuntu thinkpad or asus windows laptop. The network staff also suggested trying "wifi fixer", which I have (both of the top two apps which show up for this search in the play store). No success.

    Interestingly, I have managed to reluctantly revive the wifi functionality by messing around with the static ip and DNS settings for the connection, but it usually takes 10 minutes or so of messing around and there is no rhyme or reason to it, likely because the school network is not designed to accept static-ips. Strangely, after getting DHCP I notice that the "gateway" and "ip address" do not have the same third number. ( I am no network expert so this might be normal) for example the IP might be 192.168.16.134 while the gateway is 192.168.18.1 when I revive the wifi, it is usually when I return both of these to the same number.

    Well, that is all of the info I can think of to solve this. tl;dr: wifi connects but no internet. any suggestions anyone has would be much appreciated.

    Thanks for reading.

    Advertisement
    :
  2. Rukbat

    Rukbat Well-Known Member

    They could set the DHCP and gateway subnets differently, but why? It may be a known problem for your school network that Androids can't get internet (a limited connection), but it's a problem with the way the network is set up, not with Androids. Just go to a McDonalds, a Starbucks or anywhere else that has open wifi and you'll see an Android phone connecting with no problem. (I was at the VA today, with an open authenticated wifi network, and aside from having to open a browser, it connected.) The only wifi I haven't been able to connect to with an Android is one I don't know the password to. (I even let my drug store know that their network, which is supposed to be secure, is available to anyone, and showed them that I was connected to it. And it's strong enough to access from the parking lot next door.)

    So ... what can you do about it? Unless you have a way of making the network administrator more intelligent, not much. He has the network set up wrong, in some way.
  3. sona1111

    sona1111 New Member

    Hello! good day to you and thank you for the reply.

    I understand that the issue is with the school and not other places, but I have a few reasons I would still like to get my hands dirty and try to fix this:

    -I am going to be stuck there for a while, not much chance of that changing.
    -Other devices, both my own and friends, can connect fine and have been connecting fine for over a year without any of these issues.

    This leads me to believe that, though I don't know how to put it in technical terms, if I could allow android to "act like" a laptop, (either in the hardware level or something higher level), then the problem could be solved. The change does not 100% need to come from the network staff if other people can connect correctly. Also, the fact that it can indeed connect fine, but then does not get internet leads me to believe that it can be fixed at the software level.

    Thanks again for reading. I hope I can get some luck with this today.
  4. Hook

    Hook Ever since DU... ;-) VIP Member

  5. jj14x

    jj14x Guides Guide

    If you are able to connect to the network, but are unable to access the internet, it is likely because your gateway (and possibly DNS) settings are inaccurate.

    Can you ask your network admin for the Gateway IP, and a static IP that you can use? Once you get that information, set up the WiFi connection with that static IP (advanced options when setting up WiFi connection). You can use Google's DNS servers 8.8.8.8 & 8.8.4.4


    Edit: on your PC that is able to connect ok, run IPCONFIG /all in a command prompt window and see what the IP/Gateway address are
  6. sona1111

    sona1111 New Member

    Thanks once again for the follow ups.

    I do not believe that the 5ghz problem is that which is affecting me. The article says that the phone can not connect at all, which is not quite the case for me. An in any case my phone works in the same manner by switching to 2.4 only mode.

    In case it is not understood, this is not a small family owned building or anything, it is a college wireless network with many access points and many students. Not only would giving me a static ip be very impractical when so many others need to use the network, but I am unsure if all of the wireless sub-nets would respond to my static ip in the same way, possibly forcing me to manually change settings as I walk around. All in all I feel as if there should be something I could do without having to get special permissions from the network staff, though I don't have any problems talking to them if you had any specific questions I should ask.

    Thank you very much and have an awesome night.
  7. Hook

    Hook Ever since DU... ;-) VIP Member

    I would try working it out with the network people. Clearly it is some kind of interaction since it can't be entirely the phone (most Nexus 5s connect fine to wifi networks) and it can't be the network (other devices connect fine to the network). Solving this may help them with other android devices used on campus and you give them an ideal smart user to trouble shoot with. Maybe you solve it or not, but I think it is worth the effort.

    The one other thing you can do is to tell Google your Nexus 5 doesn't connect and have them issue a replacement. This will eliminate (or at least make less likely) that the problem is an actually defective wifi radio.
  8. jj14x

    jj14x Guides Guide

    Assigning a static IP is really not impractical. Even at the workcenter that I oversee, with over 3000 computers (and likely a higher number of tablets/mobile phones, printers and other internet enabled devices, getting a static IP is really not that complicated. Most large networks would be broken out into multiple subnets/vlans anyway, so getting a static IP from the reserved range shouldn't be that hard. The idea was just to use this to debug the problem, and to see if that would at least temporarily resolve the issue, which would then lead us to the root problem in the network.
    (and going around the campus with a static IP shouldn't cause any issue different than going around with an IP assigned by the DHCP server anyway)

    Having said that, i do realize that some network admins just don't want to make any special accommodations for anybody. So, don't worry about it if they don't permit that. Unfortunately, I don't think there is a straightforward way of changing your phone's network's gateway IP without setting a static IP.

    When I hear that only the "Android" devices have this networking issue, it just doesn't make sense. That's all :)

    Assuming you are able to at least access resources on the LAN (try to access another device that is connected to the same network), I suspect that it is a problem with the way the networking components/settings are set up in your school.

    It sounds like your phone's networking components are working fine (given that you are able to connect to other networks using DHCP). The network adapter on your phone is just requesting the information (IP, subnet mask, gateway, DNS etc) from the DHCP server, and is using that. The school's DHCP server is (for some reason) unable to transfer data between your phone and the WAN. It can happen for a variety of reasons, none of which can easily be troubleshooted over this forum, with the limited information that the network admins will give you.


    P.S. The gateway and IP being on different IP ranges is normal. Your network admins just chose to stick with a class C network (and split it into multiple smaller networks with routers), rather than go to a Class B network with a large IP range. Lot of factors influence that decision.
    Because they chose to split into smaller networks, the WAN request/response now needs to traverse across multiple routers, which again isn't too hard, assuming it is set up right.

    Why is it apparently happening only to your device? I don't know. <started to type out the reasons that I know of that could cause this, and realized that it is a very long, incomplete list>. But it should be something that the network admins should be able to troubleshoot. When you are on the LAN, using your IP and your gateway settings, they should be able to figure out why your device can't access the WAN. If not, your school probably needs better networking support folks (sorry - not trying to be rude).
Loading...

Share This Page