Wifi Keeps Disabling and Router Definitely Not The Problem, HELP!Support

Last Updated:

  1. BDelSol

    BDelSol Member

    Okay, I have the LG Connect and my WiFi keeps disabling and re connecting almost every minute. It is definitely NOT my router because my husband has the LG Esteem, which is also the LG Optimus, and his WiFi NEVER disables, it runs smoothly and never disables. Only mine does. :confused: What could it be if there is no chance it is my router? Could it be some battery saving apps I have downloaded?

    I thank you for all of your help in advance! <3

  2. DroidFan83

    DroidFan83 Well-Known Member


    So is your husband's phone the LG Esteem or LG Optimus M?

    What is the model number of your wireless router (not making any assumptions, just want to make sure of some things)?

    Do you broadcast your wifi SSID (meaning can it be seen by phones and other devices before connecting to it)?

    Are you getting a reasonably strong signal when it drops?

    When does it usually drop? Is it only when trying to access the internet, when you turn your phone off, just random?
    BDelSol likes this.
  3. UKCatFan

    UKCatFan Well-Known Member

    I think that it actually is your router. It sounds exactly like when the router is on the pre-finalized Wireless N spec. If you can force the router to only use Wireless G and it then works, then it was the router.
  4. DroidFan83

    DroidFan83 Well-Known Member

    Definitely a possibility. We can confirm with the model number of the router whether it is actually a Draft N.
  5. BDelSol

    BDelSol Member

    My husband has the LG Esteem. I made a mistake. For some reason I thought they were the same phone just different providers.

    My wireless router is Belkin N300 Model F9K1002V2

    Yes it can be seen by other phones an devices. But can you explain the question a little bit more, I am no good at this. I'm a rookie. ;)

    I am getting excellent signal, drops for a 5 seconds and connects right back automatically.

    It actually drops signal at random times. Whether I'm on the internet or on apps, rhapsody or even just texting.

    And like I mentioned before, I just did a test and used my husband phone all day at home and it never did this not even once, and his signal was excellent.
    I removed some battery saving apps I was using but made no difference.

    Thank you for helping me! I appreciate it very much! <3
  6. UKCatFan

    UKCatFan Well-Known Member

    It looks like that router does have the Draft N. You will either have to force it to only use Wireless G or buy a new router.
  7. DroidFan83

    DroidFan83 Well-Known Member

    If you don't mind me asking, where did you find it listed as a draft n device? I haven't found that particular model listed as one (maybe you mixed up model numbers) and also an LG Esteem wouldn't likely work when the LG Connect doesn't since they are both using current wireless n standards. I suspect something else is going on. I can't say Belkin routers are the most dependable though.
  8. DroidFan83

    DroidFan83 Well-Known Member

    Has it ever worked on a wireless network without issues? If not then you might want to try some other wireless n network (maybe a friend or family's house) if you have access to one. I suspect either a software issue on your phone or possibly even a manufacturing defect with the wireless radio. If you know your wireless settings (security, etc) that would be good to confirm (no passwords needed).

    Kind of a long shot but with it being a Belkin have you tried unplugging the router and plugging it back in?
  9. UKCatFan

    UKCatFan Well-Known Member

    I Googled the model number and Draft N. I found multiple sites saying that it is. Just because both are LG phones does not mean that they will behave the same. I like the idea of finding someone with an official spec N router to see if it works. Heck, for that matter go buy one to try. Or, do like I said before and go into the router setup and force it to only use Wireless G. Every router has a different setup program, but that should be easy to do. If that works then Draft N was the problem. All simple tests like that should be done before taking the phone back.
  10. UKCatFan

    UKCatFan Well-Known Member

    I just looked again and cannot find the same pages I found last night. Pull the documentation out and see what it says. I also strongly suggest doing the test I described. Routers are so cheap now that they are practically a commodity item. Don't always count on everything being compatible with every one. Back when I first started with computers you had to manually set every port, com, etc. setting that was needed. Now the devices talk better and most of the time everything works just fine, but not always. I am beginning to think that this phone model is a troublemaker since I see so many people complaining about routers not working. FWIW, I have never had any problems with any D-link products I have ever owned. I have never had a Belkin, but a network guy at my company once told me to avoid them.

    Anyway, you have things you can try before going to Metro. They are always so difficult to deal with that I suggest trying everything you can first.
  11. DroidFan83

    DroidFan83 Well-Known Member

    ...beginning rant... I have been doing this kind of work since I was 12 (currently a "network guy") so I would appreciate the lack of a history lesson to validate your point. I am simply looking for facts and trying to keep assumptions out of it. I also did that same google search prior and while I did find many results if you look at them they are referring to a different Belkin model number being the draft N. She already said that she is a newbie with the wireless routers so asking her to enable wireless G may not be an option (just because it is easy for you and me doesn't mean it is easy for everyone). Also keep in mind that not everyone can go buy a new wireless router because they are "cheap" so that should not be the recommended solution unless you know for certain. The other cases I've found on this forum where it didn't work were all verified to be Belkin Pre-N devices which of course does not indicate a problem with the device itself.....end of my rant. Sorry, I had to get that out...

    I looked up the manual and it gave no indication the device is a draft N device (which Belkin always openly referred to as "Pre-N" in case you didn't know). I also found that the device looks to have come out within the past year (the manual for that model is copyright 2011 and no support or discussion of the particular model prior to late last year no matter how much I search). The 802.11N standard was completed in late 2009. I see nothing to support this being a non-standard 802.11N device unless you can find something to confirm this.

    BDelSol, I agree with UKCatFan that you should try either on someone else's wireless N router that was bought within the past year or so or change it to wireless G only (if you know how) to see if that helps. If those don't work then you may have gotten a faulty device, but be sure to test first. If those do work then there is something a little funky with your wireless router setup that doesn't agree with your device (which could be true with a Belkin). If you don't need wireless G speeds (if your Internet is less than 24Mbps and you don't stream HD video from local devices (I have a feeling your husband knows) then you may just want to look into changing it to wireless G and keep it that way to save a little money. If you do at some point decide to replace the wireless router, a few safe bet brands are Linksys/Cisco, D-Link and Buffalo.

    This topic is borderlining counter-productive, so I'll have to make this my last post here (just PM/personal message me if you need further assistance). Sorry.
    BDelSol likes this.
  12. UKCatFan

    UKCatFan Well-Known Member

    Begin rant... Chill out. end rant

    You gave me a good laugh with your intensity over this.
  13. airtioteclint

    airtioteclint Well-Known Member

    I might not be a network guy or a even a computer guy but if the router works for the esteem but not the connect then wouldn't this mean the problem is with the connect???
  14. UKCatFan

    UKCatFan Well-Known Member

    If it was another of the exact same device, then yes. There are numerous things that could be going on. It could even be that there is a bug in the Connect programming and no Connect will work with that particular router. There could be something up with that particular model router. Who knows. Testing is about the only thing that can be easily done. I personally avoid dealing with Metro until there is no other possible alternatives. Their customer service is awful.
  15. BDelSol

    BDelSol Member

    I am completely lost, sorry! lol You guys really know your stuff!

    Here are my questions:
    I will test my phone connection to another WiFi network, but can it be any public network, such as at Starbucks or something like that?

    What is Wireless G and Draft N?

    This is the link to the router I use: http://www.belkin.com/IWCatProductPage.process?Product_Id=543385
  16. UKCatFan

    UKCatFan Well-Known Member

    You can try a public option, but you probably have no way to find out what type connection it is. It is not likely going to be N though. It might not even be G.
  17. Dracconus

    Dracconus Well-Known Member

    I've listed a fix in the main forums... This'll explain, why, and how to fix it. If you need greater detail, then just ask :D
  18. BDelSol

    BDelSol Member

    Yes, Thanks You! Where can I find it?
  19. hYpHyPuRpLe

    hYpHyPuRpLe Well-Known Member

    I went to my Wi-Fi settings and I pressed menu and went into the Wi-Fi sub-setting. There's an option there that says "disable Wi-Fi when screen is off". Just disable that option.

    EDIT: Sorry I read the question wrong. Wrong answer, but will leave just in case someone finds it useful.
  20. Dracconus

    Dracconus Well-Known Member

  21. nps531

    nps531 Well-Known Member

    i messed with my routers settings and then did a default settings of the router and now i am having the same problem with my phone. it wont hold a wifi connection on the same router it use to have no problem holding before
  22. nps531

    nps531 Well-Known Member

    went to several wifi spots it also does it there. something wrong with the phone ;/
  23. Dracconus

    Dracconus Well-Known Member

    Wifi spots doesn't mean they were using a router that's compatible with YOUR phone. I've already stated what you need to do is go test routers for your individual phone. For mine, netgear worked, but only a "G" model. whereas the manager at the store I bought mine from..hers works on an N draft Linksys.
    These phones ****ing SUCK with wifi, you're just going to have to test it.
  24. nps531

    nps531 Well-Known Member

    yeah its just my router now couse i went to my dads house and it worked like it always does, along with everywhere else i went, and i do have a belkin. looks like im going to have to figure this out, i should of just left my router settings alone!@
  25. Dracconus

    Dracconus Well-Known Member


    Trying to get the mods to sticky this thread since it'll help like every freaking person that reads this section >.<
    Seem to be taking their time with that though.
    Anyways, that'll tell you why, and how to take care of it.
    The netgear I'm using at the moment is a model WGR614 from wal-mart for 30 bucks and it works fine.
    Threw it in-line with my belkin and pushed a wifi signal through it so now I've got a b (I have legacy laptops :p) , G, n-draft, and N 300&750 signal floating through my house...kinda worried I'm going to cause extensive radioactive dmg to my newborn, but oh well, that's the cost she pays for having me as a father :p

Share This Page